summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/aws-as-tools')
-rw-r--r--app-admin/aws-as-tools/Manifest1
-rw-r--r--app-admin/aws-as-tools/aws-as-tools-1.0.49.1.ebuild64
-rw-r--r--app-admin/aws-as-tools/metadata.xml13
3 files changed, 78 insertions, 0 deletions
diff --git a/app-admin/aws-as-tools/Manifest b/app-admin/aws-as-tools/Manifest
new file mode 100644
index 000000000000..1c451137e02b
--- /dev/null
+++ b/app-admin/aws-as-tools/Manifest
@@ -0,0 +1 @@
+DIST AutoScaling-1.0.49.1.zip 12387808 SHA256 8273186a025c465ca3b69523c50f114dc6c2cececb2c9e8b8d6c6eb886dd97a3 SHA512 aefc4dfc970757062ca972c5d532485c9e28ceb771b6fa0a4fb2fe25460bd67e3023bcefde57f9852340b6015e7ab2771c49beb0826e1394710ea7eea94948ed WHIRLPOOL 99c6daa8d5cfa00d26cc43c03406824897e960b1d13d49540a4e8f829d8abba18bd15f1e63a67f9e408973eb74af59ed3769f2aad806496ed163bcbd13f1df1d
diff --git a/app-admin/aws-as-tools/aws-as-tools-1.0.49.1.ebuild b/app-admin/aws-as-tools/aws-as-tools-1.0.49.1.ebuild
new file mode 100644
index 000000000000..e2005bb81785
--- /dev/null
+++ b/app-admin/aws-as-tools/aws-as-tools-1.0.49.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+DESCRIPTION="The API tools serve as the client interface to the Auto Scaling web service"
+HOMEPAGE="http://aws.amazon.com/developertools/2535"
+# SRC_URI="http://ec2-downloads.s3.amazonaws.com/AutoScaling-2011-01-01.zip"
+SRC_URI="mirror://sabayon/app-admin/AutoScaling-1.0.49.1.zip"
+
+S="${WORKDIR}/AutoScaling-${PV}"
+
+LICENSE="Amazon"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND="app-arch/unzip"
+RDEPEND="virtual/jre"
+RESTRICT="mirror"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ find . -name '*.cmd' -delete || die
+ rm bin/as-cmd-2009-05-15
+ rm bin/service-2009-05-15
+}
+
+src_install() {
+ dodir /opt/${PN}
+ insinto /opt/${PN}/lib
+ doins -r "${S}"/lib/*
+ exeinto /opt/${PN}/bin
+ doexe "${S}"/bin/*
+
+ dodir /etc/env.d
+ cat - > "${T}"/99${PN} <<EOF
+AWS_AUTO_SCALING_HOME=/opt/${PN}
+PATH=/opt/${PN}/bin
+ROOTPATH=/opt/${PN}/bin
+EOF
+ doenvd "${T}"/99${PN}
+
+ dodoc "THIRDPARTYLICENSE.TXT"
+}
+
+pkg_postinst() {
+ ewarn "Remember to run: env-update && source /etc/profile if you plan"
+ ewarn "to use these tools in a shell before logging out (or restarting"
+ ewarn "your login manager)"
+ elog
+ elog "You need to put the following in your ~/.bashrc replacing the"
+ elog "values with the full path to your AWS credentials file."
+ elog
+ elog " export AWS_CREDENTIAL_FILE=/path/and_filename_of_credential_file"
+ elog
+ elog "It should contains two lines: the first line lists the AWS Account's"
+ elog "AWS Access Key ID, and the second line lists the AWS Account's"
+ elog "Secret Access Key. For example:"
+ elog
+ elog " AWSAccessKeyId=AKIAIOSFODNN7EXAMPLE"
+ elog " AWSSecretKey=wJalrXUtnFEMI/K7MDENG/bPxRfiCYzEXAMPLEKEY"
+}
diff --git a/app-admin/aws-as-tools/metadata.xml b/app-admin/aws-as-tools/metadata.xml
new file mode 100644
index 000000000000..1a971abe53b5
--- /dev/null
+++ b/app-admin/aws-as-tools/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>lxnay@gentoo.org</email>
+ </maintainer>
+ <maintainer>
+ <email>sergey.zhuga@gmail.com</email>
+ <name>Sergey Zhuga</name>
+ <description>Proxy maintainers. CC him on bugs</description>
+ </maintainer>
+</pkgmetadata>