summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/cdist/cdist-6.9.8.ebuild')
-rw-r--r--app-admin/cdist/cdist-6.9.8.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/app-admin/cdist/cdist-6.9.8.ebuild b/app-admin/cdist/cdist-6.9.8.ebuild
index 1dae10c0230a..4e75b661c296 100644
--- a/app-admin/cdist/cdist-6.9.8.ebuild
+++ b/app-admin/cdist/cdist-6.9.8.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{9..10} )
+
DISTUTILS_USE_SETUPTOOLS=no
inherit distutils-r1
@@ -17,7 +18,9 @@ LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-distutils_enable_sphinx docs/src dev-python/sphinx_rtd_theme
+PATCHES=( "${FILESDIR}"/test.patch )
+
+distutils_enable_sphinx docs/src dev-python/sphinx-rtd-theme
distutils_enable_tests unittest
python_prepare_all() {