summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/chrpath')
-rw-r--r--app-admin/chrpath/Manifest1
-rw-r--r--app-admin/chrpath/chrpath-0.13-r2.ebuild42
-rw-r--r--app-admin/chrpath/chrpath-0.16-r1.ebuild (renamed from app-admin/chrpath/chrpath-0.16.ebuild)15
-rw-r--r--app-admin/chrpath/files/chrpath-0.13-multilib.patch160
-rw-r--r--app-admin/chrpath/files/chrpath-0.13-testsuite-1.patch19
-rw-r--r--app-admin/chrpath/files/chrpath-keepgoing.patch20
-rw-r--r--app-admin/chrpath/metadata.xml2
7 files changed, 5 insertions, 254 deletions
diff --git a/app-admin/chrpath/Manifest b/app-admin/chrpath/Manifest
index 4532e0e45797..e24ed2c8fd6f 100644
--- a/app-admin/chrpath/Manifest
+++ b/app-admin/chrpath/Manifest
@@ -1,2 +1 @@
-DIST chrpath-0.13.tar.gz 125129 BLAKE2B 004db7e3567ceeb700d018e7e32036843413605466c218bf40252927b169775c5a86f81f8ea355f0d141821313d114ec24654ed62d75443e31739118e31bc497 SHA512 9ec2ab2731fb553497996939b421130ae221d478dab8887c184ae91f7d3ae697688e7a30e3bea30cc0cf765f1dc8c7f47d2a1f4369b36079b4033e8d0303d75e
DIST chrpath-0.16.tar.gz 134506 BLAKE2B 7003cc1cb2332ffbe6fe0873c6d30cbc3ea696e041be33b39c3d36ae34a2497b8dd40bb373773c546b8d63cfd8534e796fd7d7cbc99d37fb8751fc960907070f SHA512 aa04d490f78bff20a56fe20539cec10218c0772a668909eda8324ca825f51e8ef92001e95d9c316e79a145a043c9c327ec94d1a82e104ab408ca1021832745aa
diff --git a/app-admin/chrpath/chrpath-0.13-r2.ebuild b/app-admin/chrpath/chrpath-0.13-r2.ebuild
deleted file mode 100644
index 89d26b3b7e07..000000000000
--- a/app-admin/chrpath/chrpath-0.13-r2.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools
-
-DESCRIPTION="Chrpath can modify the rpath and runpath of ELF executables"
-HOMEPAGE="https://directory.fsf.org/wiki/Chrpath"
-# original upstream no longer exists (ftp://ftp.hungry.com/pub/hungry)
-SRC_URI="https://alioth-archive.debian.org/releases/${PN}/${PN}/${PV}/${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 arm ~mips ppc ppc64 x86 ~amd64-linux ~x86-linux ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="static-libs"
-
-PATCHES=(
- "${FILESDIR}"/${P}-multilib.patch
- "${FILESDIR}"/${PN}-keepgoing.patch
- "${FILESDIR}"/${P}-testsuite-1.patch
-)
-
-src_prepare() {
- default
- # disable installing redundant docs in the wrong dir
- sed -i -e '/doc_DATA/d' Makefile.am || die
- # fix for automake-1.13, #467538
- sed -i -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' configure.ac || die
- eautoreconf
-}
-
-src_configure() {
- econf $(use_enable static-libs static)
-}
-
-src_install() {
- default
- if ! use static-libs; then
- find "${D}" -name "*.la" -delete || die
- fi
-}
diff --git a/app-admin/chrpath/chrpath-0.16.ebuild b/app-admin/chrpath/chrpath-0.16-r1.ebuild
index a985ffe96003..2018b65c7b1e 100644
--- a/app-admin/chrpath/chrpath-0.16.ebuild
+++ b/app-admin/chrpath/chrpath-0.16-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools
@@ -11,8 +11,7 @@ SRC_URI="https://alioth-archive.debian.org/releases/${PN}/${PN}/${PV}/${P}.tar.g
LICENSE="GPL-2+"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="static-libs"
+KEYWORDS="amd64 arm ~arm64 ~mips ppc ppc64 ~riscv x86 ~amd64-linux ~x86-linux ~x64-solaris"
PATCHES=(
"${FILESDIR}"/${P}-multilib.patch
@@ -29,13 +28,7 @@ src_prepare() {
eautoreconf
}
-src_configure() {
- econf $(use_enable static-libs static)
-}
-
src_install() {
default
- if ! use static-libs; then
- find "${D}" -name "*.la" -delete || die
- fi
+ find "${ED}" -name '*.la' -delete || die
}
diff --git a/app-admin/chrpath/files/chrpath-0.13-multilib.patch b/app-admin/chrpath/files/chrpath-0.13-multilib.patch
deleted file mode 100644
index e7db0a124053..000000000000
--- a/app-admin/chrpath/files/chrpath-0.13-multilib.patch
+++ /dev/null
@@ -1,160 +0,0 @@
-Index: chrpath-0.13/Makefile.am
-===================================================================
---- chrpath-0.13.orig/Makefile.am
-+++ chrpath-0.13/Makefile.am
-@@ -12,12 +12,19 @@ debs:
- fakeroot debian/rules binary
-
- chrpath_SOURCES = \
-- chrpath.c \
-- killrpath.c \
- main.c \
-- elf.c \
- protos.h
-
-+chrpath_LDADD = $(LDLIBS)
-+
-+lib_LTLIBRARIES = libchrpath32.la libchrpath64.la
-+libchrpath32_la_SOURCES = chrpath.c killrpath.c elf.c protos.h
-+libchrpath32_la_CFLAGS = -DSIZEOF_VOID_P=4
-+libchrpath32_la_LDFLAGS = -avoid-version
-+libchrpath64_la_SOURCES = chrpath.c killrpath.c elf.c protos.h
-+libchrpath64_la_CFLAGS = -DSIZEOF_VOID_P=8
-+libchrpath64_la_LDFLAGS = -avoid-version
-+
- EXTRA_DIST = ChangeLog.usermap $(man_MANS)
-
- CLEANFILES = *.bb *.bbg *.da *.gcov testsuite/*.bb testsuite/*.bbg
-Index: chrpath-0.13/configure.ac
-===================================================================
---- chrpath-0.13.orig/configure.ac
-+++ chrpath-0.13/configure.ac
-@@ -16,6 +16,7 @@ CHRPATH_LDRPATH_OPTION
- dnl Checks for programs.
- AC_PROG_CC
- AC_PROG_INSTALL
-+AC_PROG_LIBTOOL
-
- dnl Checks for libraries.
-
-@@ -26,11 +27,19 @@ AC_CHECK_HEADERS([getopt.h elf.h fcntl.h
- dnl Checks for typedefs, structures, and compiler characteristics.
- AC_C_CONST
- AC_C_BIGENDIAN
--AC_CHECK_SIZEOF(void *)
-
- dnl Checks for library functions.
- AC_CHECK_FUNCS(getopt_long)
-
-+dnl See if we need -ldl on this platform for dlopen
-+LDLIBS=
-+save_LIBS="$LIBS"
-+LIBS=
-+AC_SEARCH_LIBS([dlopen], [dl])
-+LDLIBS=${LIBS}
-+LIBS="${save_LIBS}"
-+AC_SUBST([LDLIBS])
-+
- if eval "test x$GCC = xyes"; then
- for flag in \
- -ansi \
-Index: chrpath-0.13/main.c
-===================================================================
---- chrpath-0.13.orig/main.c
-+++ chrpath-0.13/main.c
-@@ -12,13 +12,19 @@
- # include "config.h"
- #endif
-
-+#include <dlfcn.h>
-+#include <elf.h>
-+#include <fcntl.h>
- #include <stdio.h>
- #include <stdlib.h>
-+#include <string.h>
- #include <unistd.h>
- #ifdef HAVE_GETOPT_H
- #include <getopt.h>
- #endif
--#include "protos.h"
-+
-+typedef int (*killrpath_t)(const char *filename);
-+typedef int (*chrpath_t)(const char *filename, const char *newpath, int convert);
-
- #ifdef HAVE_GETOPT_LONG
- # define GETOPT_LONG getopt_long
-@@ -61,6 +67,30 @@ usage(char *progname)
- printf("\n");
- }
-
-+static unsigned
-+elf_class(const char *filename)
-+{
-+ Elf32_Ehdr ehdr;
-+ int fd;
-+
-+ fd = open(filename, O_RDONLY);
-+ if (fd == -1)
-+ return 0;
-+ if (read(fd, &ehdr, sizeof(ehdr)) != sizeof(ehdr))
-+ {
-+ close(fd);
-+ return 0;
-+ }
-+ close(fd);
-+ if ((memcmp(ehdr.e_ident, ELFMAG, SELFMAG) != 0)
-+ || (ehdr.e_ident[EI_VERSION] != EV_CURRENT))
-+ {
-+ fprintf(stderr, "`%s' probably isn't an ELF file.\n", filename);
-+ return 0;
-+ }
-+ return ehdr.e_ident[EI_CLASS];
-+}
-+
- int
- main(int argc, char * const argv[])
- {
-@@ -73,6 +103,9 @@ main(int argc, char * const argv[])
- #ifdef HAVE_GETOPT_LONG
- int option_index = 0;
- #endif /* HAVE_GETOPT_LONG */
-+ void* dll[2];
-+ killrpath_t killrpath[2];
-+ chrpath_t chrpath[2];
-
- if (argc < 2)
- {
-@@ -116,14 +149,31 @@ main(int argc, char * const argv[])
- }
- } while (-1 != opt);
-
-+ dll[0] = dlopen("libchrpath32.so", RTLD_LAZY);
-+ killrpath[0] = (killrpath_t)dlsym(dll[0], "killrpath");
-+ chrpath[0] = (chrpath_t)dlsym(dll[0], "chrpath");
-+
-+ dll[1] = dlopen("libchrpath64.so", RTLD_LAZY);
-+ killrpath[1] = (killrpath_t)dlsym(dll[1], "killrpath");
-+ chrpath[1] = (chrpath_t)dlsym(dll[1], "chrpath");
-+
- while (optind < argc && (!retval || keep_going))
- {
-+ const char* program = argv[optind++];
-+ unsigned eclass = elf_class(program);
-+ if (!eclass)
-+ {
-+ retval = 1;
-+ continue;
-+ }
- if (remove)
-- retval |= killrpath(argv[optind++]);
-+ retval |= killrpath[eclass - ELFCLASS32](program);
- else
- /* list by default, replace if path is set */
-- retval |= chrpath(argv[optind++], newpath, convert);
-+ retval |= chrpath[eclass - ELFCLASS32](program, newpath, convert);
- }
-
-+ dlclose(dll[0]);
-+ dlclose(dll[1]);
- return retval;
- }
diff --git a/app-admin/chrpath/files/chrpath-0.13-testsuite-1.patch b/app-admin/chrpath/files/chrpath-0.13-testsuite-1.patch
deleted file mode 100644
index 1a30ce1eb94a..000000000000
--- a/app-admin/chrpath/files/chrpath-0.13-testsuite-1.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-Submitted By: Mario Fetka (geos_one) (mario dot fetka at gmail dot com)
-Date: 2010-04-04
-Initial Package Version: 0.13
-Origin: me
-Upstream Status: unknown
-Description: make the testsuite run with the new mltilib design
-
-diff -Naur chrpath-0.13.orig/testsuite/runtest.sh chrpath-0.13/testsuite/runtest.sh
---- chrpath-0.13.orig/testsuite/runtest.sh 2010-04-04 09:02:21.859114159 +0000
-+++ chrpath-0.13/testsuite/runtest.sh 2010-04-04 09:42:08.762112560 +0000
-@@ -2,6 +2,8 @@
-
- set -x
-
-+export LD_LIBRARY_PATH=$PWD/../.libs:$LD_LIBRARY_PATH
-+
- CHRPATH=../chrpath
-
- retval=0
diff --git a/app-admin/chrpath/files/chrpath-keepgoing.patch b/app-admin/chrpath/files/chrpath-keepgoing.patch
deleted file mode 100644
index d8f6965729ff..000000000000
--- a/app-admin/chrpath/files/chrpath-keepgoing.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- chrpath-0.13/main.c.orig 2006-02-27 20:21:06.000000000 +0100
-+++ chrpath-0.13/main.c 2006-02-27 21:07:16.027641500 +0100
-@@ -57,6 +57,7 @@
- printf(" -r <path>|--replace <path> Replace current rpath/runpath setting\n");
- printf(" with the path given\n");
- printf(" -l|--list List the current rpath/runpath (default)\n");
-+ printf(" -k|--keepgoing Continue as much as possible after an error.\n");
- printf(" -h|--help Show this usage information.\n");
- #ifndef HAVE_GETOPT_LONG
- printf("\n *** The long options are not available on this platform");
---- chrpath-0.13/chrpath.1.orig 2004-09-19 10:35:44.000000000 +0200
-+++ chrpath-0.13/chrpath.1 2006-02-28 10:06:28.187060500 +0100
-@@ -22,6 +22,7 @@
- [ \fB-r\fP \fI<path>\fP |\ \fB--replace\fP \fI<path>\fP ]
- [ \fB-c\fP | \fB--convert\fP ]
- [ \fB-l\fP | \fB--list\fP ]
-+[ \fB-k\fP | \fB--keepgoing\fP ]
- [ \fB-h\fP | \fB--help\fP ]
- \fI<program>\fP [ \fI<program>\fP ... ]
- .SH DESCRIPTION
diff --git a/app-admin/chrpath/metadata.xml b/app-admin/chrpath/metadata.xml
index 7b9e1c3f2223..f38edee4ac89 100644
--- a/app-admin/chrpath/metadata.xml
+++ b/app-admin/chrpath/metadata.xml
@@ -4,7 +4,7 @@
<maintainer type="person">
<email>grobian@gentoo.org</email>
</maintainer>
-<maintainer type="project">
+ <maintainer type="project">
<email>prefix@gentoo.org</email>
<name>Gentoo Prefix</name>
</maintainer>