summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/clog')
-rw-r--r--app-admin/clog/clog-1.3.0-r1.ebuild24
-rw-r--r--app-admin/clog/clog-1.3.0.ebuild14
-rw-r--r--app-admin/clog/files/clog-1.3.0-gcc13.patch11
-rw-r--r--app-admin/clog/metadata.xml10
4 files changed, 40 insertions, 19 deletions
diff --git a/app-admin/clog/clog-1.3.0-r1.ebuild b/app-admin/clog/clog-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..cc6689579c1b
--- /dev/null
+++ b/app-admin/clog/clog-1.3.0-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="clog is a colorized log tail utility"
+HOMEPAGE="https://taskwarrior.org/docs/clog/"
+SRC_URI="https://gothenburgbitfactory.org/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+RESTRICT="test" # No test suite on tar.gz
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.3.0-gcc13.patch
+)
+
+src_prepare() {
+ sed -i -e 's|share/doc/clog|share/clog|' CMakeLists.txt || die
+ cmake_src_prepare
+}
diff --git a/app-admin/clog/clog-1.3.0.ebuild b/app-admin/clog/clog-1.3.0.ebuild
deleted file mode 100644
index 238bf2e43f37..000000000000
--- a/app-admin/clog/clog-1.3.0.ebuild
+++ /dev/null
@@ -1,14 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils
-
-DESCRIPTION="clog is a colorized log tail utility"
-HOMEPAGE="https://taskwarrior.org/docs/clog/"
-SRC_URI="https://tasktools.org/download/${P}.tar.gz"
-
-KEYWORDS="~amd64 ~x86 ~x64-macos"
-LICENSE="MIT"
-SLOT="0"
diff --git a/app-admin/clog/files/clog-1.3.0-gcc13.patch b/app-admin/clog/files/clog-1.3.0-gcc13.patch
new file mode 100644
index 000000000000..3bdbc464a90e
--- /dev/null
+++ b/app-admin/clog/files/clog-1.3.0-gcc13.patch
@@ -0,0 +1,11 @@
+https://github.com/GothenburgBitFactory/libshared/pull/71
+--- a/src/libshared/src/JSON2.h
++++ b/src/libshared/src/JSON2.h
+@@ -27,6 +27,7 @@
+ #ifndef INCLUDED_JSON2
+ #define INCLUDED_JSON2
+
++#include <cstdint>
+ #include <string>
+
+ class JSON2
diff --git a/app-admin/clog/metadata.xml b/app-admin/clog/metadata.xml
index 143be88f0726..e7c3b330a17a 100644
--- a/app-admin/clog/metadata.xml
+++ b/app-admin/clog/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>alicef@gentoo.org</email>
- <name>Alice Ferrazzi</name>
- </maintainer>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="github">GothenburgBitFactory/clog</remote-id>
+ </upstream>
</pkgmetadata>