summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/clsync/clsync-9999.ebuild')
-rw-r--r--app-admin/clsync/clsync-9999.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/app-admin/clsync/clsync-9999.ebuild b/app-admin/clsync/clsync-9999.ebuild
index 3c91bb41d6fe..f97b3e7c2752 100644
--- a/app-admin/clsync/clsync-9999.ebuild
+++ b/app-admin/clsync/clsync-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -19,7 +19,7 @@ LICENSE="GPL-3+"
SLOT="0"
IUSE="apidoc +caps +clsync cluster control-socket cgroups doc debug
examples extra-debug extra-hardened gio +hardened +highload-locks
-+inotify +lto mhash namespaces seccomp socket-library static-libs"
++inotify mhash namespaces seccomp socket-library static-libs"
REQUIRED_USE="
|| ( clsync socket-library )
@@ -29,7 +29,7 @@ REQUIRED_USE="
"
BDEPEND="
virtual/pkgconfig
- apidoc? ( app-doc/doxygen[dot] )
+ apidoc? ( app-text/doxygen[dot] )
"
DEPEND="
caps? ( sys-libs/libcap )
@@ -65,7 +65,9 @@ src_configure() {
use debug && debug_level=1
use extra-debug && debug_level=2
+ # --enable-lto just appends -flto
econf \
+ --disable-lto \
--enable-debug=${debug_level} \
--enable-paranoid=${harden_level} \
--without-bsm \
@@ -75,7 +77,6 @@ src_configure() {
$(use_enable cluster) \
$(use_enable control-socket socket) \
$(use_enable highload-locks) \
- $(use_enable lto) \
$(use_enable namespaces unshare) \
$(use_enable seccomp) \
$(use_enable socket-library) \