summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/clsync')
-rw-r--r--app-admin/clsync/clsync-0.4.5.ebuild9
-rw-r--r--app-admin/clsync/clsync-9999.ebuild9
-rw-r--r--app-admin/clsync/metadata.xml10
3 files changed, 13 insertions, 15 deletions
diff --git a/app-admin/clsync/clsync-0.4.5.ebuild b/app-admin/clsync/clsync-0.4.5.ebuild
index 239047ab2b24..84dc0971fc9d 100644
--- a/app-admin/clsync/clsync-0.4.5.ebuild
+++ b/app-admin/clsync/clsync-0.4.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -19,7 +19,7 @@ LICENSE="GPL-3+"
SLOT="0"
IUSE="apidoc +caps +clsync cluster control-socket cgroups doc debug
examples extra-debug extra-hardened gio +hardened +highload-locks
-+inotify +lto mhash namespaces seccomp socket-library static-libs"
++inotify mhash namespaces seccomp socket-library static-libs"
REQUIRED_USE="
|| ( clsync socket-library )
@@ -29,7 +29,7 @@ REQUIRED_USE="
"
BDEPEND="
virtual/pkgconfig
- apidoc? ( app-doc/doxygen[dot] )
+ apidoc? ( app-text/doxygen[dot] )
"
DEPEND="
caps? ( sys-libs/libcap )
@@ -65,7 +65,9 @@ src_configure() {
use debug && debug_level=1
use extra-debug && debug_level=2
+ # --enable-lto just appends -flto
econf \
+ --disable-lto \
--enable-debug=${debug_level} \
--enable-paranoid=${harden_level} \
--without-bsm \
@@ -75,7 +77,6 @@ src_configure() {
$(use_enable cluster) \
$(use_enable control-socket socket) \
$(use_enable highload-locks) \
- $(use_enable lto) \
$(use_enable namespaces unshare) \
$(use_enable seccomp) \
$(use_enable socket-library) \
diff --git a/app-admin/clsync/clsync-9999.ebuild b/app-admin/clsync/clsync-9999.ebuild
index 3c91bb41d6fe..f97b3e7c2752 100644
--- a/app-admin/clsync/clsync-9999.ebuild
+++ b/app-admin/clsync/clsync-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -19,7 +19,7 @@ LICENSE="GPL-3+"
SLOT="0"
IUSE="apidoc +caps +clsync cluster control-socket cgroups doc debug
examples extra-debug extra-hardened gio +hardened +highload-locks
-+inotify +lto mhash namespaces seccomp socket-library static-libs"
++inotify mhash namespaces seccomp socket-library static-libs"
REQUIRED_USE="
|| ( clsync socket-library )
@@ -29,7 +29,7 @@ REQUIRED_USE="
"
BDEPEND="
virtual/pkgconfig
- apidoc? ( app-doc/doxygen[dot] )
+ apidoc? ( app-text/doxygen[dot] )
"
DEPEND="
caps? ( sys-libs/libcap )
@@ -65,7 +65,9 @@ src_configure() {
use debug && debug_level=1
use extra-debug && debug_level=2
+ # --enable-lto just appends -flto
econf \
+ --disable-lto \
--enable-debug=${debug_level} \
--enable-paranoid=${harden_level} \
--without-bsm \
@@ -75,7 +77,6 @@ src_configure() {
$(use_enable cluster) \
$(use_enable control-socket socket) \
$(use_enable highload-locks) \
- $(use_enable lto) \
$(use_enable namespaces unshare) \
$(use_enable seccomp) \
$(use_enable socket-library) \
diff --git a/app-admin/clsync/metadata.xml b/app-admin/clsync/metadata.xml
index 39a9cda50e2d..b151837c352f 100644
--- a/app-admin/clsync/metadata.xml
+++ b/app-admin/clsync/metadata.xml
@@ -1,10 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>bircoph@gentoo.org</email>
- <name>Andrew Savchenko</name>
- </maintainer>
+ <!-- maintainer-needed -->
<longdescription>
Clsync recursively watches for source directory and executes external
program to sync the changes. Clsync is adapted to be used together with rsync.
@@ -13,7 +10,7 @@
and multicast notifing clsync instances on another nodes to prevent loop
syncing. Clsync can use advanced features for isolation: capabilities, cgroups,
namespaces, seccomp, code hardening.
-</longdescription>
+ </longdescription>
<use>
<flag name="apidoc">Provide doxygen generated API docs.</flag>
<flag name="clsync">Build clsync binary. Most likely you want it. However it is possible to build only libclsync without clsync itself. </flag>
@@ -24,7 +21,6 @@
<flag name="extra-hardened">Enable extra security checks. This will hurt performance.</flag>
<flag name="gio">Enable GIO for FS monitoring (glib based alternative to inotify interface, not recommended; if both are compiled, may be selected at runtime).</flag>
<flag name="highload-locks">Allows to use spinlocks for short delays instead of mutexes, but only on SMP systems.</flag>
- <flag name="lto">Build with link time optimization (LTO).</flag>
<flag name="namespaces">Enable namespaces isolation.</flag>
<flag name="socket-library">Build the control and monitoring socket library: libclsync.</flag>
</use>