summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/clustershell')
-rw-r--r--app-admin/clustershell/Manifest2
-rw-r--r--app-admin/clustershell/clustershell-1.8.3-r1.ebuild44
-rw-r--r--app-admin/clustershell/clustershell-1.9.2.ebuild61
-rw-r--r--app-admin/clustershell/metadata.xml5
4 files changed, 65 insertions, 47 deletions
diff --git a/app-admin/clustershell/Manifest b/app-admin/clustershell/Manifest
index 6f30a4d35adf..6a70beb978ec 100644
--- a/app-admin/clustershell/Manifest
+++ b/app-admin/clustershell/Manifest
@@ -1 +1 @@
-DIST clustershell-1.8.3.tar.gz 363975 BLAKE2B 3a7bb9103398e96f57f53d0d5d5edc6895ce02b6983e8fed34d65cad83a6d4e86f40b9576f41631e499a99adc8be5f4f422005b8ddc7ac8325fe11abd2c99477 SHA512 5108773e2958d1dae0aa6966d764e9af9d41024f65271005b202468f2bd1a3b63acc977729324fe1305d400dc8b06b0c4672e8d8ded207fa77cef69fb0005108
+DIST ClusterShell-1.9.2.tar.gz 400880 BLAKE2B d10c78696268cabd001e1da1c28f1850d6b2fd9d20e73f9aeab378c855a0b937f32d706869e2d3fcdf109b2e98175abbec8f06fe0c6d2c4139d2da14f1c5b610 SHA512 852c9dcbe333965fa853e4360da7305c448dc037348ede18c0417d763e68d4bafad0a60480fce421f1815a86dd0a20e07d32fd8828aa185e7e1b88ed292014fc
diff --git a/app-admin/clustershell/clustershell-1.8.3-r1.ebuild b/app-admin/clustershell/clustershell-1.8.3-r1.ebuild
deleted file mode 100644
index 53371ad3d6a7..000000000000
--- a/app-admin/clustershell/clustershell-1.8.3-r1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8,9} )
-PYTHON_REQ_USE="xml"
-
-inherit distutils-r1
-
-DESCRIPTION="Python framework for efficient cluster administration"
-HOMEPAGE="https://cea-hpc.github.com/clustershell/"
-SRC_URI="https://github.com/cea-hpc/clustershell/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-2.1+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-BDEPEND="
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-RDEPEND="
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-libs/openssl:0="
-
-RESTRICT="test" # currently fail
-
-python_install() {
- distutils-r1_python_install
- python_optimize
-}
-
-python_test() {
- cd tests || die
- nosetests -sv --all-modules || die
-}
-
-pkg_postinst() {
- einfo
- einfo "Some default system-wide config files have been installed into"
- einfo "/etc/${PN}"
- einfo
-}
diff --git a/app-admin/clustershell/clustershell-1.9.2.ebuild b/app-admin/clustershell/clustershell-1.9.2.ebuild
new file mode 100644
index 000000000000..30dcc094b0f4
--- /dev/null
+++ b/app-admin/clustershell/clustershell-1.9.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=ClusterShell
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python framework for efficient cluster administration"
+HOMEPAGE="
+ https://github.com/cea-hpc/clustershell/
+ https://pypi.org/project/ClusterShell/
+"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+
+RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ app-shells/pdsh
+ virtual/openssh
+ app-alternatives/bc
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ default
+
+ # remove test sets that require working ssh connection
+ rm tests/{CLIClush,TaskDistant*}Test.py || die
+}
+
+python_test() {
+ cd tests || die
+ local runner=unittest_or_fail
+ if [[ ${EPYTHON} == python3.12 ]]; then
+ runner=unittest
+ fi
+ # Automatic discovery does not work
+ "${EPYTHON}" -m "${runner}" -v *.py || die "Tests failed with ${EPYTHON}"
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}
+
+pkg_postinst() {
+ einfo "Some default system-wide config files have been installed into"
+ einfo "/etc/${PN}"
+}
diff --git a/app-admin/clustershell/metadata.xml b/app-admin/clustershell/metadata.xml
index 596520c245e8..6589872592ea 100644
--- a/app-admin/clustershell/metadata.xml
+++ b/app-admin/clustershell/metadata.xml
@@ -2,10 +2,11 @@
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
- <email>monsieurp@gentoo.org</email>
- <name>Patrice Clement</name>
+ <email>arkamar@gentoo.org</email>
+ <name>Petr Vaněk</name>
</maintainer>
<upstream>
+ <remote-id type="pypi">ClusterShell</remote-id>
<remote-id type="github">cea-hpc/clustershell</remote-id>
</upstream>
</pkgmetadata>