summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/conky/files')
-rw-r--r--app-admin/conky/files/conky-1.10.8-clang.patch30
-rw-r--r--app-admin/conky/files/conky-1.10.8-fpermissive.patch14
-rw-r--r--app-admin/conky/files/conky-1.10.8-libical-3.patch32
-rw-r--r--app-admin/conky/files/conky-1.10.8-portmon.patch20
-rw-r--r--app-admin/conky/files/conky-1.10.8-use-pkgconfig.patch34
-rw-r--r--app-admin/conky/files/conky-1.10.8-virtual-sinks.patch49
-rw-r--r--app-admin/conky/files/conky-1.11.6-fpermissive.patch29
-rw-r--r--app-admin/conky/files/conky-1.11.6-ipv6.patch22
8 files changed, 0 insertions, 230 deletions
diff --git a/app-admin/conky/files/conky-1.10.8-clang.patch b/app-admin/conky/files/conky-1.10.8-clang.patch
deleted file mode 100644
index 2fc49fa9cf25..000000000000
--- a/app-admin/conky/files/conky-1.10.8-clang.patch
+++ /dev/null
@@ -1,30 +0,0 @@
---- conky-1.10.8/src/linux.cc 2018-02-07 17:16:39.000000000 +0300
-+++ conky-1.10.8.new/src/linux.cc 2020-02-22 00:43:52.336620654 +0300
-@@ -37,6 +37,7 @@
- #include <ctype.h>
- #include <errno.h>
- #include <limits.h>
-+#include <clocale>
- #include <sys/types.h>
- #include <sys/sysinfo.h>
- #include <sys/stat.h>
---- conky-1.10.8/src/luamm.cc 2020-02-22 00:57:25.847867585 +0300
-+++ conky-1.10.8.new/src/luamm.cc 2020-02-22 00:59:29.820510124 +0300
-@@ -23,6 +23,8 @@
-
- #include "luamm.hh"
-
-+#include <cxxabi.h>
-+
- namespace lua {
- namespace {
-
-@@ -57,7 +59,7 @@
- lua_pushstring(l, e.what());
- }
- catch(...) {
-- lua_pushstring(l, ptr->__cxa_exception_type()->name());
-+ lua_pushstring(l, abi::__cxa_current_exception_type()->name());
- }
- return 1;
- }
diff --git a/app-admin/conky/files/conky-1.10.8-fpermissive.patch b/app-admin/conky/files/conky-1.10.8-fpermissive.patch
deleted file mode 100644
index 42abeb831cd6..000000000000
--- a/app-admin/conky/files/conky-1.10.8-fpermissive.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- conky-1.10.8/src/conky.cc.orig 2020-08-28 13:17:22.330113596 -0400
-+++ conky-1.10.8/src/conky.cc 2020-08-28 13:19:48.564891015 -0400
-@@ -478,9 +478,9 @@
- struct MHD_Daemon *httpd;
- static conky::simple_config_setting<bool> http_refresh("http_refresh", false, true);
-
--int sendanswer(void *cls, struct MHD_Connection *connection, const char *url, const char *method, const char *version, const char *upload_data, size_t *upload_data_size, void **con_cls) {
-+MHD_Result sendanswer(void *cls, struct MHD_Connection *connection, const char *url, const char *method, const char *version, const char *upload_data, size_t *upload_data_size, void **con_cls) {
- struct MHD_Response *response = MHD_create_response_from_data(webpage.length(), (void*) webpage.c_str(), MHD_NO, MHD_NO);
-- int ret = MHD_queue_response (connection, MHD_HTTP_OK, response);
-+ MHD_Result ret = MHD_queue_response (connection, MHD_HTTP_OK, response);
- MHD_destroy_response(response);
- if(cls || url || method || version || upload_data || upload_data_size || con_cls) {} //make compiler happy
- return ret;
diff --git a/app-admin/conky/files/conky-1.10.8-libical-3.patch b/app-admin/conky/files/conky-1.10.8-libical-3.patch
deleted file mode 100644
index 032a6d2ef263..000000000000
--- a/app-admin/conky/files/conky-1.10.8-libical-3.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 128c8cce3415839a3d19a5cb877fd77af2538d35 Mon Sep 17 00:00:00 2001
-From: Adam Majer <amajer@suse.de>
-Date: Tue, 6 Mar 2018 13:46:31 +0100
-Subject: [PATCH] Add support for libical 3.x (#465)
-
-In libical3, deprecated icaltime_from_timet is removed
-Use icaltime_from_timet_with_zone instead. This function
-exists in libical 2.x so no need to change requirements
----
- src/ical.cc | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/ical.cc b/src/ical.cc
-index e4b48511..ef069124 100644
---- a/src/ical.cc
-+++ b/src/ical.cc
-@@ -49,13 +49,13 @@ struct ical_event *add_event(struct ical_event *listend, icalcomponent *new_ev)
- icaltimetype start;
-
- start = icalcomponent_get_dtstart(new_ev);
-- if(icaltime_compare(start, icaltime_from_timet(time(NULL), 0)) <= 0) {
-+ if(icaltime_compare(start, icaltime_from_timet_with_zone(time(NULL), 0, NULL)) <= 0) {
- icalproperty *rrule = icalcomponent_get_first_property(new_ev, ICAL_RRULE_PROPERTY);
- if(rrule) {
- icalrecur_iterator* ritr = icalrecur_iterator_new(icalproperty_get_rrule(rrule), start);
- icaltimetype nexttime = icalrecur_iterator_next(ritr);
- while (!icaltime_is_null_time(nexttime)) {
-- if(icaltime_compare(nexttime, icaltime_from_timet(time(NULL), 0)) > 0) {
-+ if(icaltime_compare(nexttime, icaltime_from_timet_with_zone(time(NULL), 0, NULL)) > 0) {
- start = nexttime;
- break;
- }
diff --git a/app-admin/conky/files/conky-1.10.8-portmon.patch b/app-admin/conky/files/conky-1.10.8-portmon.patch
deleted file mode 100644
index e7b17dd1119a..000000000000
--- a/app-admin/conky/files/conky-1.10.8-portmon.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- conky-1.10.8/src/CMakeLists.txt 2019-03-09 08:24:26.315879386 +0100
-+++ conky-1.10.8/src/CMakeLists.txt 2019-03-09 08:24:38.555878656 +0100
-@@ -220,6 +220,15 @@
- install(TARGETS
- conky
- RUNTIME DESTINATION bin
-- LIBRARY DESTINATION lib
-- ARCHIVE DESTINATION lib
-+ LIBRARY DESTINATION ${LIB_INSTALL_DIR}
-+ ARCHIVE DESTINATION ${LIB_INSTALL_DIR}
- )
-+
-+if(BUILD_PORT_MONITORS)
-+ install(TARGETS
-+ tcp-portmon
-+ RUNTIME DESTINATION bin
-+ LIBRARY DESTINATION ${LIB_INSTALL_DIR}
-+ ARCHIVE DESTINATION ${LIB_INSTALL_DIR}
-+)
-+endif(BUILD_PORT_MONITORS)
diff --git a/app-admin/conky/files/conky-1.10.8-use-pkgconfig.patch b/app-admin/conky/files/conky-1.10.8-use-pkgconfig.patch
deleted file mode 100644
index 97e6bd02323f..000000000000
--- a/app-admin/conky/files/conky-1.10.8-use-pkgconfig.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-Reversed patch
-
-From abd0be51a00444d3be6b213e0926675e5a4e5ed3 Mon Sep 17 00:00:00 2001
-From: Brenden Matthews <brenden@diddyinc.com>
-Date: Tue, 23 Jan 2018 12:56:06 -0500
-Subject: [PATCH] Use FindCurses instead of pkg_check_modules.
-
-This should resolve #217.
----
- cmake/ConkyPlatformChecks.cmake | 10 +++++-----
- 1 file changed, 5 insertions(+), 5 deletions(-)
-
-diff --git a/cmake/ConkyPlatformChecks.cmake b/cmake/ConkyPlatformChecks.cmake
-index c5b39b2f..19ec7b9b 100644
---- a/cmake/ConkyPlatformChecks.cmake
-+++ b/cmake/ConkyPlatformChecks.cmake
-@@ -129,12 +129,12 @@ if(BUILD_HTTP)
- endif(BUILD_HTTP)
-
- if(BUILD_NCURSES)
-+ pkg_check_modules(NCURSES ncurses)
-+ if(NOT NCURSES_FOUND)
-- include(FindCurses)
-- if(NOT CURSES_FOUND)
- message(FATAL_ERROR "Unable to find ncurses library")
-+ endif(NOT NCURSES_FOUND)
-+ set(conky_libs ${conky_libs} ${NCURSES_LIBRARIES})
-+ set(conky_includes ${conky_includes} ${NCURSES_INCLUDE_DIRS})
-- endif(NOT CURSES_FOUND)
-- set(conky_libs ${conky_libs} ${CURSES_LIBRARIES})
-- set(conky_includes ${conky_includes} ${CURSES_INCLUDE_DIR})
- endif(BUILD_NCURSES)
-
- if(BUILD_MYSQL)
diff --git a/app-admin/conky/files/conky-1.10.8-virtual-sinks.patch b/app-admin/conky/files/conky-1.10.8-virtual-sinks.patch
deleted file mode 100644
index c0198ccc4ecf..000000000000
--- a/app-admin/conky/files/conky-1.10.8-virtual-sinks.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-From 8221ba62045012abf8a4443de20f17a0a8fc1288 Mon Sep 17 00:00:00 2001
-From: Jan Seeger <jan.seeger@thenybble.de>
-Date: Wed, 5 Aug 2020 15:39:20 +0200
-Subject: Fixed crash on virtual sinks.
-
-Taken from upstream commits
-https://github.com/brndnmtthws/conky/commit/ddf8a0f58f3110e31ec4c44ecff838d2b231f6f3 and
-https://github.com/brndnmtthws/conky/commit/2a7226d89331f7d5d0abf0b9aff6d75435dd3a2d.
-
-Signed-off-by: Jan Seeger <jan.seeger@thenybble.de>
----
- src/pulseaudio.cc | 12 +++++++++---
- 1 file changed, 9 insertions(+), 3 deletions(-)
-
-diff --git a/src/pulseaudio.cc b/src/pulseaudio.cc
-index 93226c1b..af814bd6 100644
---- a/src/pulseaudio.cc
-+++ b/src/pulseaudio.cc
-@@ -53,8 +53,13 @@ void pa_sink_info_callback(pa_context *c, const pa_sink_info *i, int eol, void *
- pdr->sink_mute = i->mute;
- pdr->sink_card = i->card;
- pdr->sink_index = i->index;
-- pdr->sink_active_port_name.assign(i->active_port->name);
-- pdr->sink_active_port_description.assign(i->active_port->description);
-+ if (i->active_port != nullptr) {
-+ pdr->sink_active_port_name.assign(i->active_port->name);
-+ pdr->sink_active_port_description.assign(i->active_port->description);
-+ } else {
-+ pdr->sink_active_port_name.erase();
-+ pdr->sink_active_port_name.erase();
-+ }
- pdr->sink_volume = round_to_int(100.0f * (float)pa_cvolume_avg(&(i->volume)) / (float)PA_VOLUME_NORM);
- pa_threaded_mainloop_signal(pulseaudio->mainloop, 0);
- }
-@@ -224,9 +229,10 @@ void init_pulseaudio(struct text_object *obj) {
- return;
- }
-
-- if(pulseaudio->result.sink_card!=(uint32_t)-1)
-+ if(pulseaudio->result.sink_card!=(uint32_t)-1) {
- PULSEAUDIO_WAIT(pa_context_get_card_info_by_index(pulseaudio->context, pulseaudio->result.sink_card,
- pa_card_info_callback, &pulseaudio->result));
-+ }
-
- // get notification when something changes in PA
- pa_context_set_subscribe_callback(pulseaudio->context, subscribe_cb, &pulseaudio->result);
---
-2.26.2
-
diff --git a/app-admin/conky/files/conky-1.11.6-fpermissive.patch b/app-admin/conky/files/conky-1.11.6-fpermissive.patch
deleted file mode 100644
index f608769b6433..000000000000
--- a/app-admin/conky/files/conky-1.11.6-fpermissive.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- old/src/conky.cc 2021-01-24 17:05:43.361378726 +0100
-+++ new/src/conky.cc 2021-01-24 17:05:49.055378611 +0100
-@@ -317,17 +321,22 @@
- static FILE *append_fpointer = nullptr;
-
- #ifdef BUILD_HTTP
-+#ifdef MHD_YES
-+/* older API */
-+#define MHD_Result int
-+#endif /* MHD_YES */
- std::string webpage;
- struct MHD_Daemon *httpd;
- static conky::simple_config_setting<bool> http_refresh("http_refresh", false,
- true);
-
--int sendanswer(void *cls, struct MHD_Connection *connection, const char *url,
-- const char *method, const char *version, const char *upload_data,
-- size_t *upload_data_size, void **con_cls) {
-+MHD_Result sendanswer(void *cls, struct MHD_Connection *connection,
-+ const char *url, const char *method, const char *version,
-+ const char *upload_data, size_t *upload_data_size,
-+ void **con_cls) {
- struct MHD_Response *response = MHD_create_response_from_buffer(
- webpage.length(), (void *)webpage.c_str(), MHD_RESPMEM_PERSISTENT);
-- int ret = MHD_queue_response(connection, MHD_HTTP_OK, response);
-+ MHD_Result ret = MHD_queue_response(connection, MHD_HTTP_OK, response);
- MHD_destroy_response(response);
- if (cls || url || method || version || upload_data || upload_data_size ||
- con_cls) {} // make compiler happy
diff --git a/app-admin/conky/files/conky-1.11.6-ipv6.patch b/app-admin/conky/files/conky-1.11.6-ipv6.patch
deleted file mode 100644
index 65066270a750..000000000000
--- a/app-admin/conky/files/conky-1.11.6-ipv6.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-Fix no-ipv6
-From https://github.com/brndnmtthws/conky/issues/1033#issue-748414180
-
-diff '--color=auto' -aur a/src/linux.cc b/src/linux.cc
---- a/src/linux.cc 2019-08-12 14:53:54.000000000 -0700
-+++ b/src/linux.cc 2020-11-22 18:44:04.394329722 -0700
-@@ -667,6 +667,7 @@
- }
- }
-
-+#ifdef BUILD_IPV6
- void update_ipv6_net_stats() {
- FILE *file;
- char v6addr[33];
-@@ -731,6 +732,7 @@
-
- fclose(file);
- }
-+#endif /* BUILD_IPV6 */
-
- /**
- * Parses information from /proc/net/dev and stores them in ???