summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/conky')
-rw-r--r--app-admin/conky/Manifest4
-rw-r--r--app-admin/conky/conky-1.19.6-r2.ebuild (renamed from app-admin/conky/conky-1.12.2.ebuild)125
-rw-r--r--app-admin/conky/conky-1.19.8.ebuild (renamed from app-admin/conky/conky-1.12.1-r1.ebuild)140
-rw-r--r--app-admin/conky/files/conky-1.11.6-ipv6.patch22
-rw-r--r--app-admin/conky/files/conky-1.12.1-network-speed.patch36
-rw-r--r--app-admin/conky/metadata.xml3
6 files changed, 180 insertions, 150 deletions
diff --git a/app-admin/conky/Manifest b/app-admin/conky/Manifest
index aa6e74924d41..f55d8c5c81e5 100644
--- a/app-admin/conky/Manifest
+++ b/app-admin/conky/Manifest
@@ -1,2 +1,2 @@
-DIST conky-1.12.1.tar.gz 2404597 BLAKE2B 9e751844db9d1c90990b1e7dd5d9731330244f6ee772a7403e3520636f2ac930ccf3219e65da970d63396512cf843d4f8137854781fdf3c797fe910a8edb872d SHA512 897c6b83528809aa2e33e15b9ad6644d8cf36f4cff93f014811754f982c13180001b972b2b145b607de8d865c2af9a425ab50246065f537e14be75da5631593a
-DIST conky-1.12.2.tar.gz 2407428 BLAKE2B b8d1b40dc4b547679b5ab4bf0328aabaac868025433729f48baf572c536da4a527a073a6d47f36c179851aecef58535dccb956e3a695700f06bf8e6ab170ae1f SHA512 55280953da437efe36320e4c12f74d95b8406bd7d8b7d93c6582f9b346c1c80a94b71d1c27860f6274de9171865fca91e330dfc39feb80bb2f453a538bc5ce1a
+DIST conky-1.19.6.tar.gz 1727487 BLAKE2B 2ef2b0acd354559679b9d7d442de7a709e932418e27459b02bdf2f8b6dbdcf7911964932ab9851bab213e7f68d9a82034acab96892752544ab1a26d68c174c09 SHA512 9f1900f495125c668835334239b69fc098c30fe450a384786d873eb3d3e955ff0f06ca70c3a94f47a4b38a42d4510be77efd13873411f11ff84d8bfdc2869fde
+DIST conky-1.19.8.tar.gz 1711683 BLAKE2B f1c1057f07570e63026e51a03fc4d7a51cc1dcaefb963b5f9ce9fba4e71342770bc1a59aa9a834fe8f9d6d552e7775ab0e2d5a487d9b6ec2d215768349c4994c SHA512 bdc5b29bea3a3050f4fe4ce76fc642134d93a91362e491203dc10cdde1d9c1bde8a106cd8388aab1893e4b1def058abf1f35c1fd022c26ac773071ddd44abbc4
diff --git a/app-admin/conky/conky-1.12.2.ebuild b/app-admin/conky/conky-1.19.6-r2.ebuild
index e40d09332fef..780a97784f42 100644
--- a/app-admin/conky/conky-1.12.2.ebuild
+++ b/app-admin/conky/conky-1.19.6-r2.ebuild
@@ -1,11 +1,12 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-LUA_COMPAT=( lua5-3 )
+LUA_COMPAT=( lua5-4 )
+PYTHON_COMPAT=( python{3_10,3_11} )
-inherit cmake linux-info lua-single readme.gentoo-r1 xdg
+inherit cmake linux-info lua-single python-any-r1 readme.gentoo-r1 xdg
DESCRIPTION="An advanced, highly configurable system monitor for X"
HOMEPAGE="https://github.com/brndnmtthws/conky"
@@ -13,15 +14,14 @@ SRC_URI="https://github.com/brndnmtthws/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.
LICENSE="GPL-3 BSD LGPL-2.1 MIT"
SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ppc ppc64 sparc ~x86"
-IUSE="apcupsd bundled-toluapp cmus curl doc hddtemp ical iconv imlib
- intel-backlight iostats ipv6 irc lua-cairo lua-imlib lua-rsvg math moc
- mpd mysql nano-syntax ncurses nvidia +portmon pulseaudio rss systemd
- thinkpad truetype vim-syntax weather-metar webserver wifi X xinerama
- xmms2"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~ppc ppc64 ~riscv sparc x86"
+IUSE="apcupsd bundled-toluapp cmus curl doc extras hddtemp ical iconv imlib
+ intel-backlight iostats irc lua-cairo lua-imlib lua-rsvg math moc mpd
+ mysql ncurses nvidia +portmon pulseaudio rss systemd test thinkpad
+ truetype wayland webserver wifi X xinerama xmms2"
+RESTRICT="!test? ( test )"
COMMON_DEPEND="
- cmus? ( media-sound/cmus )
curl? ( net-misc/curl )
ical? ( dev-libs/libical:= )
iconv? ( virtual/libiconv )
@@ -33,13 +33,23 @@ COMMON_DEPEND="
mysql? ( dev-db/mysql-connector-c )
ncurses? ( sys-libs/ncurses:= )
nvidia? ( x11-drivers/nvidia-drivers[tools,static-libs] )
- pulseaudio? ( media-sound/pulseaudio )
- rss? ( dev-libs/libxml2 net-misc/curl dev-libs/glib:2 )
+ pulseaudio? ( media-libs/libpulse )
+ rss? (
+ dev-libs/libxml2
+ net-misc/curl
+ dev-libs/glib:2
+ )
systemd? ( sys-apps/systemd )
- truetype? ( x11-libs/libXft >=media-libs/freetype-2 )
+ truetype? (
+ x11-libs/libXft
+ >=media-libs/freetype-2
+ )
+ wayland? (
+ dev-libs/wayland
+ x11-libs/pango
+ )
wifi? ( net-wireless/wireless-tools )
- weather-metar? ( net-misc/curl )
- webserver? ( net-libs/libmicrohttpd )
+ webserver? ( net-libs/libmicrohttpd:= )
X? (
x11-libs/libX11
x11-libs/libXdamage
@@ -53,17 +63,44 @@ COMMON_DEPEND="
RDEPEND="
${COMMON_DEPEND}
apcupsd? ( sys-power/apcupsd )
+ cmus? ( media-sound/cmus )
hddtemp? ( app-admin/hddtemp )
moc? ( media-sound/moc )
- nano-syntax? ( app-editors/nano )
- vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )
"
DEPEND="
${COMMON_DEPEND}
- doc? ( app-text/docbook2X dev-libs/libxslt )
+ test? (
+ dev-cpp/catch
+ )
+ wayland? (
+ dev-libs/wayland-protocols
+ )
+"
+BDEPEND="
+ doc? (
+ virtual/pandoc
+ $(python_gen_any_dep '
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ ')
+ )
+ extras? (
+ $(python_gen_any_dep '
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ ')
+ )
+ wayland? ( dev-util/wayland-scanner )
"
+python_check_deps() {
+ use doc || use extras || return 0
+ python_has_version -b "dev-python/pyyaml[${PYTHON_USEDEP}]" &&
+ python_has_version -b "dev-python/jinja[${PYTHON_USEDEP}]"
+}
+
REQUIRED_USE="
+ ${LUA_REQUIRED_USE}
imlib? ( X )
lua-cairo? ( X bundled-toluapp )
lua-imlib? ( X bundled-toluapp )
@@ -78,44 +115,46 @@ CONFIG_CHECK="~IPV6"
DOCS=( README.md AUTHORS )
DISABLE_AUTOFORMATTING="yes"
-DOC_CONTENTS="You can find sample configurations at ${ROOT}/usr/share/doc/${PF}.
-To customize, copy to \${XDG_CONFIG_HOME}/conky/conky.conf
-and edit it to your liking.
+DOC_CONTENTS="You can find sample configurations at /usr/share/doc/${PF}.
+To customize, copy to \${XDG_CONFIG_HOME}/conky/conky.conf and edit it to your liking.
-There are pretty html docs available at the conky homepage
-or in ${ROOT}/usr/share/doc/${PF}/html when built with USE=doc.
+There are pretty html docs available at https://conky.cc/.
-Also see https://wiki.gentoo.org/wiki/Conky/HOWTO"
+Also see https://github.com/brndnmtthws/conky/wiki or https://wiki.gentoo.org/wiki/Conky"
pkg_setup() {
- use ipv6 && linux-info_pkg_setup
-
+ linux-info_pkg_setup
lua-single_pkg_setup
+ if use doc || use extras; then
+ python-any-r1_pkg_setup
+ fi
}
src_prepare() {
- cmake_src_prepare
+ # pin lua 5.4
+ sed -i -e 's|Lua "5.3" REQUIRED|Lua "5.4" EXACT|g' \
+ cmake/ConkyPlatformChecks.cmake || die "ConkyPlatformChecks.cmake"
+ cmake_src_prepare
xdg_environment_reset
-
- sed -i -e "s|find_program(APP_MAN man)|set(APP_MAN $(which man) CACHE FILEPATH MAN_BINARY)|" \
- cmake/ConkyPlatformChecks.cmake || die
}
src_configure() {
- local mycmakeargs
+ local mycmakeargs=()
if use X; then
- mycmakeargs=(
+ mycmakeargs+=(
-DBUILD_ARGB=yes
-DBUILD_X11=yes
-DBUILD_XDAMAGE=yes
-DBUILD_XDBE=yes
+ -DBUILD_XFIXES=yes
-DBUILD_XSHAPE=yes
+ -DBUILD_MOUSE_EVENTS=yes
-DOWN_WINDOW=yes
)
else
- mycmakeargs=(
+ mycmakeargs+=(
-DBUILD_X11=no
)
fi
@@ -127,6 +166,7 @@ src_configure() {
-DBUILD_CMUS=$(usex cmus)
-DBUILD_CURL=$(usex curl)
-DBUILD_DOCS=$(usex doc)
+ -DBUILD_EXTRAS=$(usex extras)
-DBUILD_HDDTEMP=$(usex hddtemp)
-DBUILD_HTTP=$(usex webserver)
-DBUILD_I18N=yes
@@ -136,7 +176,7 @@ src_configure() {
-DBUILD_IMLIB2=$(usex imlib)
-DBUILD_INTEL_BACKLIGHT=$(usex intel-backlight)
-DBUILD_IOSTATS=$(usex iostats)
- -DBUILD_IPV6=$(usex ipv6)
+ -DBUILD_IPV6=yes
-DBUILD_IRC=$(usex irc)
-DBUILD_JOURNAL=$(usex systemd)
-DBUILD_LUA_CAIRO=$(usex lua-cairo)
@@ -152,7 +192,8 @@ src_configure() {
-DBUILD_PORT_MONITORS=$(usex portmon)
-DBUILD_PULSEAUDIO=$(usex pulseaudio)
-DBUILD_RSS=$(usex rss)
- -DBUILD_WEATHER_METAR=$(usex weather-metar)
+ -DBUILD_TESTS=$(usex test)
+ -DBUILD_WAYLAND=$(usex wayland)
-DBUILD_WLAN=$(usex wifi)
-DBUILD_XFT=$(usex truetype)
-DBUILD_XINERAMA=$(usex xinerama)
@@ -162,23 +203,25 @@ src_configure() {
-DRELEASE=yes
)
+ if use doc || use extras; then
+ mycmakeargs+=( -DPython3_EXECUTABLE="${PYTHON}" )
+ fi
+
cmake_src_configure
}
src_install() {
cmake_src_install
- if use vim-syntax; then
+ if use extras; then
insinto /usr/share/vim/vimfiles/ftdetect
doins "${S}"/extras/vim/ftdetect/conkyrc.vim
insinto /usr/share/vim/vimfiles/syntax
- doins "${S}"/extras/vim/syntax/conkyrc.vim
- fi
+ doins "${BUILD_DIR}"/extras/vim/syntax/conkyrc.vim
- if use nano-syntax; then
insinto /usr/share/nano/
- doins "${S}"/extras/nano/conky.nanorc
+ doins "${BUILD_DIR}"/extras/nano/conky.nanorc
fi
readme.gentoo_create_doc
diff --git a/app-admin/conky/conky-1.12.1-r1.ebuild b/app-admin/conky/conky-1.19.8.ebuild
index 440519c7fc22..3c34a84c0eba 100644
--- a/app-admin/conky/conky-1.12.1-r1.ebuild
+++ b/app-admin/conky/conky-1.19.8.ebuild
@@ -1,11 +1,12 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-LUA_COMPAT=( lua5-3 )
+LUA_COMPAT=( lua5-4 )
+PYTHON_COMPAT=( python3_{10,11,12} )
-inherit cmake linux-info lua-single readme.gentoo-r1 xdg
+inherit cmake linux-info lua-single python-any-r1 readme.gentoo-r1 xdg
DESCRIPTION="An advanced, highly configurable system monitor for X"
HOMEPAGE="https://github.com/brndnmtthws/conky"
@@ -13,32 +14,47 @@ SRC_URI="https://github.com/brndnmtthws/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.
LICENSE="GPL-3 BSD LGPL-2.1 MIT"
SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ppc ppc64 sparc x86"
-IUSE="apcupsd bundled-toluapp cmus curl doc hddtemp ical iconv imlib iostats
- ipv6 irc lua-cairo lua-imlib lua-rsvg math moc mpd mysql nano-syntax
- ncurses nvidia +portmon pulseaudio rss systemd thinkpad truetype
- vim-syntax weather-metar webserver wifi X xinerama xmms2"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~ppc ppc64 ~riscv sparc x86"
+IUSE="apcupsd bundled-toluapp cmus curl doc extras hddtemp ical iconv imlib
+ intel-backlight iostats irc lua-cairo lua-imlib lua-rsvg math moc mpd
+ mysql ncurses nvidia +portmon pulseaudio rss systemd test thinkpad
+ truetype wayland webserver wifi X xinerama xmms2"
+RESTRICT="!test? ( test )"
+
+# Note: toluapp is bundled in conky since 1.11.2
+# Note: maintainer mode "-DMAINTAINER_MODE=yes" sets CMAKE_BUILD_TYPE Debug
+# which creates debug symbols and enables "-DBUILD_TESTS" which also
+# results in conky_core debug library getting installed
COMMON_DEPEND="
- cmus? ( media-sound/cmus )
curl? ( net-misc/curl )
ical? ( dev-libs/libical:= )
iconv? ( virtual/libiconv )
- imlib? ( media-libs/imlib2[X] )
+ imlib? ( >=media-libs/imlib2-1.11.0[X] )
irc? ( net-libs/libircclient )
lua-cairo? ( x11-libs/cairo[X] )
- lua-imlib? ( media-libs/imlib2[X] )
+ lua-imlib? ( >=media-libs/imlib2-1.11.0[X] )
lua-rsvg? ( gnome-base/librsvg )
mysql? ( dev-db/mysql-connector-c )
ncurses? ( sys-libs/ncurses:= )
nvidia? ( x11-drivers/nvidia-drivers[tools,static-libs] )
- pulseaudio? ( media-sound/pulseaudio )
- rss? ( dev-libs/libxml2 net-misc/curl dev-libs/glib:2 )
+ pulseaudio? ( media-libs/libpulse )
+ rss? (
+ dev-libs/libxml2
+ net-misc/curl
+ dev-libs/glib:2
+ )
systemd? ( sys-apps/systemd )
- truetype? ( x11-libs/libXft >=media-libs/freetype-2 )
+ truetype? (
+ x11-libs/libXft
+ >=media-libs/freetype-2
+ )
+ wayland? (
+ dev-libs/wayland
+ x11-libs/pango
+ )
wifi? ( net-wireless/wireless-tools )
- weather-metar? ( net-misc/curl )
- webserver? ( net-libs/libmicrohttpd )
+ webserver? ( net-libs/libmicrohttpd:= )
X? (
x11-libs/libX11
x11-libs/libXdamage
@@ -52,17 +68,44 @@ COMMON_DEPEND="
RDEPEND="
${COMMON_DEPEND}
apcupsd? ( sys-power/apcupsd )
+ cmus? ( media-sound/cmus )
hddtemp? ( app-admin/hddtemp )
moc? ( media-sound/moc )
- nano-syntax? ( app-editors/nano )
- vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )
"
DEPEND="
${COMMON_DEPEND}
- doc? ( app-text/docbook2X dev-libs/libxslt )
+ test? (
+ dev-cpp/catch
+ )
+ wayland? (
+ dev-libs/wayland-protocols
+ )
+"
+BDEPEND="
+ doc? (
+ virtual/pandoc
+ $(python_gen_any_dep '
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ ')
+ )
+ extras? (
+ $(python_gen_any_dep '
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ ')
+ )
+ wayland? ( dev-util/wayland-scanner )
"
+python_check_deps() {
+ use doc || use extras || return 0
+ python_has_version -b "dev-python/pyyaml[${PYTHON_USEDEP}]" &&
+ python_has_version -b "dev-python/jinja[${PYTHON_USEDEP}]"
+}
+
REQUIRED_USE="
+ ${LUA_REQUIRED_USE}
imlib? ( X )
lua-cairo? ( X bundled-toluapp )
lua-imlib? ( X bundled-toluapp )
@@ -76,50 +119,48 @@ CONFIG_CHECK="~IPV6"
DOCS=( README.md AUTHORS )
-PATCHES=(
- "${FILESDIR}"/${PN}-1.11.6-ipv6.patch
- "${FILESDIR}"/${P}-network-speed.patch
-)
-
DISABLE_AUTOFORMATTING="yes"
-DOC_CONTENTS="You can find sample configurations at ${ROOT}/usr/share/doc/${PF}.
-To customize, copy to \${XDG_CONFIG_HOME}/conky/conky.conf
-and edit it to your liking.
+DOC_CONTENTS="You can find sample configurations at /usr/share/doc/${PF}.
+To customize, copy to \${XDG_CONFIG_HOME}/conky/conky.conf and edit it to your liking.
-There are pretty html docs available at the conky homepage
-or in ${ROOT}/usr/share/doc/${PF}/html when built with USE=doc.
+There are pretty html docs available at https://conky.cc/.
-Also see https://wiki.gentoo.org/wiki/Conky/HOWTO"
+Also see https://github.com/brndnmtthws/conky/wiki or https://wiki.gentoo.org/wiki/Conky"
pkg_setup() {
- use ipv6 && linux-info_pkg_setup
-
+ linux-info_pkg_setup
lua-single_pkg_setup
+ if use doc || use extras; then
+ python-any-r1_pkg_setup
+ fi
}
src_prepare() {
- cmake_src_prepare
+ # pin lua 5.4
+ sed -i -e 's|Lua "5.3" REQUIRED|Lua "5.4" EXACT|g' \
+ cmake/ConkyPlatformChecks.cmake || die "ConkyPlatformChecks.cmake"
+ cmake_src_prepare
xdg_environment_reset
-
- sed -i -e "s|find_program(APP_MAN man)|set(APP_MAN $(which man) CACHE FILEPATH MAN_BINARY)|" \
- cmake/ConkyPlatformChecks.cmake || die
}
src_configure() {
- local mycmakeargs
+ local mycmakeargs=()
if use X; then
- mycmakeargs=(
+ mycmakeargs+=(
-DBUILD_ARGB=yes
-DBUILD_X11=yes
-DBUILD_XDAMAGE=yes
-DBUILD_XDBE=yes
+ -DBUILD_XFIXES=yes
-DBUILD_XSHAPE=yes
+ -DBUILD_XINPUT=yes
+ -DBUILD_MOUSE_EVENTS=yes
-DOWN_WINDOW=yes
)
else
- mycmakeargs=(
+ mycmakeargs+=(
-DBUILD_X11=no
)
fi
@@ -131,6 +172,7 @@ src_configure() {
-DBUILD_CMUS=$(usex cmus)
-DBUILD_CURL=$(usex curl)
-DBUILD_DOCS=$(usex doc)
+ -DBUILD_EXTRAS=$(usex extras)
-DBUILD_HDDTEMP=$(usex hddtemp)
-DBUILD_HTTP=$(usex webserver)
-DBUILD_I18N=yes
@@ -138,8 +180,9 @@ src_configure() {
-DBUILD_ICAL=$(usex ical)
-DBUILD_ICONV=$(usex iconv)
-DBUILD_IMLIB2=$(usex imlib)
+ -DBUILD_INTEL_BACKLIGHT=$(usex intel-backlight)
-DBUILD_IOSTATS=$(usex iostats)
- -DBUILD_IPV6=$(usex ipv6)
+ -DBUILD_IPV6=yes
-DBUILD_IRC=$(usex irc)
-DBUILD_JOURNAL=$(usex systemd)
-DBUILD_LUA_CAIRO=$(usex lua-cairo)
@@ -155,7 +198,8 @@ src_configure() {
-DBUILD_PORT_MONITORS=$(usex portmon)
-DBUILD_PULSEAUDIO=$(usex pulseaudio)
-DBUILD_RSS=$(usex rss)
- -DBUILD_WEATHER_METAR=$(usex weather-metar)
+ -DBUILD_TESTS=$(usex test)
+ -DBUILD_WAYLAND=$(usex wayland)
-DBUILD_WLAN=$(usex wifi)
-DBUILD_XFT=$(usex truetype)
-DBUILD_XINERAMA=$(usex xinerama)
@@ -165,23 +209,25 @@ src_configure() {
-DRELEASE=yes
)
+ if use doc || use extras; then
+ mycmakeargs+=( -DPython3_EXECUTABLE="${PYTHON}" )
+ fi
+
cmake_src_configure
}
src_install() {
cmake_src_install
- if use vim-syntax; then
+ if use extras; then
insinto /usr/share/vim/vimfiles/ftdetect
doins "${S}"/extras/vim/ftdetect/conkyrc.vim
insinto /usr/share/vim/vimfiles/syntax
- doins "${S}"/extras/vim/syntax/conkyrc.vim
- fi
+ doins "${BUILD_DIR}"/extras/vim/syntax/conkyrc.vim
- if use nano-syntax; then
insinto /usr/share/nano/
- doins "${S}"/extras/nano/conky.nanorc
+ doins "${BUILD_DIR}"/extras/nano/conky.nanorc
fi
readme.gentoo_create_doc
diff --git a/app-admin/conky/files/conky-1.11.6-ipv6.patch b/app-admin/conky/files/conky-1.11.6-ipv6.patch
deleted file mode 100644
index 65066270a750..000000000000
--- a/app-admin/conky/files/conky-1.11.6-ipv6.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-Fix no-ipv6
-From https://github.com/brndnmtthws/conky/issues/1033#issue-748414180
-
-diff '--color=auto' -aur a/src/linux.cc b/src/linux.cc
---- a/src/linux.cc 2019-08-12 14:53:54.000000000 -0700
-+++ b/src/linux.cc 2020-11-22 18:44:04.394329722 -0700
-@@ -667,6 +667,7 @@
- }
- }
-
-+#ifdef BUILD_IPV6
- void update_ipv6_net_stats() {
- FILE *file;
- char v6addr[33];
-@@ -731,6 +732,7 @@
-
- fclose(file);
- }
-+#endif /* BUILD_IPV6 */
-
- /**
- * Parses information from /proc/net/dev and stores them in ???
diff --git a/app-admin/conky/files/conky-1.12.1-network-speed.patch b/app-admin/conky/files/conky-1.12.1-network-speed.patch
deleted file mode 100644
index 46a7615c589a..000000000000
--- a/app-admin/conky/files/conky-1.12.1-network-speed.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From 415c730133476d6652f479242b0638496b5f673b Mon Sep 17 00:00:00 2001
-From: Steven Xu <stevenxxiu@gmail.com>
-Date: Tue, 23 Mar 2021 20:12:52 +1100
-Subject: [PATCH] fix: update `update last_update_time` earlier, so the network
- speed is correctly displayed, otherwise the speed shown is much lower than
- the actual speed (resolves #863)
-
----
- src/conky.cc | 7 ++++++-
- 1 file changed, 6 insertions(+), 1 deletion(-)
-
-diff --git a/src/conky.cc b/src/conky.cc
-index b116b2bed..af5602c5b 100644
---- a/src/conky.cc
-+++ b/src/conky.cc
-@@ -766,6 +766,12 @@ static void generate_text() {
- * some info.mem entries */
- update_stuff();
-
-+ /* Update `last_update_time` before `generate_text_internal()`, as the latter
-+ * calls `evaluate()` -> `update_net_stats()`, which needs `last_update_time`
-+ * to be set correctly. If this is not done, than the network speed being
-+ * shown will be much lower than the actual speed.*/
-+ last_update_time = current_update_time;
-+
- /* populate the text buffer; generate_text_internal() iterates through
- * global_root_object (an instance of the text_object struct) and calls
- * any callbacks that were set on startup by construct_text_object(). */
-@@ -822,7 +828,6 @@ static void generate_text() {
- if (next_update_time < time || next_update_time > time + ui) {
- next_update_time = time - fmod(time, ui) + ui;
- }
-- last_update_time = current_update_time;
- total_updates++;
- }
-
diff --git a/app-admin/conky/metadata.xml b/app-admin/conky/metadata.xml
index adb290e7c2fd..2caf95af9ae7 100644
--- a/app-admin/conky/metadata.xml
+++ b/app-admin/conky/metadata.xml
@@ -18,6 +18,7 @@
<flag name="apcupsd">Enable support for <pkg>sys-power/apcupsd</pkg></flag>
<flag name="bundled-toluapp">Enable support for bundled toluapp. This only makes sense in combination with the lua-* flags</flag>
<flag name="cmus">Enable monitoring of music played by <pkg>media-sound/cmus</pkg></flag>
+ <flag name="extras">Enable syntax highlighting for <pkg>app-editors/nano</pkg>and app-editors/vim</flag>
<flag name="ical">Enable support for events from iCalendar (RFC 5545) files using <pkg>dev-libs/libical</pkg></flag>
<flag name="intel-backlight">Enable support for Intel backlight</flag>
<flag name="iostats">Enable support for per-task I/O statistics</flag>
@@ -28,11 +29,9 @@
<flag name="math">Enable support for glibc's libm math library</flag>
<flag name="moc">Enable monitoring of music played by <pkg>media-sound/moc</pkg></flag>
<flag name="mpd">Enable monitoring of music controlled by <pkg>media-sound/mpd</pkg></flag>
- <flag name="nano-syntax">Enable syntax highlighting for <pkg>app-editors/nano</pkg></flag>
<flag name="nvidia">Enable reading of nvidia card temperature sensors via <pkg>x11-drivers/nvidia-drivers</pkg></flag>
<flag name="portmon">Enable support for tcp (ip4) port monitoring</flag>
<flag name="thinkpad">Enable support for IBM/Lenovo notebooks</flag>
- <flag name="weather-metar">Enable support for metar weather service</flag>
<flag name="webserver">Enable support to act as a webserver serving conkys output using <pkg>net-libs/libmicrohttpd</pkg></flag>
<flag name="xmms2">Enable monitoring of music played by <pkg>media-sound/xmms2</pkg></flag>
</use>