summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/conky')
-rw-r--r--app-admin/conky/conky-1.11.6-r2.ebuild3
-rw-r--r--app-admin/conky/files/conky-1.11.6-ipv6.patch22
2 files changed, 24 insertions, 1 deletions
diff --git a/app-admin/conky/conky-1.11.6-r2.ebuild b/app-admin/conky/conky-1.11.6-r2.ebuild
index fb7f8a7087d9..827e39e30975 100644
--- a/app-admin/conky/conky-1.11.6-r2.ebuild
+++ b/app-admin/conky/conky-1.11.6-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -78,6 +78,7 @@ DOCS=( README.md AUTHORS )
PATCHES=(
"${FILESDIR}"/${P}-fpermissive.patch
+ "${FILESDIR}"/${P}-ipv6.patch
)
DISABLE_AUTOFORMATTING="yes"
diff --git a/app-admin/conky/files/conky-1.11.6-ipv6.patch b/app-admin/conky/files/conky-1.11.6-ipv6.patch
new file mode 100644
index 000000000000..65066270a750
--- /dev/null
+++ b/app-admin/conky/files/conky-1.11.6-ipv6.patch
@@ -0,0 +1,22 @@
+Fix no-ipv6
+From https://github.com/brndnmtthws/conky/issues/1033#issue-748414180
+
+diff '--color=auto' -aur a/src/linux.cc b/src/linux.cc
+--- a/src/linux.cc 2019-08-12 14:53:54.000000000 -0700
++++ b/src/linux.cc 2020-11-22 18:44:04.394329722 -0700
+@@ -667,6 +667,7 @@
+ }
+ }
+
++#ifdef BUILD_IPV6
+ void update_ipv6_net_stats() {
+ FILE *file;
+ char v6addr[33];
+@@ -731,6 +732,7 @@
+
+ fclose(file);
+ }
++#endif /* BUILD_IPV6 */
+
+ /**
+ * Parses information from /proc/net/dev and stores them in ???