summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/consul-template')
-rw-r--r--app-admin/consul-template/Manifest6
-rw-r--r--app-admin/consul-template/consul-template-0.29.1.ebuild58
-rw-r--r--app-admin/consul-template/consul-template-0.37.4.ebuild (renamed from app-admin/consul-template/consul-template-0.29.0.ebuild)11
3 files changed, 8 insertions, 67 deletions
diff --git a/app-admin/consul-template/Manifest b/app-admin/consul-template/Manifest
index 9dc24c045c01..94b93a5de3bc 100644
--- a/app-admin/consul-template/Manifest
+++ b/app-admin/consul-template/Manifest
@@ -1,4 +1,2 @@
-DIST consul-template-0.29.0-deps.tar.xz 37430348 BLAKE2B 9e0af3e245420bb3166a56bf2e570300ae0d35d9d93a6f6ae08bced79b26bae102339faa955a989f0617453cd5e40c6a3358a0b265ed49f4bc2dd7cb07e605c9 SHA512 fc3ed6150bb53c27c4a8e8e8b4d2d96cf4fada966016c8fbff48d4f61d392d08fc8bd53e9fa52256c84b1e5249a34e2fe361fd96a860841337a308bc3caa7f3a
-DIST consul-template-0.29.0.tar.gz 244446 BLAKE2B 9ff2b33d9a3ca296913bf4f5e6928b789341438a566b63e841e04b0ad528d13588bcdb34994a1d3a829c7d64593b9811480fcf9395d3527a09d473d90bdf4e23 SHA512 e562d89c753ca2bbd14ae57e084e7e2b0aac28c92c210357e22d32d5c3c138054a46f5fb8883a44f64bdd8e9654f457230cef3b24513fa7eeaefd177fd8004c7
-DIST consul-template-0.29.1-deps.tar.xz 59041120 BLAKE2B dd822c41cf9fdfe773ed48edbc02eb409b4840c9bd6f6b66c590d2fa6a44ccea3bcac89569abf318abd2c97e7515e600ee2f1f6c469c60d068959f90e3487831 SHA512 37fd93e9ce064251941626c6ac6b6770e7c019d82cd5f6c113d2adb09460a02fb1644af26714b34f9634e6312346edb98cd841aee6b6805f7d06a07fc7c997d7
-DIST consul-template-0.29.1.tar.gz 254592 BLAKE2B 4ad5e7c1bf2edc06d72ec1ed48f9546c698d22f8562c4c9924106891c44511b912abecc94517ed2359592b709f1f8fd05fcb00cea52893de29c62b34b61fd71e SHA512 edcfe45a3d98b9affda8b5d07fb375a647a78473c7041a87f1f5a2aa2faef2bfdef26a7037d228f6a86d0c446397e7452e7005ce16beff2bc68edabf2268a6f9
+DIST consul-template-0.37.4-deps.tar.xz 1548760 BLAKE2B 34a4e7926f41578071e60c715c534a8a50c49db3a78b06ae6ee49ed1a1c857faea753f27921cb6345bbc94f44ab81da58d3ffd1d27a0e29220bd2631bb35b58a SHA512 e28e29034407a5fbf78f9872b2cd85c0d6414cb5ec3c4b023b080c227583ae34ead6ab5b98c6ff4e1d278d9af137e895cedc79def10017d073f2b99561f1d483
+DIST consul-template-0.37.4.tar.gz 288565 BLAKE2B 69fc82a482c7fce4201621ee43aca689b328be4e34bb99e1cd552ba844787744a97fb64364adc7d9a180fd424d30881deaed45077851bc10fa037799ea99d189 SHA512 e36a5e444801c8700577df28fb3fbc7398b825d8f549d620c07445d86099a7597d0e95d56ce24daedd44eb573cc33e40dd1bb1e7a6def2c2a1788133bb811c38
diff --git a/app-admin/consul-template/consul-template-0.29.1.ebuild b/app-admin/consul-template/consul-template-0.29.1.ebuild
deleted file mode 100644
index 612bb41f3539..000000000000
--- a/app-admin/consul-template/consul-template-0.29.1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit go-module systemd
-
-DESCRIPTION="Generic template rendering and notifications with Consul"
-HOMEPAGE="https://github.com/hashicorp/consul-template"
-SRC_URI="https://github.com/hashicorp/consul-template/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
- https://dev.gentoo.org/~zmedico/dist/${P}-deps.tar.xz"
-
-LICENSE="MPL-2.0 Apache-2.0 BSD BSD-2 ISC MIT WTFPL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-
-COMMON_DEPEND="
- acct-group/consul-template
- acct-user/consul-template"
-
-DEPEND="${COMMON_DEPEND}"
-RDEPEND="${COMMON_DEPEND}"
-
-# TODO: debug test failures
-RESTRICT+=" test"
-
-src_prepare() {
- default
- # remove -s and -w from the linker flags
- sed \
- -e '/-s \\/d' \
- -e '/-w \\/d' \
- -i Makefile || die
-}
-
-src_compile() {
- emake GOBIN="${S}"/bin dev
-}
-
-src_test() {
- emake GOBIN="${S}"/bin test
-}
-
-src_install() {
- dobin bin/${PN}
- dodoc CHANGELOG.md README.md
-
- newinitd "${FILESDIR}/${PN}.initd" "${PN}"
- newconfd "${FILESDIR}/${PN}.confd" "${PN}"
- insinto /etc/logrotate.d
- newins "${FILESDIR}/${PN}.logrotated" "${PN}"
- systemd_dounit "${FILESDIR}/${PN}.service"
-
- keepdir /etc/${PN}.d
-
- keepdir /var/log/${PN}
- fowners ${PN}:${PN} /var/log/${PN}
-}
diff --git a/app-admin/consul-template/consul-template-0.29.0.ebuild b/app-admin/consul-template/consul-template-0.37.4.ebuild
index 612bb41f3539..adf2f99b89be 100644
--- a/app-admin/consul-template/consul-template-0.29.0.ebuild
+++ b/app-admin/consul-template/consul-template-0.37.4.ebuild
@@ -1,16 +1,17 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit go-module systemd
DESCRIPTION="Generic template rendering and notifications with Consul"
HOMEPAGE="https://github.com/hashicorp/consul-template"
-SRC_URI="https://github.com/hashicorp/consul-template/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
- https://dev.gentoo.org/~zmedico/dist/${P}-deps.tar.xz"
+SRC_URI="https://github.com/hashicorp/consul-template/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~zmedico/dist/${P}-deps.tar.xz"
-LICENSE="MPL-2.0 Apache-2.0 BSD BSD-2 ISC MIT WTFPL-2"
+LICENSE="MPL-2.0"
+LICENSE+=" Apache-2.0 BSD BSD-2 ISC MIT WTFPL-2"
SLOT="0"
KEYWORDS="~amd64"