summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/diamond')
-rw-r--r--app-admin/diamond/Manifest2
-rw-r--r--app-admin/diamond/diamond-4.0.515.20170311-r1.ebuild102
-rw-r--r--app-admin/diamond/diamond-4.0.515.20200620-r1.ebuild84
-rw-r--r--app-admin/diamond/files/diamond.confd2
-rw-r--r--app-admin/diamond/files/diamond.initd24
-rw-r--r--app-admin/diamond/metadata.xml22
6 files changed, 0 insertions, 236 deletions
diff --git a/app-admin/diamond/Manifest b/app-admin/diamond/Manifest
deleted file mode 100644
index 1a7c1f5d2b73..000000000000
--- a/app-admin/diamond/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST python-diamond-4.0.515.20170311.tar.gz 671963 BLAKE2B 9449f2d27b48c0e24727eb2c415a5095b20199d9315ef69df92a4aa6f8f3397743f3dc6cf2d8d91f79eca309926731b6b42da170a02987a20aeccd1e0980f4ac SHA512 d18a80540018975455b839a78fd55d13d167726b92914e3dc2de1c6f27f47319962361e05961c55047ba185e11ebf57831f3ab5cff9158a50d30a2ca635d53bd
-DIST python-diamond-4.0.515.20200620.tar.gz 674623 BLAKE2B eaf290a18a79115fdc013addff5b9d5a5c5b5ce06989c7e3cb8ac5dd988f47878a893ae37a96d1f020dac1aff00ebe191bf27c3d19ac5625afd56cf79451a141 SHA512 5e43aa1bb7acbeaa80db2bbc8e956042104fa9364893b5149bcfa7bff3e00b3667a112243e7a1fad85c1fb1b0c2e2727d0f73fb6851c1959ac95c1854b0c0f76
diff --git a/app-admin/diamond/diamond-4.0.515.20170311-r1.ebuild b/app-admin/diamond/diamond-4.0.515.20170311-r1.ebuild
deleted file mode 100644
index 437140f59999..000000000000
--- a/app-admin/diamond/diamond-4.0.515.20170311-r1.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-if [[ ${PV} = 9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/python-diamond/Diamond.git"
- S=${WORKDIR}/diamond-${PV}
-else
- GHASH=73207d04e0739a4ce92bc201b36681c42d9fa7e7 # python3 branch
- SRC_URI="https://github.com/python-diamond/Diamond/archive/${GHASH}.tar.gz -> python-diamond-${PV}.tar.gz"
- KEYWORDS="amd64 x86 ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
- S=${WORKDIR}/Diamond-${GHASH}
-fi
-
-PYTHON_COMPAT=( python3_{7,8} )
-
-inherit distutils-r1 prefix
-
-DESCRIPTION="Python daemon that collects and publishes system metrics"
-HOMEPAGE="https://github.com/python-diamond/Diamond"
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="test mongo mysql snmp redis"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/configobj
- dev-python/setproctitle
- mongo? ( dev-python/pymongo )
- mysql? ( dev-python/mysqlclient )
- snmp? ( dev-python/pysnmp )
- redis? ( dev-python/redis-py )
- !kernel_linux? ( >=dev-python/psutil-3 )"
-DEPEND="${RDEPEND}
- test? (
- dev-python/mock
- dev-python/pysnmp
- )"
-
-src_prepare() {
- # adjust for Prefix
- hprefixify bin/diamond*
-
- # fix the version (not set in GitHub archive)
- sed -i -e "s/__VERSIONTOKENHERE__/${PV}/" src/diamond/version.py.tmpl || die
- echo "${PV}" > version.txt || die
- # fix psutil usage
- sed -i -e 's/psutil\.network_io_counters/psutil.net_io_counters/' \
- src/collectors/network/network.py || die
- # fix symlink out of place
- rm README.md || die
- cp docs/index.md README.md || die
-
- # this module isn't Python3 yet (lambda), if you use this and have a
- # fix, let me know
- rm src/diamond/handler/rrdtool.py || die
-
- # forgotten conversion
- sed -i \
- -e 's/import Queue/import queue/' \
- -e 's/Queue\.Full/queue.Full/' \
- src/diamond/handler/queue.py || die
- # fix usage of map as list
- sed -i \
- -e '/paths = map(str.strip, paths)/d' \
- src/diamond/utils/classes.py || die
- # send data as bytes
- sed -i \
- -e '/self.socket.sendall/s/data/str.encode(data)/' \
- src/diamond/handler/graphite.py || die
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- # don't want to depend on docker for just this
- mv src/collectors/docker_collector/test/{test,no}docker_collector.py || die
- # fails on binding ports
- mv src/collectors/portstat/tests/{test,no}_portstat.py || die
- "${PYTHON}" ./test.py || die "Tests fail with ${PYTHON}"
-}
-
-python_install() {
- export VIRTUAL_ENV=1
- distutils-r1_python_install
- python_optimize
- mv "${ED}"/usr/etc "${ED}"/ || die
- rm "${ED}"/etc/diamond/*.windows # won't need these
- sed -i \
- -e '/pid_file =/s:/var/run:/run:' \
- "${ED}"/etc/diamond/diamond.conf.example || die
- hprefixify "${ED}"/etc/diamond/diamond.conf.example
-}
-
-src_install() {
- distutils-r1_src_install
- newinitd "${FILESDIR}"/${PN}.initd ${PN}
- newconfd "${FILESDIR}"/${PN}.confd ${PN}
- keepdir /var/log/diamond
-}
diff --git a/app-admin/diamond/diamond-4.0.515.20200620-r1.ebuild b/app-admin/diamond/diamond-4.0.515.20200620-r1.ebuild
deleted file mode 100644
index 86d47e1ca5aa..000000000000
--- a/app-admin/diamond/diamond-4.0.515.20200620-r1.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-if [[ ${PV} = 9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/grobian/Diamond.git"
- EGIT_BRANCH="python3"
- S=${WORKDIR}/diamond-${PV}
-else
- GHASH=8d8a2e49d80d44968a34d43e36c1d864695a29c1 # from python3 branch
- SRC_URI="https://github.com/grobian/Diamond/archive/${GHASH}.tar.gz -> python-diamond-${PV}.tar.gz"
- KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
- S=${WORKDIR}/Diamond-${GHASH}
-fi
-
-PYTHON_COMPAT=( python3_{7,8} )
-
-inherit distutils-r1 prefix
-
-DESCRIPTION="Python daemon that collects and publishes system metrics"
-HOMEPAGE="https://github.com/python-diamond/Diamond"
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="test mongo mysql snmp redis"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/configobj
- dev-python/setproctitle
- mongo? ( dev-python/pymongo )
- mysql? ( dev-python/mysqlclient )
- snmp? ( dev-python/pysnmp )
- redis? ( dev-python/redis-py )
- !kernel_linux? ( >=dev-python/psutil-3 )
- kernel_linux? ( sys-process/psmisc )"
-DEPEND="${RDEPEND}
- test? ( dev-python/mock )"
-
-src_prepare() {
- # adjust for Prefix
- hprefixify bin/diamond*
-
- # fix the version (not set in GitHub archive)
- sed -i -e "s/__VERSIONTOKENHERE__/${PV}/" src/diamond/version.py.tmpl || die
- echo "${PV}" > version.txt || die
- # fix symlink out of place
- rm README.md || die
- cp docs/index.md README.md || die
-
- # this module isn't Python3 yet (lambda), if you use this and have a
- # fix, let me know
- rm src/diamond/handler/rrdtool.py || die
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- "${PYTHON}" ./test.py || die "Tests fail with ${PYTHON}"
-}
-
-python_install() {
- export VIRTUAL_ENV=1
- distutils-r1_python_install
- python_optimize
- # since python3.8 installation goes straight into /etc
- [[ -d ${ED}/etc ]] && [[ -d ${ED}/usr/etc ]] && rm -Rf "${ED}"/usr/etc
- if [[ -d ${ED}/usr/etc ]] ; then
- mv "${ED}"/usr/etc "${ED}"/ || die
- fi
- rm "${ED}"/etc/diamond/*.windows # won't need these
- sed -i \
- -e '/pid_file =/s:/var/run:/run:' \
- "${ED}"/etc/diamond/diamond.conf.example || die
- hprefixify "${ED}"/etc/diamond/diamond.conf.example
-}
-
-src_install() {
- distutils-r1_src_install
- newinitd "${FILESDIR}"/${PN}.initd ${PN}
- newconfd "${FILESDIR}"/${PN}.confd ${PN}
- keepdir /var/log/diamond
-}
diff --git a/app-admin/diamond/files/diamond.confd b/app-admin/diamond/files/diamond.confd
deleted file mode 100644
index ad9939223182..000000000000
--- a/app-admin/diamond/files/diamond.confd
+++ /dev/null
@@ -1,2 +0,0 @@
-# command line options for running diamond
-DIAMOND_OPTS=
diff --git a/app-admin/diamond/files/diamond.initd b/app-admin/diamond/files/diamond.initd
deleted file mode 100644
index f9b829488c79..000000000000
--- a/app-admin/diamond/files/diamond.initd
+++ /dev/null
@@ -1,24 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-depend() {
- need net
-}
-
-start() {
- ebegin "Starting ${SVCNAME}"
- start-stop-daemon --start --exec /usr/bin/diamond --pidfile /run/${SVCNAME}.pid -- -c /etc/diamond/${SVCNAME}.conf ${DIAMOND_OPTS}
- eend $?
-}
-
-stop() {
- ebegin "Stopping ${SVCNAME}"
- #start-stop-daemon --stop -R 80 --pidfile /run/${SVCNAME}.pid
- # diamond doesn't kill its children, so work around that for now
- pid=$(< /run/${SVCNAME}.pid)
- if [ -n ${pid} ] && [ ${pid} -gt 1 ] ; then
- pstree -Tp ${pid} | grep -o '([0-9]\+)' | tr '()' ' ' | xargs kill
- fi
- eend $?
-}
diff --git a/app-admin/diamond/metadata.xml b/app-admin/diamond/metadata.xml
deleted file mode 100644
index 0198be759037..000000000000
--- a/app-admin/diamond/metadata.xml
+++ /dev/null
@@ -1,22 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>grobian@gentoo.org</email>
- <name>Fabian Groffen</name>
- </maintainer>
- <longdescription lang="en">
- Diamond is a python daemon that collects system metrics and
- publishes them to Graphite (and others). It is capable of
- collecting cpu, memory, network, i/o, load and disk metrics.
- Additionally, it features an API for implementing custom
- collectors for gathering metrics from almost any source.
- </longdescription>
- <use>
- <flag name="mongo">Enable MongoDB support</flag>
- <flag name="redis">Enable Redis support</flag>
- </use>
- <upstream>
- <remote-id type="github">python-diamond/Diamond</remote-id>
- </upstream>
-</pkgmetadata>