summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/djbdns-logparse/djbdns-logparse-0.0.2-r2.ebuild')
-rw-r--r--app-admin/djbdns-logparse/djbdns-logparse-0.0.2-r2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-admin/djbdns-logparse/djbdns-logparse-0.0.2-r2.ebuild b/app-admin/djbdns-logparse/djbdns-logparse-0.0.2-r2.ebuild
new file mode 100644
index 000000000000..2a5bb8a3b82e
--- /dev/null
+++ b/app-admin/djbdns-logparse/djbdns-logparse-0.0.2-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Make tinydns and dnscache logs human-readable"
+HOMEPAGE="https://michael.orlitzky.com/code/djbdns-logparse.xhtml"
+SRC_URI="https://michael.orlitzky.com/code/releases/${P}.tar.gz"
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# djbdns-logparse pipes the logs through the "tai64nlocal" program
+# that comes with sys-process/daemontools.
+RDEPEND="sys-process/daemontools"
+BDEPEND="test? ( ${RDEPEND} )"
+
+python_install_all() {
+ doman "doc/man1/${PN}.1"
+ local DOCS=( doc/README )
+ distutils-r1_python_install_all
+}
+
+python_test() {
+ esetup.py test
+}