summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/djbdns-logparse')
-rw-r--r--app-admin/djbdns-logparse/Manifest1
-rw-r--r--app-admin/djbdns-logparse/djbdns-logparse-0.0.2-r2.ebuild32
-rw-r--r--app-admin/djbdns-logparse/metadata.xml7
3 files changed, 40 insertions, 0 deletions
diff --git a/app-admin/djbdns-logparse/Manifest b/app-admin/djbdns-logparse/Manifest
new file mode 100644
index 000000000000..0f5ba0955e46
--- /dev/null
+++ b/app-admin/djbdns-logparse/Manifest
@@ -0,0 +1 @@
+DIST djbdns-logparse-0.0.2.tar.gz 23425 BLAKE2B dfcad00ddc27d85497d671fde9d51cad033d63b132b7d73e35b65825af4c222239a4815a8081eecdeeab18ec3a00237a16a4a12b647ad6520c0a8e302d0830cc SHA512 8b4b8a59567b929e20571f50bbd302280bcf2755d6e016475db20b98884d380bdeb6800a1ce815265b0655c4f5c725c28575c89f907c89d85a163f88b7a97f6c
diff --git a/app-admin/djbdns-logparse/djbdns-logparse-0.0.2-r2.ebuild b/app-admin/djbdns-logparse/djbdns-logparse-0.0.2-r2.ebuild
new file mode 100644
index 000000000000..2a5bb8a3b82e
--- /dev/null
+++ b/app-admin/djbdns-logparse/djbdns-logparse-0.0.2-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Make tinydns and dnscache logs human-readable"
+HOMEPAGE="https://michael.orlitzky.com/code/djbdns-logparse.xhtml"
+SRC_URI="https://michael.orlitzky.com/code/releases/${P}.tar.gz"
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# djbdns-logparse pipes the logs through the "tai64nlocal" program
+# that comes with sys-process/daemontools.
+RDEPEND="sys-process/daemontools"
+BDEPEND="test? ( ${RDEPEND} )"
+
+python_install_all() {
+ doman "doc/man1/${PN}.1"
+ local DOCS=( doc/README )
+ distutils-r1_python_install_all
+}
+
+python_test() {
+ esetup.py test
+}
diff --git a/app-admin/djbdns-logparse/metadata.xml b/app-admin/djbdns-logparse/metadata.xml
new file mode 100644
index 000000000000..c6418674131d
--- /dev/null
+++ b/app-admin/djbdns-logparse/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>