summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/eclean-kernel/eclean-kernel-9999.ebuild')
-rw-r--r--app-admin/eclean-kernel/eclean-kernel-9999.ebuild22
1 files changed, 14 insertions, 8 deletions
diff --git a/app-admin/eclean-kernel/eclean-kernel-9999.ebuild b/app-admin/eclean-kernel/eclean-kernel-9999.ebuild
index 2e9db8819bee..5f9082c69fdb 100644
--- a/app-admin/eclean-kernel/eclean-kernel-9999.ebuild
+++ b/app-admin/eclean-kernel/eclean-kernel-9999.ebuild
@@ -1,24 +1,30 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
-PYTHON_COMPAT=( python3_{8..9} )
inherit distutils-r1 git-r3
DESCRIPTION="Remove outdated built kernels"
-HOMEPAGE="https://github.com/mgorny/eclean-kernel/"
-EGIT_REPO_URI="https://github.com/mgorny/eclean-kernel.git"
+HOMEPAGE="
+ https://github.com/projg2/eclean-kernel/
+ https://pypi.org/project/eclean-kernel/
+"
+EGIT_REPO_URI="https://github.com/projg2/eclean-kernel.git"
-LICENSE="BSD"
+LICENSE="GPL-2+"
SLOT="0"
-KEYWORDS=""
IUSE="lz4 lzo zstd"
RDEPEND="
+ dev-python/distro[${PYTHON_USEDEP}]
kernel_linux? ( dev-python/pymountboot[${PYTHON_USEDEP}] )
lz4? ( dev-python/lz4[${PYTHON_USEDEP}] )
lzo? ( dev-python/python-lzo[${PYTHON_USEDEP}] )
- zstd? ( dev-python/zstandard[${PYTHON_USEDEP}] )"
+ zstd? ( dev-python/zstandard[${PYTHON_USEDEP}] )
+"
distutils_enable_tests pytest