summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/entr')
-rw-r--r--app-admin/entr/entr-3.9-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-admin/entr/entr-3.9-r1.ebuild b/app-admin/entr/entr-3.9-r1.ebuild
new file mode 100644
index 000000000000..ec8d53eb289b
--- /dev/null
+++ b/app-admin/entr/entr-3.9-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Run arbitrary commands when files change"
+HOMEPAGE="http://entrproject.org"
+SRC_URI="http://entrproject.org/code/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+src_unpack() {
+ unpack "${P}.tar.gz"
+ mv eradman-* "${P}" || die
+}
+
+src_configure() {
+ sh configure || die
+ sed -i -e 's#\(^PREFIX \).*#\1\?= /usr#' Makefile.bsd || die
+}
+
+src_compile() {
+ export CC=$(tc-getCC)
+ default
+}
+
+src_test() {
+ export CC=$(tc-getCC)
+ default
+}