summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/eselect')
-rw-r--r--app-admin/eselect/Manifest4
-rw-r--r--app-admin/eselect/eselect-1.4.26-r1.ebuild (renamed from app-admin/eselect/eselect-1.4.17.ebuild)17
-rw-r--r--app-admin/eselect/eselect-1.4.27-r1.ebuild (renamed from app-admin/eselect/eselect-1.4.20.ebuild)17
-rw-r--r--app-admin/eselect/eselect-9999.ebuild10
4 files changed, 26 insertions, 22 deletions
diff --git a/app-admin/eselect/Manifest b/app-admin/eselect/Manifest
index c648030ffb11..5cd4e19cf408 100644
--- a/app-admin/eselect/Manifest
+++ b/app-admin/eselect/Manifest
@@ -1,2 +1,2 @@
-DIST eselect-1.4.17.tar.xz 178980 BLAKE2B d905ac88bc009080912af75e64c7920d745788866fa3cb35466d68a652efbbd6984d6e1efeed76d9a344aed94705b74c85aa43e9c037d4d548d2e24afa69bd7a SHA512 35dc4c52f44c4f64db9c0dc2aec57b3055a6d36760b1bbbd094ad11b3f9e71a731444802632817b89c3b511f1dc9bb92046b59322d177e13fdc501ed767b591e
-DIST eselect-1.4.20.tar.xz 180272 BLAKE2B 424653d00eda45335c3aaae50f6fbf2e89486da4529f657596516352f3b7fcb9859ceb2dc5b9762a34c44fb64e645fa27c46b86453bf50be6e8ae820664a4289 SHA512 9589ed89c4d5d31f71d535886eb50da67b84dec8a13a5df081e7569efee861dede4eaa43a0bfb9930c5b95d4f334e19245cb8820a73f7361527da262da1d1fb2
+DIST eselect-1.4.26.tar.xz 184332 BLAKE2B ee1e8890802fc50646c8d1d5219f1ab0ec5cfc0138c758f73ad6baccf673992bbf3e763d8e84491f33e724ba4e1cf3bed6971ba7fa4373e0f06464ff4a5fa1e6 SHA512 397ae2f15d90d722eb84225b08f1afaaf6f89758bfae5d93b0a1c3eddc997c21e74ab62e09ee5e71941d3a8587b3372b64336d12054c3bbf0e56e1ba398a26f9
+DIST eselect-1.4.27.tar.xz 184464 BLAKE2B 718874f4d0651194f361ca3202e5140982812bf486c8efe82354944d55206b0113fa135992203e8baa00019c3fd773a90ddaf67157c16f4ac2d69965d9822fbd SHA512 f534785fc1f79869840f420b4ab2b2bf35593c504cce878a6d3d07f75012cf32288009ea9ac2a5607dba216a794110a64c5f2c54d5d8a3c641328489cecc024b
diff --git a/app-admin/eselect/eselect-1.4.17.ebuild b/app-admin/eselect/eselect-1.4.26-r1.ebuild
index aa1883651084..7651d332b72a 100644
--- a/app-admin/eselect/eselect-1.4.17.ebuild
+++ b/app-admin/eselect/eselect-1.4.26-r1.ebuild
@@ -1,8 +1,13 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+# Packages sharing a common release tarball:
+# app-admin/eselect
+# app-emacs/eselect-mode
+# Please bump and mark them stable together!
+
inherit bash-completion-r1
DESCRIPTION="Gentoo's multi-purpose configuration and management tool"
@@ -11,14 +16,12 @@ SRC_URI="https://dev.gentoo.org/~ulm/eselect/${P}.tar.xz"
LICENSE="GPL-2+ || ( GPL-2+ CC-BY-SA-4.0 )"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ~ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
IUSE="doc emacs vim-syntax"
-DEPEND="sys-apps/sed
- || (
- sys-apps/coreutils
- app-misc/realpath
- )"
+# coreutils for realpath
+DEPEND="sys-apps/coreutils
+ sys-apps/sed"
RDEPEND="${DEPEND}
sys-apps/file
sys-libs/ncurses:0"
diff --git a/app-admin/eselect/eselect-1.4.20.ebuild b/app-admin/eselect/eselect-1.4.27-r1.ebuild
index 2c4e05c15d73..7591adecec8d 100644
--- a/app-admin/eselect/eselect-1.4.20.ebuild
+++ b/app-admin/eselect/eselect-1.4.27-r1.ebuild
@@ -1,8 +1,13 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+# Packages sharing a common release tarball:
+# app-admin/eselect
+# app-emacs/eselect-mode
+# Please bump and mark them stable together!
+
inherit bash-completion-r1
DESCRIPTION="Gentoo's multi-purpose configuration and management tool"
@@ -11,14 +16,12 @@ SRC_URI="https://dev.gentoo.org/~ulm/eselect/${P}.tar.xz"
LICENSE="GPL-2+ || ( GPL-2+ CC-BY-SA-4.0 )"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
IUSE="doc emacs vim-syntax"
-DEPEND="sys-apps/sed
- || (
- sys-apps/coreutils
- app-misc/realpath
- )"
+# coreutils for realpath
+DEPEND="sys-apps/coreutils
+ sys-apps/sed"
RDEPEND="${DEPEND}
sys-apps/file
sys-libs/ncurses:0"
diff --git a/app-admin/eselect/eselect-9999.ebuild b/app-admin/eselect/eselect-9999.ebuild
index 5922f93c46e0..6c2f3d7252b2 100644
--- a/app-admin/eselect/eselect-9999.ebuild
+++ b/app-admin/eselect/eselect-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -14,11 +14,9 @@ LICENSE="GPL-2+ || ( GPL-2+ CC-BY-SA-4.0 )"
SLOT="0"
IUSE="doc emacs vim-syntax"
-DEPEND="sys-apps/sed
- || (
- sys-apps/coreutils
- app-misc/realpath
- )"
+# coreutils for realpath
+DEPEND="sys-apps/coreutils
+ sys-apps/sed"
RDEPEND="${DEPEND}
sys-apps/file
sys-libs/ncurses:0"