summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/exo')
-rw-r--r--app-admin/exo/Manifest2
-rw-r--r--app-admin/exo/exo-1.78.2.ebuild (renamed from app-admin/exo/exo-1.49.2.ebuild)17
2 files changed, 9 insertions, 10 deletions
diff --git a/app-admin/exo/Manifest b/app-admin/exo/Manifest
index c1d034ebbb4c..8d8ded050f48 100644
--- a/app-admin/exo/Manifest
+++ b/app-admin/exo/Manifest
@@ -1 +1 @@
-DIST exo-1.49.2.tar.gz 5560650 BLAKE2B 1fe332c26f39c792aa1c49f324ebd898d8481edc846356968adfeba6ccf807e5d4d169be6ed68f990adbb8f9f833fc68dae8236a8b0ea2c75ca7750517ba5530 SHA512 57a4c0f6b077526ee165cf0b8a7d38a0dbede3a10d5b78ec938c8e3fdd60623fda5ba4d795def5ef81d7d917910ab21999c8c8d4c9ef49a07508375d50eb6d4f
+DIST exo-1.78.2.gh.tar.gz 11084100 BLAKE2B 56cf1212040df77d2e39bbc90490276563a45632fe47f1781bba84fe5d99634a6d050c52dd15c9bb837e7ebef2ea21087a5c50cc165b0b606a0f3e9b4f59182a SHA512 1f2b3fedd12a00457e241b0d00eb4235804b60c8c8e6bec1f970617a969761eb9e18c10a6031bffba6c58571ca7049c47d8eb74f3fbaacb095ef72b21bea1c20
diff --git a/app-admin/exo/exo-1.49.2.ebuild b/app-admin/exo/exo-1.78.2.ebuild
index 0e7f06f5fe7f..43fbacd8aa32 100644
--- a/app-admin/exo/exo-1.49.2.ebuild
+++ b/app-admin/exo/exo-1.78.2.ebuild
@@ -1,25 +1,24 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
+inherit go-module
DESCRIPTION="Command-line tool for everything at Exoscale: compute, storage, dns"
HOMEPAGE="https://github.com/exoscale/cli"
-SRC_URI="https://github.com/exoscale/cli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/exoscale/cli/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/cli-${PV}"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"
-IUSE=""
-DEPEND="dev-lang/go:="
+DEPEND=">=dev-lang/go-1.16:="
RESTRICT="strip"
-QA_FLAGS_IGNORED=".*"
-
-S="${WORKDIR}/cli-${PV}"
src_compile() {
- go build -mod vendor -o ${PN} || die "build failed"
+ ego build -mod vendor -o ${PN} -ldflags "-X main.version=${PVR}-gentoo -X main.commit="
}
src_test() {