summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/exo')
-rw-r--r--app-admin/exo/Manifest2
-rw-r--r--app-admin/exo/exo-1.78.2.ebuild (renamed from app-admin/exo/exo-1.54.0.ebuild)17
2 files changed, 9 insertions, 10 deletions
diff --git a/app-admin/exo/Manifest b/app-admin/exo/Manifest
index e370c87db8e9..8d8ded050f48 100644
--- a/app-admin/exo/Manifest
+++ b/app-admin/exo/Manifest
@@ -1 +1 @@
-DIST exo-1.54.0.tar.gz 5596697 BLAKE2B 2cfc0b9eb8775d16311b8d6a2745bb8a59ec52e15f9006732a272cc949faa919d03f86e7031d18d7cd7fc95f71a7092f54f9bfddd827642ff99f2705f7c66af0 SHA512 5a49d13cf7e96980cb0077da199497e0d0a0b4dc4697327466b272f7e65d4e9bcc37dfd5368df8733eac70a5ae494c5890b4f08e625573bdae92300cf0ff5ca3
+DIST exo-1.78.2.gh.tar.gz 11084100 BLAKE2B 56cf1212040df77d2e39bbc90490276563a45632fe47f1781bba84fe5d99634a6d050c52dd15c9bb837e7ebef2ea21087a5c50cc165b0b606a0f3e9b4f59182a SHA512 1f2b3fedd12a00457e241b0d00eb4235804b60c8c8e6bec1f970617a969761eb9e18c10a6031bffba6c58571ca7049c47d8eb74f3fbaacb095ef72b21bea1c20
diff --git a/app-admin/exo/exo-1.54.0.ebuild b/app-admin/exo/exo-1.78.2.ebuild
index 6149acedfa18..43fbacd8aa32 100644
--- a/app-admin/exo/exo-1.54.0.ebuild
+++ b/app-admin/exo/exo-1.78.2.ebuild
@@ -1,25 +1,24 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
+inherit go-module
DESCRIPTION="Command-line tool for everything at Exoscale: compute, storage, dns"
HOMEPAGE="https://github.com/exoscale/cli"
-SRC_URI="https://github.com/exoscale/cli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/exoscale/cli/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/cli-${PV}"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"
-IUSE=""
-DEPEND="dev-lang/go:="
+DEPEND=">=dev-lang/go-1.16:="
RESTRICT="strip"
-QA_FLAGS_IGNORED=".*"
-
-S="${WORKDIR}/cli-${PV}"
src_compile() {
- go build -mod vendor -o ${PN} || die "build failed"
+ ego build -mod vendor -o ${PN} -ldflags "-X main.version=${PVR}-gentoo -X main.commit="
}
src_test() {