summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/fetchlog/fetchlog-1.4.ebuild')
-rw-r--r--app-admin/fetchlog/fetchlog-1.4.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-admin/fetchlog/fetchlog-1.4.ebuild b/app-admin/fetchlog/fetchlog-1.4.ebuild
new file mode 100644
index 000000000000..7bf7b9bfd25b
--- /dev/null
+++ b/app-admin/fetchlog/fetchlog-1.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="Displays the last new messages of a logfile"
+HOMEPAGE="http://fetchlog.sourceforge.net/"
+SRC_URI="mirror://sourceforge/fetchlog/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~ppc64"
+
+IUSE="snmp"
+
+RDEPEND="snmp? (
+ >=dev-perl/Net-SNMP-4.0.1-r2
+ >=net-analyzer/net-snmp-5.0.6
+ )"
+
+pkg_preinst() {
+ elog
+ elog "This utility can be used together with Nagios"
+ elog "To make use of these features you need to"
+ elog "install net-analyzer/nagios."
+ elog "This feature depends on SNMP, so make use you"
+ elog "have 'snmp' in your USE flags"
+ elog
+}
+
+src_compile() {
+ # Links the .c file straight to the binary
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} ${LDFLAGS}" || die
+}
+
+src_install() {
+ dodoc CHANGES README*
+ dodoc *cfg*
+ dobin fetchlog
+ doman fetchlog.1
+}