summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/fleet/fleet-1.0.0.ebuild')
-rw-r--r--app-admin/fleet/fleet-1.0.0.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/app-admin/fleet/fleet-1.0.0.ebuild b/app-admin/fleet/fleet-1.0.0.ebuild
deleted file mode 100644
index 9f43c632f33a..000000000000
--- a/app-admin/fleet/fleet-1.0.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-EGO_PN="github.com/coreos/fleet"
-
-inherit systemd vcs-snapshot
-
-DESCRIPTION="A Distributed init System"
-HOMEPAGE="https://github.com/coreos/fleet"
-SRC_URI="https://github.com/coreos/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="doc examples test"
-
-DEPEND="
- >=dev-lang/go-1.5:=
- test? ( dev-go/go-tools )
-"
-RDEPEND=""
-
-src_compile() {
- ./build || die 'Build failed'
-}
-
-src_test() {
- ./test || die 'Tests failed'
-}
-
-src_install() {
- dobin "${S}"/bin/fleetd
- dobin "${S}"/bin/fleetctl
-
- systemd_dounit "${FILESDIR}"/fleet.service
- systemd_dounit "${FILESDIR}"/fleet.socket
-
- dodoc README.md
- use doc && dodoc -r Documentation
- use examples && dodoc -r examples
-
- insinto /etc/${PN}
- newins "${PN}".conf.sample "${PN}".conf
-}