summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/gkrellm/gkrellm-9999.ebuild')
-rw-r--r--app-admin/gkrellm/gkrellm-9999.ebuild46
1 files changed, 27 insertions, 19 deletions
diff --git a/app-admin/gkrellm/gkrellm-9999.ebuild b/app-admin/gkrellm/gkrellm-9999.ebuild
index 8b29bcf41db9..a978bc39106d 100644
--- a/app-admin/gkrellm/gkrellm-9999.ebuild
+++ b/app-admin/gkrellm/gkrellm-9999.ebuild
@@ -1,22 +1,22 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit desktop multilib systemd toolchain-funcs
-
-MY_P="${P/_/-}"
+PLOCALES="bg cs da de es fr it ja nl pl po pt pt_BR ru sl sv uk"
+PLOCALE_BACKUP="en"
+inherit desktop plocale systemd toolchain-funcs
DESCRIPTION="Single process stack of various system monitors"
-HOMEPAGE="http://www.gkrellm.net/"
+HOMEPAGE="http://gkrellm.srcbox.net/"
if [[ "${PV}" == 9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://git.srcbox.net/gkrellm/gkrellm.git"
else
- SRC_URI="http://gkrellm.srcbox.net/${MY_P}.tar.bz2"
+ SRC_URI="http://gkrellm.srcbox.net/releases/${P}.tar.bz2"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
fi
-LICENSE="GPL-3"
+LICENSE="GPL-3+"
SLOT="2"
IUSE="gnutls hddtemp lm-sensors nls ntlm ssl X"
@@ -41,22 +41,23 @@ RDEPEND="
x11-libs/libSM
x11-libs/libX11
x11-libs/pango
- )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-
-BDEPEND="
- virtual/pkgconfig
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+ nls? ( sys-devel/gettext )
"
+BDEPEND="virtual/pkgconfig"
+
PATCHES=(
- "${FILESDIR}"/${PN}-2.3.5-config.patch
- "${FILESDIR}"/${PN}-2.3.5-width.patch
- "${FILESDIR}"/${PN}-2.3.5-sansfont.patch
+ "${FILESDIR}/${PN}-2.3.5-config.patch"
+ "${FILESDIR}/${PN}-2.3.5-width.patch"
+ "${FILESDIR}/${PN}-2.3.5-sansfont.patch"
+ "${FILESDIR}/${PN}-2.3.11-clang16.patch"
)
-S="${WORKDIR}/${MY_P}"
-
DOCS=( Changelog CREDITS README )
pkg_pretend() {
@@ -76,6 +77,13 @@ src_prepare() {
-e "s:/usr/local/lib:${EPREFIX}/usr/local/$(get_libdir):" \
-i src/${PN}.h || die "sed ${PN}.h failed"
+ delete_locale() {
+ local locale=${1}
+ rm -f po/${locale}{.po,.mo} || die
+ }
+
+ plocale_for_each_disabled_locale delete_locale
+
default
}