summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/helm/helm-3.10.1.ebuild')
-rw-r--r--app-admin/helm/helm-3.10.1.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/app-admin/helm/helm-3.10.1.ebuild b/app-admin/helm/helm-3.10.1.ebuild
deleted file mode 100644
index bc68205d21a4..000000000000
--- a/app-admin/helm/helm-3.10.1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-inherit bash-completion-r1 go-module
-GIT_COMMIT=9f88ccb6aee40b9a0535fcc7efea6055e1ef72c9
-GIT_SHA=9f88ccb6
-MY_PV=${PV/_rc/-rc.}
-
-DESCRIPTION="Kubernetes Package Manager"
-HOMEPAGE="https://github.com/helm/helm https://helm.sh"
-SRC_URI="https://github.com/helm/helm/archive/v${MY_PV}.tar.gz -> k8s-${P}.tar.gz"
-SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
-
-LICENSE="Apache-2.0 BSD BSD-2 CC-BY-4.0 CC-BY-SA-4.0 ISC MIT ZLIB"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~loong ~riscv"
-
-RESTRICT=" test"
-
-src_compile() {
- emake \
- GOFLAGS="${GOFLAGS}" \
- LDFLAGS="" \
- GIT_COMMIT=${GIT_COMMIT} \
- GIT_SHA=${GIT_SHA} \
- GIT_TAG=v${MY_PV} \
- GIT_DIRTY=clean \
- build
- bin/${PN} completion bash > ${PN}.bash || die
- bin/${PN} completion zsh > ${PN}.zsh || die
-}
-
-src_install() {
- newbashcomp ${PN}.bash ${PN}
- insinto /usr/share/zsh/site-functions
- newins ${PN}.zsh _${PN}
-
- dobin bin/${PN}
- dodoc README.md
-}