summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/keepass')
-rw-r--r--app-admin/keepass/Manifest2
-rw-r--r--app-admin/keepass/files/keepass-2.53-xsl-path-detection.patch22
-rw-r--r--app-admin/keepass/keepass-2.49.ebuild6
-rw-r--r--app-admin/keepass/keepass-2.53.ebuild116
-rw-r--r--app-admin/keepass/keepass-2.56.ebuild116
-rw-r--r--app-admin/keepass/metadata.xml5
6 files changed, 260 insertions, 7 deletions
diff --git a/app-admin/keepass/Manifest b/app-admin/keepass/Manifest
index 92b3d0126d99..1c35ecef078a 100644
--- a/app-admin/keepass/Manifest
+++ b/app-admin/keepass/Manifest
@@ -1 +1,3 @@
DIST KeePass-2.49-Source.zip 5135190 BLAKE2B bf5a9aab0065a97545bd1b81a74b5ab113e4c4802873445719ce2a571745b04c69ab5d8be9a67dc59a713947f0955cbcccc782b6628f722a0d564283b943eee6 SHA512 7a25de6acb2637bd8820fb70866ab4ced4ece4b3e64172f616c2fb59d2a4e7a2f340435db10731ed3d7e66db7761487925cf1c7941b0bac12e72c5fcd9e8b7d3
+DIST KeePass-2.53-Source.zip 5201820 BLAKE2B a87918278915f1a54d8f6d6b8ef05d5a86f41a58887a1c80a8217112061fd40d59393012ae7b69d6c2110a7b0b36c57ecce4292a68e9161e99e1762b1622192e SHA512 8d35ec83ada7142e91be6a5889eabb98f1d8fe32140a3b904db76d64f42bed0ce1cc0378f38560b7f1307df545f00a398da599ef9fc44474e8c16722433d4e4e
+DIST KeePass-2.56-Source.zip 5231868 BLAKE2B d7ed0baf6db6a0398ce9bceb9a61088ef7cc14ba0c5b13a01123f9c7fca37e52bf352c438c3100ba32d59cfcfa90de790a07649684a971224bba6eb554cbed34 SHA512 cee9d8569e59a29044760dc94c4ab3ee6f1eb26aaa12d18a36d9e1b87e421291b49a3747fdb340a7af06494d65fe4d37579f16a577b0af2c053504b80e8a1c60
diff --git a/app-admin/keepass/files/keepass-2.53-xsl-path-detection.patch b/app-admin/keepass/files/keepass-2.53-xsl-path-detection.patch
new file mode 100644
index 000000000000..3fed7593a1de
--- /dev/null
+++ b/app-admin/keepass/files/keepass-2.53-xsl-path-detection.patch
@@ -0,0 +1,22 @@
+--- a/KeePass/Forms/AboutForm.cs
++++ b/KeePass/Forms/AboutForm.cs
+@@ -135,7 +135,18 @@
+ m_lvComponents.Columns.Add(strValueColumn, 100);
+
+ string strExe = WinUtil.GetExecutable();
+- string strDir = UrlUtil.GetFileDirectory(strExe, true, false);
++ string strDir = null;
++ if (KeePassLib.Native.NativeLib.IsUnix())
++ {
++ string strBPath = Environment.GetFolderPath(Environment.SpecialFolder.CommonApplicationData);
++ strBPath = UrlUtil.EnsureTerminatingSeparator(strBPath, false);
++ strBPath += PwDefs.ShortProductName.ToLower();
++ strDir = UrlUtil.EnsureTerminatingSeparator(strBPath, false);
++ }
++ else
++ {
++ strDir = UrlUtil.GetFileDirectory(strExe, true, false);
++ }
+
+ AddComponentItem(PwDefs.ShortProductName, strMainVersion, strExe);
+
diff --git a/app-admin/keepass/keepass-2.49.ebuild b/app-admin/keepass/keepass-2.49.ebuild
index 7d5fde39dc39..218b7363d31b 100644
--- a/app-admin/keepass/keepass-2.49.ebuild
+++ b/app-admin/keepass/keepass-2.49.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -8,12 +8,12 @@ inherit desktop optfeature wrapper xdg-utils
MY_PN="KeePass"
DESCRIPTION="A free, open source, light-weight and easy-to-use password manager"
HOMEPAGE="https://keepass.info/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-${PV}-Source.zip"
+SRC_URI="https://downloads.sourceforge.net/${PN}/${MY_PN}-${PV}-Source.zip"
S="${WORKDIR}"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 x86"
+KEYWORDS="amd64 ~arm64 x86"
IUSE="aot"
BDEPEND="app-arch/unzip"
diff --git a/app-admin/keepass/keepass-2.53.ebuild b/app-admin/keepass/keepass-2.53.ebuild
new file mode 100644
index 000000000000..d5f8f014254f
--- /dev/null
+++ b/app-admin/keepass/keepass-2.53.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop optfeature wrapper xdg-utils
+
+MY_PN="KeePass"
+DESCRIPTION="A free, open source, light-weight and easy-to-use password manager"
+HOMEPAGE="https://keepass.info/"
+SRC_URI="https://downloads.sourceforge.net/${PN}/${MY_PN}-${PV}-Source.zip"
+S="${WORKDIR}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE="aot"
+
+BDEPEND="app-arch/unzip"
+DEPEND="dev-lang/mono"
+RDEPEND="
+ ${DEPEND}
+ dev-dotnet/libgdiplus[cairo]
+"
+
+PATCHES=( "${FILESDIR}/${PN}-2.53-xsl-path-detection.patch" )
+
+# bug #687052
+# file generated by mono --aot where *FLAGS don't make sense
+QA_PREBUILT="usr/lib64/keepass/KeePass.exe.so"
+
+src_prepare() {
+ # KeePass looks for some XSL files in the same folder as the executable,
+ # we prefer to have it in /usr/share/KeePass. Apply patch using base function.
+ # This XSL file will not be upstreamed since the KeePass creator said that
+ # including this patch would break the Portable USB version of KeePass
+ # (which keeps/looks for xsl files in its own folder)
+ default
+
+ # Switch into build dir so the mono prepration script works correctly
+ pushd Build || die
+ source PrepMonoDev.sh || die
+ popd || die
+}
+
+src_compile() {
+ export MONO_REGISTRY_PATH=/dev/null # bug 659808
+
+ # bug 704358
+ export LANG=C LC_ALL=C
+
+ # Build with Release target
+ xbuild /target:KeePass /property:Configuration=Release || die
+
+ # Run Ahead Of Time compiler on the binary
+ if use aot; then
+ cp Ext/KeePass.exe.config Build/KeePass/Release/ || die
+ mono --aot -O=all Build/KeePass/Release/KeePass.exe || die
+ fi
+}
+
+src_install() {
+ # Wrapper script to launch mono
+ make_wrapper "${PN}" "mono /usr/$(get_libdir)/${PN}/KeePass.exe"
+
+ # Some XSL files
+ insinto "/usr/share/${PN}/XSL"
+ doins Ext/XSL/*
+
+ insinto "/usr/$(get_libdir)/${PN}"
+ exeinto "/usr/$(get_libdir)/${PN}"
+
+ doins Ext/KeePass.exe.config
+
+ # Default configuration, simply says to use user-specific configuration
+ doins Ext/KeePass.config.xml
+
+ # The actual executable
+ doexe Build/KeePass/Release/KeePass.exe
+
+ # Copy the AOT compilation result
+ if use aot; then
+ doexe Build/KeePass/Release/KeePass.exe.so
+ fi
+
+ # Prepare the icons
+ newicon -s 256 Ext/Icons_04_CB/Finals/plockb.png "${PN}.png"
+ newicon -s 256 -t gnome -c mimetypes Ext/Icons_04_CB/Finals/plockb.png "application-x-${PN}2.png"
+
+ # Create a desktop entry and associate it with the KeePass mime type
+ make_desktop_entry "${PN}" "${MY_PN}" "${PN}" "System;Security" "MimeType=application/x-keepass2;\nStartupWMClass=KeePass2;"
+
+ # MIME descriptor for .kdbx files
+ insinto /usr/share/mime/packages
+ doins "${FILESDIR}/${PN}.xml"
+
+ # sed, because patching this really sucks
+ sed -i 's/mono/mono --verify-all/g' "${D}/usr/bin/keepass" || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+
+ optfeature "enables autotype/autofill" x11-misc/xdotool
+
+ elog "Some systems may experience issues with copy and paste operations."
+ elog "If you encounter this, please install x11-misc/xsel."
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
diff --git a/app-admin/keepass/keepass-2.56.ebuild b/app-admin/keepass/keepass-2.56.ebuild
new file mode 100644
index 000000000000..6cde0c268a1d
--- /dev/null
+++ b/app-admin/keepass/keepass-2.56.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop optfeature wrapper xdg-utils
+
+MY_PN="KeePass"
+DESCRIPTION="A free, open source, light-weight and easy-to-use password manager"
+HOMEPAGE="https://keepass.info/"
+SRC_URI="https://downloads.sourceforge.net/${PN}/${MY_PN}-${PV}-Source.zip"
+S="${WORKDIR}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="aot"
+
+BDEPEND="app-arch/unzip"
+DEPEND="dev-lang/mono"
+RDEPEND="
+ ${DEPEND}
+ dev-dotnet/libgdiplus[cairo]
+"
+
+PATCHES=( "${FILESDIR}/${PN}-2.53-xsl-path-detection.patch" )
+
+# bug #687052
+# file generated by mono --aot where *FLAGS don't make sense
+QA_PREBUILT="usr/lib64/keepass/KeePass.exe.so"
+
+src_prepare() {
+ # KeePass looks for some XSL files in the same folder as the executable,
+ # we prefer to have it in /usr/share/KeePass. Apply patch using base function.
+ # This XSL file will not be upstreamed since the KeePass creator said that
+ # including this patch would break the Portable USB version of KeePass
+ # (which keeps/looks for xsl files in its own folder)
+ default
+
+ # Switch into build dir so the mono prepration script works correctly
+ pushd Build || die
+ source PrepMonoDev.sh || die
+ popd || die
+}
+
+src_compile() {
+ export MONO_REGISTRY_PATH=/dev/null # bug 659808
+
+ # bug 704358
+ export LANG=C LC_ALL=C
+
+ # Build with Release target
+ xbuild /target:KeePass /property:Configuration=Release || die
+
+ # Run Ahead Of Time compiler on the binary
+ if use aot; then
+ cp Ext/KeePass.exe.config Build/KeePass/Release/ || die
+ mono --aot -O=all Build/KeePass/Release/KeePass.exe || die
+ fi
+}
+
+src_install() {
+ # Wrapper script to launch mono
+ make_wrapper "${PN}" "mono /usr/$(get_libdir)/${PN}/KeePass.exe"
+
+ # Some XSL files
+ insinto "/usr/share/${PN}/XSL"
+ doins Ext/XSL/*
+
+ insinto "/usr/$(get_libdir)/${PN}"
+ exeinto "/usr/$(get_libdir)/${PN}"
+
+ doins Ext/KeePass.exe.config
+
+ # Default configuration, simply says to use user-specific configuration
+ doins Ext/KeePass.config.xml
+
+ # The actual executable
+ doexe Build/KeePass/Release/KeePass.exe
+
+ # Copy the AOT compilation result
+ if use aot; then
+ doexe Build/KeePass/Release/KeePass.exe.so
+ fi
+
+ # Prepare the icons
+ newicon -s 256 Ext/Icons_04_CB/Finals/plockb.png "${PN}.png"
+ newicon -s 256 -t gnome -c mimetypes Ext/Icons_04_CB/Finals/plockb.png "application-x-${PN}2.png"
+
+ # Create a desktop entry and associate it with the KeePass mime type
+ make_desktop_entry "${PN}" "${MY_PN}" "${PN}" "System;Security" "MimeType=application/x-keepass2;\nStartupWMClass=KeePass2;"
+
+ # MIME descriptor for .kdbx files
+ insinto /usr/share/mime/packages
+ doins "${FILESDIR}/${PN}.xml"
+
+ # sed, because patching this really sucks
+ sed -i 's/mono/mono --verify-all/g' "${D}/usr/bin/keepass" || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+
+ optfeature "enables autotype/autofill" x11-misc/xdotool
+
+ elog "Some systems may experience issues with copy and paste operations."
+ elog "If you encounter this, please install x11-misc/xsel."
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
diff --git a/app-admin/keepass/metadata.xml b/app-admin/keepass/metadata.xml
index 0de39b024dc7..390a212c5de7 100644
--- a/app-admin/keepass/metadata.xml
+++ b/app-admin/keepass/metadata.xml
@@ -1,10 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>kensington@gentoo.org</email>
- <name>Michael Palimaka</name>
- </maintainer>
+ <!-- maintainer-needed -->
<use>
<flag name="aot">Generate native code at build time, rather than runtime.</flag>
</use>