summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/linode-cli')
-rw-r--r--app-admin/linode-cli/Manifest2
-rw-r--r--app-admin/linode-cli/linode-cli-5.48.4.ebuild30
-rw-r--r--app-admin/linode-cli/linode-cli-5.49.1.ebuild45
-rw-r--r--app-admin/linode-cli/metadata.xml16
4 files changed, 93 insertions, 0 deletions
diff --git a/app-admin/linode-cli/Manifest b/app-admin/linode-cli/Manifest
new file mode 100644
index 000000000000..6d4f5deb8e8f
--- /dev/null
+++ b/app-admin/linode-cli/Manifest
@@ -0,0 +1,2 @@
+DIST linode_cli-5.48.4.tar.gz 142928 BLAKE2B 28b1c90bb0709afc594b7023ef846b6d59e0376730f05d9701ebbc6744376f33536ad5a6f53b7b26a25805b258dc58378a76b0e6a4157e149f83e691d862dec8 SHA512 b07a3612afc329fc346b523412ac03932c84213d6bc23726f4c0e5edc737100bf65ec84f8131943439444fee268646789dc4d135cd61b2362311d1ab18601c3e
+DIST linode_cli-5.49.1.tar.gz 146883 BLAKE2B b4124b84f812b00c93e09e7c91c128b7ff15fbaf3a5c487613dbc4d26b1c5f00f083f521d8501e9a8649d3dc970a6349100602586dbb4acec27a7859470ba3b1 SHA512 06859939ac0c65a152acc012c87c53322a2a8cc1d4267c5dd0526b8ed0ad2b7aad7f3df42e24657d9bcca4b3fa02956ec23ea0d90ce4f5f9b61247a5b288dc72
diff --git a/app-admin/linode-cli/linode-cli-5.48.4.ebuild b/app-admin/linode-cli/linode-cli-5.48.4.ebuild
new file mode 100644
index 000000000000..0e1692e8e982
--- /dev/null
+++ b/app-admin/linode-cli/linode-cli-5.48.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi
+
+DESCRIPTION="Linode Command Line Interface"
+HOMEPAGE="https://github.com/linode/linode-cli https://www.linode.com/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# Tests require network, a linode account and an API key.
+# WARNING: tests will incur costs and will wipe the account.
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/boto3[${PYTHON_USEDEP}]
+ dev-python/linode-metadata[${PYTHON_USEDEP}]
+ dev-python/openapi3[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ <dev-python/urllib3-3[${PYTHON_USEDEP}]
+"
diff --git a/app-admin/linode-cli/linode-cli-5.49.1.ebuild b/app-admin/linode-cli/linode-cli-5.49.1.ebuild
new file mode 100644
index 000000000000..21d1ca44d811
--- /dev/null
+++ b/app-admin/linode-cli/linode-cli-5.49.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi shell-completion
+
+DESCRIPTION="Official command-line interface for interacting with the Linode API"
+HOMEPAGE="https://github.com/linode/linode-cli https://www.linode.com/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# Tests require network, a linode account and an API key.
+# WARNING: tests will incur costs and will wipe the account.
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/boto3[${PYTHON_USEDEP}]
+ >=dev-python/linode-metadata-0.3[${PYTHON_USEDEP}]
+ dev-python/openapi3[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ <dev-python/urllib3-3[${PYTHON_USEDEP}]
+"
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ PYTHONPATH=. ${EPYTHON} linodecli completion bash > "${T}/${PN}".bash || die
+ PYTHONPATH=. ${EPYTHON} linodecli completion fish > "${T}/${PN}".fish || die
+
+ newbashcomp "${T}/${PN}".bash ${PN}
+ newfishcomp "${T}/${PN}".fish ${PN}
+
+ dosym ${PN} "$(get_bashcompdir)"/linode
+ dosym ${PN} "$(get_bashcompdir)"/lin
+ dosym ${PN} "$(get_fishcompdir)"/linode
+ dosym ${PN} "$(get_fishcompdir)"/lin
+}
diff --git a/app-admin/linode-cli/metadata.xml b/app-admin/linode-cli/metadata.xml
new file mode 100644
index 000000000000..d323d0d15b1e
--- /dev/null
+++ b/app-admin/linode-cli/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'https://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ceamac@gentoo.org</email>
+ <name>Viorel Munteanu</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">linode/linode-cli</remote-id>
+ <remote-id type="pypi">linode-cli</remote-id>
+ </upstream>
+</pkgmetadata>