summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/metalog/metalog-3-r2.ebuild')
-rw-r--r--app-admin/metalog/metalog-3-r2.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/app-admin/metalog/metalog-3-r2.ebuild b/app-admin/metalog/metalog-3-r2.ebuild
deleted file mode 100644
index 9c63681e4eee..000000000000
--- a/app-admin/metalog/metalog-3-r2.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-inherit eutils systemd
-
-DESCRIPTION="A highly configurable replacement for syslogd/klogd"
-HOMEPAGE="http://metalog.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86"
-IUSE="unicode"
-
-RDEPEND=">=dev-libs/libpcre-3.4"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- app-arch/xz-utils"
-
-PATCHES=( "${FILESDIR}"/${PN}-0.9-metalog-conf.patch )
-
-src_configure() {
- econf $(use_with unicode)
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc AUTHORS ChangeLog README NEWS metalog.conf
-
- into /
- dosbin "${FILESDIR}"/consolelog.sh
-
- newinitd "${FILESDIR}"/metalog.initd metalog
- newconfd "${FILESDIR}"/metalog.confd metalog
- systemd_newunit "${FILESDIR}/${PN}.service-r1" "${PN}.service"
-}
-
-pkg_preinst() {
- if [[ -d "${ROOT}"/etc/metalog ]] && [[ ! -e "${ROOT}"/etc/metalog.conf ]] ; then
- mv -f "${ROOT}"/etc/metalog/metalog.conf "${ROOT}"/etc/metalog.conf
- rmdir "${ROOT}"/etc/metalog
- export MOVED_METALOG_CONF=true
- else
- export MOVED_METALOG_CONF=false
- fi
-}
-
-pkg_postinst() {
- if ${MOVED_METALOG_CONF} ; then
- ewarn "The default metalog.conf file has been moved"
- ewarn "from /etc/metalog/metalog.conf to just"
- ewarn "/etc/metalog.conf. If you had a standard"
- ewarn "setup, the file has been moved for you."
- fi
-}