summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/passwordsafe')
-rw-r--r--app-admin/passwordsafe/Manifest4
-rw-r--r--app-admin/passwordsafe/files/passwordsafe-1.06_beta-system-gtest.patch69
-rw-r--r--app-admin/passwordsafe/passwordsafe-1.17.0.ebuild (renamed from app-admin/passwordsafe/passwordsafe-1.14.0-r1.ebuild)23
-rw-r--r--app-admin/passwordsafe/passwordsafe-1.18.2.ebuild (renamed from app-admin/passwordsafe/passwordsafe-1.13.0.ebuild)37
4 files changed, 26 insertions, 107 deletions
diff --git a/app-admin/passwordsafe/Manifest b/app-admin/passwordsafe/Manifest
index 27a57771a878..5301b99b1991 100644
--- a/app-admin/passwordsafe/Manifest
+++ b/app-admin/passwordsafe/Manifest
@@ -1,2 +1,2 @@
-DIST passwordsafe-1.13.0.tar.gz 15022877 BLAKE2B 353976c22365fc98c034eac339f067061ee659043ab8507bbec174483414619b8442ba4fd7671e888127b83e9865d21587529c7821bd706a55da951c300425d4 SHA512 eb8ae46e9f3e8287b2ad781ed6d6e13026096a35fadc1fd1da1116e5e6b65e16e76090d8e7d1c64be387229ccd1053dcc820acbe7ee97914e46c311ee8ff03b8
-DIST passwordsafe-1.14.0.tar.gz 15303935 BLAKE2B 977386e5c469772753173bd46f608e9fb77e462706fbe6bf80a18cf8e5f3b89cc7300f92298b2b45885dafbef323a0ba59d67ddcea20c229f4f9520a54800653 SHA512 958ab87ac6a9066a0359890facd509c1085646eddcefc33f89b934a9375df51bcbc78213298d165d354c64618c8fb753c2588e386e886fa4c1c478e0a27d3d27
+DIST passwordsafe-1.17.0.tar.gz 15463920 BLAKE2B e64c73139c829b16b5f825d3c078f1cb3285cb15400be988e35b64e4ce701a5241e099a09092a576e487f709464b6fa5d5911f5f68e096d194329cd0214ac8cd SHA512 de1ef537c2f6c17e35d93a53cf46e86b7c1f1a4439282f8c2b98443845e3d381e113448acd739fc6ccdb5eee8ff7ebfd8c0e4306cda517ab623eaf5b9354d39d
+DIST passwordsafe-1.18.2.tar.gz 15613801 BLAKE2B e4ad44fe3aae6230c6a1d07e644b7b02831ec5bc815decd85050099c6f43e83bc09cd7d8f88ddfa5b63e5636db774f4b295bb34739e15115ba55c5142d3b08ae SHA512 09fb19133ff325832fa5d284aa1b1e7eda1788c4298424701132ede27fbb17956d874c0007ac00a2b9367d279175666744e192523ec79786baf626fb461abec7
diff --git a/app-admin/passwordsafe/files/passwordsafe-1.06_beta-system-gtest.patch b/app-admin/passwordsafe/files/passwordsafe-1.06_beta-system-gtest.patch
deleted file mode 100644
index b17385bdcd83..000000000000
--- a/app-admin/passwordsafe/files/passwordsafe-1.06_beta-system-gtest.patch
+++ /dev/null
@@ -1,69 +0,0 @@
---- a/CMakeLists.txt 2018-08-11 09:54:05.000000000 +0200
-+++ b/CMakeLists.txt 2018-08-22 10:48:06.422755215 +0200
-@@ -91,6 +91,7 @@
- # Configurable options:
- option (NO_YUBI "Set ON to disable YubiKey support" OFF)
- option (NO_GTEST "Set ON to disable gtest unit testing" OFF)
-+option (SYSTEM_GTEST "Set ON to use gtest provided by the system" OFF)
-
- if (WIN32)
- option (WX_WINDOWS "Build wxWidget under Windows" OFF)
-@@ -256,31 +257,36 @@
- endif (MSVC)
-
- if (NOT NO_GTEST)
-- # Download and unpack googletest at configure time
-- # See https://crascit.com/2015/07/25/cmake-gtest/
-- configure_file(Misc/CMakeLists.gtest.txt.in googletest-download/CMakeLists.txt)
-- execute_process(COMMAND "${CMAKE_COMMAND}" -G "${CMAKE_GENERATOR}" .
-+ if (NOT SYSTEM_GTEST)
-+ # Download and unpack googletest at configure time
-+ # See https://crascit.com/2015/07/25/cmake-gtest/
-+ configure_file(Misc/CMakeLists.gtest.txt.in googletest-download/CMakeLists.txt)
-+ execute_process(COMMAND "${CMAKE_COMMAND}" -G "${CMAKE_GENERATOR}" .
- WORKING_DIRECTORY "${CMAKE_BINARY_DIR}/googletest-download" )
-- execute_process(COMMAND "${CMAKE_COMMAND}" --build .
-+ execute_process(COMMAND "${CMAKE_COMMAND}" --build .
- WORKING_DIRECTORY "${CMAKE_BINARY_DIR}/googletest-download" )
-+ # Prevent GoogleTest from overriding our compiler/linker options
-+ # when building with Visual Studio
-+ set(gtest_force_shared_crt ON CACHE BOOL "" FORCE)
-+ # Set some other gtest configurations:
-+ set(BUILD_GMOCK OFF CACHE BOOL "" FORCE)
-+ set(BUILD_GTEST ON CACHE BOOL "" FORCE)
-+ set(INSTALL_GTEST OFF CACHE BOOL "" FORCE)
-+
-+ # Add googletest directly to our build. This adds
-+ # the following targets: gtest, gtest_main, gmock
-+ # and gmock_main
-+ add_subdirectory("${CMAKE_BINARY_DIR}/googletest-src"
-+ "${CMAKE_BINARY_DIR}/googletest-build")
-+
-+ include_directories("${gtest_SOURCE_DIR}/include"
-+# "${gmock_SOURCE_DIR}/include"
-+ )
-+ else (NOT SYSTEM_GTEST)
-+ find_package(GTest REQUIRED)
-+ set(GTEST_LIBRARIES ${GTEST_BOTH_LIBRARIES})
-+ endif(NOT SYSTEM_GTEST)
-
-- # Prevent GoogleTest from overriding our compiler/linker options
-- # when building with Visual Studio
-- set(gtest_force_shared_crt ON CACHE BOOL "" FORCE)
-- # Set some other gtest configurations:
-- set(BUILD_GMOCK OFF CACHE BOOL "" FORCE)
-- set(BUILD_GTEST ON CACHE BOOL "" FORCE)
-- set(INSTALL_GTEST OFF CACHE BOOL "" FORCE)
--
-- # Add googletest directly to our build. This adds
-- # the following targets: gtest, gtest_main, gmock
-- # and gmock_main
-- add_subdirectory("${CMAKE_BINARY_DIR}/googletest-src"
-- "${CMAKE_BINARY_DIR}/googletest-build")
--
-- include_directories("${gtest_SOURCE_DIR}/include"
--# "${gmock_SOURCE_DIR}/include"
-- )
- endif(NOT NO_GTEST)
-
- if (WIN32 AND NOT WX_WINDOWS)
diff --git a/app-admin/passwordsafe/passwordsafe-1.14.0-r1.ebuild b/app-admin/passwordsafe/passwordsafe-1.17.0.ebuild
index 89108fe1776f..fb5458c1a459 100644
--- a/app-admin/passwordsafe/passwordsafe-1.14.0-r1.ebuild
+++ b/app-admin/passwordsafe/passwordsafe-1.17.0.ebuild
@@ -1,27 +1,26 @@
-# Copyright 2021 Gentoo Authors
+# Copyright 2021-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
WX_GTK_VER="3.0-gtk3"
-inherit cmake desktop flag-o-matic optfeature wxwidgets xdg
+inherit cmake desktop optfeature wxwidgets xdg
MY_PV="${PV/_beta/BETA}"
DESCRIPTION="Password manager with wxGTK based frontend"
HOMEPAGE="https://pwsafe.org/ https://github.com/pwsafe/pwsafe/"
SRC_URI="https://github.com/pwsafe/pwsafe/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/pwsafe-${MY_PV}"
LICENSE="Artistic-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 ~arm64 ~x86"
IUSE="qr test +xml yubikey"
RESTRICT="!test? ( test )"
-DEPEND="
- dev-libs/openssl:0=
+RDEPEND="
net-misc/curl
- sys-apps/file
sys-apps/util-linux
x11-libs/libXt
x11-libs/libXtst
@@ -29,19 +28,15 @@ DEPEND="
qr? ( media-gfx/qrencode )
xml? ( dev-libs/xerces-c )
yubikey? ( sys-auth/ykpers )"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
BDEPEND="
app-arch/zip
+ dev-lang/perl
sys-devel/gettext
+ virtual/pkgconfig
test? ( dev-cpp/gtest )"
-S="${WORKDIR}/pwsafe-${MY_PV}"
-
-pkg_pretend() {
- einfo "Checking for -std=c++11 support in compiler"
- test-flags-CXX -std=c++11 > /dev/null || die
-}
-
src_configure() {
setup-wxwidgets
diff --git a/app-admin/passwordsafe/passwordsafe-1.13.0.ebuild b/app-admin/passwordsafe/passwordsafe-1.18.2.ebuild
index 68384c419018..9581dc5e6d16 100644
--- a/app-admin/passwordsafe/passwordsafe-1.13.0.ebuild
+++ b/app-admin/passwordsafe/passwordsafe-1.18.2.ebuild
@@ -1,27 +1,26 @@
-# Copyright 2021 Gentoo Authors
+# Copyright 2021-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-WX_GTK_VER="3.0-gtk3"
+WX_GTK_VER="3.2-gtk3"
-inherit cmake desktop flag-o-matic optfeature wxwidgets
+inherit cmake desktop optfeature wxwidgets xdg
MY_PV="${PV/_beta/BETA}"
DESCRIPTION="Password manager with wxGTK based frontend"
HOMEPAGE="https://pwsafe.org/ https://github.com/pwsafe/pwsafe/"
SRC_URI="https://github.com/pwsafe/pwsafe/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/pwsafe-${MY_PV}"
LICENSE="Artistic-2"
SLOT="0"
-KEYWORDS="amd64 ~x86"
+KEYWORDS="amd64 ~arm64 ~x86"
IUSE="qr test +xml yubikey"
RESTRICT="!test? ( test )"
-DEPEND="
- dev-libs/openssl:0=
+RDEPEND="
net-misc/curl
- sys-apps/file
sys-apps/util-linux
x11-libs/libXt
x11-libs/libXtst
@@ -29,30 +28,22 @@ DEPEND="
qr? ( media-gfx/qrencode )
xml? ( dev-libs/xerces-c )
yubikey? ( sys-auth/ykpers )"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
BDEPEND="
app-arch/zip
+ dev-lang/perl
sys-devel/gettext
+ virtual/pkgconfig
test? ( dev-cpp/gtest )"
-S="${WORKDIR}/pwsafe-${MY_PV}"
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.06_beta-system-gtest.patch"
-)
-
-pkg_pretend() {
- einfo "Checking for -std=c++11 support in compiler"
- test-flags-CXX -std=c++11 > /dev/null || die
-}
-
src_configure() {
setup-wxwidgets
local mycmakeargs=(
-DNO_QR=$(usex !qr)
-DNO_GTEST=$(usex !test)
- -DSYSTEM_GTEST=ON
+ -DGTEST_BUILD=OFF
-DXML_XERCESC=$(usex xml)
-DNO_YUBI=$(usex !yubikey)
)
@@ -83,10 +74,12 @@ src_install() {
insinto /usr/share/${PN}
doins -r xml
- doicon install/graphics/pwsafe.png
+ doicon -s 48 install/graphics/pwsafe.png
newmenu install/desktop/pwsafe.desktop ${PN}.desktop
}
pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
optfeature "on-screen keyboard for password entry" x11-misc/xvkbd
}