summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/paxtest/paxtest-0.9.15-r1.ebuild')
-rw-r--r--app-admin/paxtest/paxtest-0.9.15-r1.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/app-admin/paxtest/paxtest-0.9.15-r1.ebuild b/app-admin/paxtest/paxtest-0.9.15-r1.ebuild
index ed402aa9eaf8..4fe8a445c276 100644
--- a/app-admin/paxtest/paxtest-0.9.15-r1.ebuild
+++ b/app-admin/paxtest/paxtest-0.9.15-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=6
-inherit eutils multilib toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="PaX regression test suite"
HOMEPAGE="https://pax.grsecurity.net"
@@ -21,12 +21,15 @@ DEPEND="${RDEPEND}
# EI_PAX flags are not strip safe.
RESTRICT="strip"
+PATCHES=(
+ "${FILESDIR}/${PN}-0.9.13-Makefile.patch"
+)
+
src_prepare() {
mv Makefile.psm Makefile
- epatch "${FILESDIR}/${PN}-0.9.13-Makefile.patch"
+ default
sed -i "s/^CC := gcc/CC := $(tc-getCC)/" Makefile
sed -i "s/^LD := ld/LD := $(tc-getLD)/" Makefile
- eapply_user
}
src_compile() {