summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/paxtest')
-rw-r--r--app-admin/paxtest/metadata.xml5
-rw-r--r--app-admin/paxtest/paxtest-0.9.15-r2.ebuild (renamed from app-admin/paxtest/paxtest-0.9.15-r1.ebuild)17
2 files changed, 8 insertions, 14 deletions
diff --git a/app-admin/paxtest/metadata.xml b/app-admin/paxtest/metadata.xml
index 78cd07dfc29d..e57f785d5475 100644
--- a/app-admin/paxtest/metadata.xml
+++ b/app-admin/paxtest/metadata.xml
@@ -1,9 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>blueness@gentoo.org</email>
- </maintainer>
<maintainer type="project">
<email>hardened@gentoo.org</email>
<name>Gentoo Hardened</name>
diff --git a/app-admin/paxtest/paxtest-0.9.15-r1.ebuild b/app-admin/paxtest/paxtest-0.9.15-r2.ebuild
index 2919e526c917..0cc7aa297a4e 100644
--- a/app-admin/paxtest/paxtest-0.9.15-r1.ebuild
+++ b/app-admin/paxtest/paxtest-0.9.15-r2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit toolchain-funcs
@@ -12,11 +12,8 @@ SRC_URI="https://grsecurity.net/~spender/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
-RDEPEND=""
-DEPEND="${RDEPEND}
- sys-apps/paxctl"
+DEPEND="sys-apps/paxctl"
# EI_PAX flags are not strip safe.
RESTRICT="strip"
@@ -26,10 +23,10 @@ PATCHES=(
)
src_prepare() {
- mv Makefile.psm Makefile
+ mv Makefile.psm Makefile || die
default
- sed -i "s/^CC := gcc/CC := $(tc-getCC)/" Makefile
- sed -i "s/^LD := ld/LD := $(tc-getLD)/" Makefile
+ sed -e "s/^CC := gcc/CC := $(tc-getCC)/" -i Makefile || die
+ sed -e "s/^LD := ld/LD := $(tc-getLD)/" -i Makefile || die
}
src_compile() {
@@ -37,7 +34,7 @@ src_compile() {
}
src_install() {
- emake DESTDIR="${D}" BINDIR=/usr/bin RUNDIR=/usr/$(get_libdir)/paxtest install
+ emake DESTDIR="${ED}" BINDIR=/usr/bin RUNDIR=/usr/$(get_libdir)/paxtest install
newman debian/manpage.1.ex paxtest.1
dodoc ChangeLog README