summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/phpsyslogng')
-rw-r--r--app-admin/phpsyslogng/Manifest1
-rw-r--r--app-admin/phpsyslogng/files/postinstall-en.txt8
-rw-r--r--app-admin/phpsyslogng/metadata.xml12
-rw-r--r--app-admin/phpsyslogng/phpsyslogng-2.9.8m-r1.ebuild41
4 files changed, 62 insertions, 0 deletions
diff --git a/app-admin/phpsyslogng/Manifest b/app-admin/phpsyslogng/Manifest
new file mode 100644
index 000000000000..4262a5927c81
--- /dev/null
+++ b/app-admin/phpsyslogng/Manifest
@@ -0,0 +1 @@
+DIST php-syslog-ng-2.9.8m.tar.gz 6773000 SHA256 0e51ab75a39f06f49acd170cacc2a8003bd36b257cb241d651c5338d6bffd6e4 SHA512 4685ba47199efe30b8eca9d688604a60bf5284665d540322d6c190a385aa4e3644b633fc574a5f7a8da71a5d9778be0d0fb6f19e431f17903e1fb7eda33e419c WHIRLPOOL 8cd9b539290ab85605f23540d7aa898f629ea0cef177cf28edee9eeddcc2b2dc73fef201af90410f977ea9677ff13d805a38c8df93a1978b4d5704d116db1a10
diff --git a/app-admin/phpsyslogng/files/postinstall-en.txt b/app-admin/phpsyslogng/files/postinstall-en.txt
new file mode 100644
index 000000000000..655ac2e018bc
--- /dev/null
+++ b/app-admin/phpsyslogng/files/postinstall-en.txt
@@ -0,0 +1,8 @@
+phpsyslogng is installed. You will need to
+configure it by editing the config file:
+
+${MY_INSTALLDIR}/config/config.php
+
+Please read /usr/share/doc/${PN}-${PVR}/README.gz for
+more information relating to how to set
+phpsyslogng up on your system.
diff --git a/app-admin/phpsyslogng/metadata.xml b/app-admin/phpsyslogng/metadata.xml
new file mode 100644
index 000000000000..afbbc8783d41
--- /dev/null
+++ b/app-admin/phpsyslogng/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>matthias@dsx.at</email>
+ <name>Matthias Schöffmann</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">php-syslog-ng</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-admin/phpsyslogng/phpsyslogng-2.9.8m-r1.ebuild b/app-admin/phpsyslogng/phpsyslogng-2.9.8m-r1.ebuild
new file mode 100644
index 000000000000..4de4257ed11b
--- /dev/null
+++ b/app-admin/phpsyslogng/phpsyslogng-2.9.8m-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit webapp
+
+DESCRIPTION="php-syslog-ng is a log monitor designed to easily manage logs from many hosts"
+HOMEPAGE="http://php-syslog-ng.googlecode.com/"
+SRC_URI="http://php-syslog-ng.googlecode.com/files/php-syslog-ng-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="mysql"
+
+RDEPEND="virtual/httpd-php
+ mysql? ( >=virtual/mysql-4.1 )"
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc html/README html/CHANGELOG \
+ html/INSTALL-STEPS \
+ html/TROUBLESHOOTING-INSTALL
+ rm html/LICENSE html/README \
+ html/CHANGELOG html/INSTALL-STEPS \
+ html/TROUBLESHOOTING-INSTALL
+ insinto /usr/share/doc/${PF}
+ doins -r scripts/*
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r ./html/{.htaccess,*}
+
+ webapp_configfile "${MY_HTDOCSDIR}/config/config.php"
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}/config/"
+ webapp_serverowned -R "${MY_HTDOCSDIR}/jpcache/"
+
+ webapp_postinst_txt en "${FILESDIR}/postinstall-en.txt"
+
+ webapp_src_install
+}