summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/pprocm/pprocm-1.0-r4.ebuild')
-rw-r--r--app-admin/pprocm/pprocm-1.0-r4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-admin/pprocm/pprocm-1.0-r4.ebuild b/app-admin/pprocm/pprocm-1.0-r4.ebuild
new file mode 100644
index 000000000000..126c1a0902a8
--- /dev/null
+++ b/app-admin/pprocm/pprocm-1.0-r4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="PProcM"
+GIT_COMMIT="98ca63f43afb9ec8491cceb81f62850ff00379e0"
+
+DESCRIPTION="Ncurses-based program to monitor CPU, disk, network and memory usage"
+HOMEPAGE="https://github.com/ZachGoldberg/Perl-Proc-Monitor-PProcM/"
+SRC_URI="https://github.com/ZachGoldberg/Perl-Proc-Monitor-PProcM/archive/${GIT_COMMIT}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}/Perl-Proc-Monitor-PProcM-${GIT_COMMIT}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/IO-Pipely
+ dev-perl/POE
+ dev-perl/Sys-Statistics-Linux
+"
+
+src_install() {
+ newbin "${MY_PN}" "${PN}"
+ einstalldocs
+}