summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/pprocm')
-rw-r--r--app-admin/pprocm/Manifest1
-rw-r--r--app-admin/pprocm/metadata.xml5
-rw-r--r--app-admin/pprocm/pprocm-1.0-r3.ebuild (renamed from app-admin/pprocm/pprocm-1.0-r2.ebuild)21
-rw-r--r--app-admin/pprocm/pprocm-1.0-r4.ebuild29
4 files changed, 42 insertions, 14 deletions
diff --git a/app-admin/pprocm/Manifest b/app-admin/pprocm/Manifest
index 53596a95ad5d..74e5dccbdc34 100644
--- a/app-admin/pprocm/Manifest
+++ b/app-admin/pprocm/Manifest
@@ -1 +1,2 @@
DIST PProcM-1.0.tar.gz 29007 BLAKE2B 511934eedb0f2269d505affbe15d9ba151ba4e6647885787caf045bdb52080ca26072f5a8986e8fdbd12fc8a0516d9c35f0d0dfd1d42ec268777c1288c55b00f SHA512 d592455719babb9dd55c0d63ea097fb110747eb481e81b237779543f7bc90c8fcc0a4e7ecb94e3287afe9ac9f707e1e90c28ab634dd8d0e2bd7708aee8e79277
+DIST pprocm-1.0.tar.gz 13388 BLAKE2B 9ef3ce2965108397ad8de25d0f3f447edb32584a7767841ee14782904f124a69e492543f36ee809f19795ef3a3393ce02ac8491267a0e3d32729b9d8161a5f34 SHA512 72d816e2bf210b8724da12e360cd637cb7ed130ae36e0435900b3561bfdcad7a1b0656e2fb55c6778141193e0717308c726d1099dfbe677d93f1bbf8d1f4723f
diff --git a/app-admin/pprocm/metadata.xml b/app-admin/pprocm/metadata.xml
index 6f49eba8f496..f62d36ead7f1 100644
--- a/app-admin/pprocm/metadata.xml
+++ b/app-admin/pprocm/metadata.xml
@@ -1,5 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="github">ZachGoldberg/Perl-Proc-Monitor-PProcM</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/app-admin/pprocm/pprocm-1.0-r2.ebuild b/app-admin/pprocm/pprocm-1.0-r3.ebuild
index a91f192678ca..ce36cdee03d4 100644
--- a/app-admin/pprocm/pprocm-1.0-r2.ebuild
+++ b/app-admin/pprocm/pprocm-1.0-r3.ebuild
@@ -1,31 +1,26 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
MY_PN="PProcM"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="ncurses-based program to monitor CPU, disk, network and memory usage"
-HOMEPAGE="http://www.fusedcreations.com/PProcM/"
+HOMEPAGE="https://github.com/ZachGoldberg/Perl-Proc-Monitor-PProcM"
SRC_URI="http://www.fusedcreations.com/PProcM/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-DEPEND="
+RDEPEND="
+ dev-lang/perl
+ dev-perl/IO-Pipely
dev-perl/POE
dev-perl/Sys-Statistics-Linux
- dev-perl/IO-Pipely
- dev-lang/perl"
-
-RDEPEND="
- ${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS=( AUTHORS README )
+"
src_install() {
newbin "${MY_PN}" "${PN}"
diff --git a/app-admin/pprocm/pprocm-1.0-r4.ebuild b/app-admin/pprocm/pprocm-1.0-r4.ebuild
new file mode 100644
index 000000000000..126c1a0902a8
--- /dev/null
+++ b/app-admin/pprocm/pprocm-1.0-r4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="PProcM"
+GIT_COMMIT="98ca63f43afb9ec8491cceb81f62850ff00379e0"
+
+DESCRIPTION="Ncurses-based program to monitor CPU, disk, network and memory usage"
+HOMEPAGE="https://github.com/ZachGoldberg/Perl-Proc-Monitor-PProcM/"
+SRC_URI="https://github.com/ZachGoldberg/Perl-Proc-Monitor-PProcM/archive/${GIT_COMMIT}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}/Perl-Proc-Monitor-PProcM-${GIT_COMMIT}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/IO-Pipely
+ dev-perl/POE
+ dev-perl/Sys-Statistics-Linux
+"
+
+src_install() {
+ newbin "${MY_PN}" "${PN}"
+ einstalldocs
+}