summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/pydf/pydf-12-r2.ebuild')
-rw-r--r--app-admin/pydf/pydf-12-r2.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/app-admin/pydf/pydf-12-r2.ebuild b/app-admin/pydf/pydf-12-r2.ebuild
index d7c8357b072c..08f2836810a4 100644
--- a/app-admin/pydf/pydf-12-r2.ebuild
+++ b/app-admin/pydf/pydf-12-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit python-r1
@@ -13,12 +13,11 @@ SRC_URI="http://kassiopeia.juls.savba.sk/~garabik/software/pydf/${PN}_${PV}.tar.
LICENSE="public-domain"
SLOT="0"
-KEYWORDS="amd64 arm ~arm64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
+KEYWORDS="amd64 arm ~arm64 ppc ppc64 ~riscv x86 ~amd64-linux ~x86-linux"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="${PYTHON_DEPS}"
-RDEPEND="${DEPEND}"
+RDEPEND="${PYTHON_DEPS}"
+BDEPEND="${RDEPEND}"
src_prepare() {
default