summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/qpage/files')
-rw-r--r--app-admin/qpage/files/qpage28
-rw-r--r--app-admin/qpage/files/qpage-3.3-fix-build-system.patch21
-rw-r--r--app-admin/qpage/files/qpage-3.3-fix-warning.patch12
-rw-r--r--app-admin/qpage/files/qpage-3.3-gentoo.patch72
4 files changed, 0 insertions, 133 deletions
diff --git a/app-admin/qpage/files/qpage b/app-admin/qpage/files/qpage
deleted file mode 100644
index 81ffe86d9950..000000000000
--- a/app-admin/qpage/files/qpage
+++ /dev/null
@@ -1,28 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-depend() {
- need net
-}
-
-checkconfig() {
- if [ ! -e /etc/qpage/qpage.cf ] ; then
- eerror "You need a /etc/qpage/qpage.cf file first."
- eerror "There is a sample file in /etc/qpage/."
- return 1
- fi
-}
-
-start() {
- checkconfig || return 1
- ebegin "Starting qpage"
- start-stop-daemon --start --quiet --exec /usr/bin/qpage -- -q 10
- eend $?
-}
-
-stop() {
- ebegin "Stopping qpage"
- start-stop-daemon --stop --quiet --exec /usr/bin/qpage
- eend $?
-}
diff --git a/app-admin/qpage/files/qpage-3.3-fix-build-system.patch b/app-admin/qpage/files/qpage-3.3-fix-build-system.patch
deleted file mode 100644
index 0fd091df8e0e..000000000000
--- a/app-admin/qpage/files/qpage-3.3-fix-build-system.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -65,12 +65,12 @@
- @exit 1
-
- install: all
-- $(RM) $(bindir)/$(PROG)
-- $(MKDIR) -p $(bindir)
-- $(CP) $(PROG) $(bindir)
-- $(RM) $(mandir)/man1/$(PROG).1
-- $(MKDIR) -p $(mandir)/man1
-- $(CP) $(PROG).man $(mandir)/man1/$(PROG).1
-+ $(RM) $(DESTDIR)$(bindir)/$(PROG)
-+ $(MKDIR) -p $(DESTDIR)$(bindir)
-+ $(CP) $(PROG) $(DESTDIR)$(bindir)
-+ $(RM) $(DESTDIR)$(mandir)/man1/$(PROG).1
-+ $(MKDIR) -p $(DESTDIR)$(mandir)/man1
-+ $(CP) $(PROG).man $(DESTDIR)$(mandir)/man1/$(PROG).1
-
- # $(INSTALL) S99qpage /etc/rc3.d
- # ln /etc/rc3.d/S99qpage /etc/init.d/qpage
diff --git a/app-admin/qpage/files/qpage-3.3-fix-warning.patch b/app-admin/qpage/files/qpage-3.3-fix-warning.patch
deleted file mode 100644
index 722677648250..000000000000
--- a/app-admin/qpage/files/qpage-3.3-fix-warning.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -urN qpage-3.3.orig/srvrsnpp.c qpage-3.3/srvrsnpp.c
---- qpage-3.3.orig/srvrsnpp.c 1998-10-25 14:55:05.000000000 -0500
-+++ qpage-3.3/srvrsnpp.c 2006-01-25 15:49:57.000000000 -0500
-@@ -1061,7 +1061,7 @@
- if (ptr && strcmp(ptr, STRING_UNKNOWN) != 0)
- p->ident = strdup(ptr);
-
-- ptr = eval_hostinfo(&request.client);
-+ ptr = eval_hostinfo(&request.client[0]);
-
- if (ptr && strcmp(ptr, STRING_UNKNOWN) != 0)
- p->hostname = strdup(ptr);
diff --git a/app-admin/qpage/files/qpage-3.3-gentoo.patch b/app-admin/qpage/files/qpage-3.3-gentoo.patch
deleted file mode 100644
index 72baf899764e..000000000000
--- a/app-admin/qpage/files/qpage-3.3-gentoo.patch
+++ /dev/null
@@ -1,72 +0,0 @@
---- a/config.input
-+++ b/config.input
-@@ -20,7 +20,7 @@
- # See the QuickPage documentation for complete details about
- # the syntax of the configuration file.
- #
--QPAGE_CONFIG="/etc/qpage.cf"
-+QPAGE_CONFIG="/etc/qpage/qpage.cf"
-
-
- #
-@@ -41,7 +41,7 @@
- # copies of the configuration file. Only one filename
- # may be specified.
- #
--SNPP_SERVER_FILE="/etc/qpage.servers"
-+SNPP_SERVER_FILE="/etc/qpage/qpage.servers"
-
-
- #
---- a/qpage.man
-+++ b/qpage.man
-@@ -867,7 +867,7 @@
- must be able to detect when it's safe to send dial commands to the modem.
- .LP
- .SH FILES
--/etc/qpage.cf
-+/etc/qpage/qpage.cf
- .SH SEE ALSO
- .B RFC-1861
- .SH KNOWN BUGS
---- a/example.cf
-+++ b/example.cf
-@@ -21,7 +21,7 @@
- #
- # modem=<modem name>
- # text=<optional text, no whitespace allowed>
--# device=<modem device e.g. /dev/ttya>
-+# device=<modem device e.g. /dev/tts/0>
- # initcmd=<modem initialization command>
- # dialcmd=<modem dial command not including phone number>
- #
-@@ -64,14 +64,15 @@
-
- queuedir=/var/spool/qpage
-
-+lockdir=/var/lock/subsys/qpage
-+
- identtimeout=5
- snpptimeout=60
-
--modem=ttya device=/dev/cua/a
--modem=ttyb device=/dev/cua/b
-+modem=ttyS0 device=/dev/tts/0
-
- service=default
-- device=ttya,ttyb
-+ device=ttyS0
- baudrate=1200
- parity=even
- allowpid=yes
---- a/ixo.c
-+++ b/ixo.c
-@@ -192,7 +192,7 @@
- if ((i = read_modem(fd, seconds)) < 0)
- return(NULL);
-
-- if (i == '\r') {
-+ if (i == '\r' || i == '\n') {
- *ptr = '\0';
- got_full_packet++;
- }