summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/radmind')
-rw-r--r--app-admin/radmind/Manifest2
-rw-r--r--app-admin/radmind/files/radmind-1.15.4-autoreconf-libsnet.patch276
-rw-r--r--app-admin/radmind/files/radmind-1.15.4-autoreconf.patch395
-rw-r--r--app-admin/radmind/metadata.xml1
-rw-r--r--app-admin/radmind/radmind-1.15.3-r1.ebuild26
-rw-r--r--app-admin/radmind/radmind-1.15.4-r1.ebuild57
6 files changed, 730 insertions, 27 deletions
diff --git a/app-admin/radmind/Manifest b/app-admin/radmind/Manifest
index e5cfe77288e0..ca8f483d7a92 100644
--- a/app-admin/radmind/Manifest
+++ b/app-admin/radmind/Manifest
@@ -1 +1 @@
-DIST radmind-1.15.3.tar.gz 843033 BLAKE2B 3d4446e5ce9e668039277f63a16c014dbbecca870886e68603af4100cdbf4a0adf074d26c90985968ec1a680fb483395676b85020134ec56686318b3d0664d99 SHA512 121fa2ea4dc9532bdbb1440c3ee485db1d6a1e770bd01dc0e832d51ee26112441ff47bea8e7f063feffc4d5bf3cfc5ce53d316bb469ff4ff0a65ca5463c99d11
+DIST radmind-1.15.4.tar.gz 413132 BLAKE2B 1327b429e12b09d49866e393b344ec7e2c471313a9437e5cb979f25674c7871948a0a4374c05d4939a697702675df70279ac476b3ed6a437b99afe5c98918e25 SHA512 538165123dfebc5c3890ae0864bc32988170e5235093d291a18ea7cf86eb50e9cf90c8a0530ae4b72611e95b5faa9474561f411ad646374173ee7b14235b5a5b
diff --git a/app-admin/radmind/files/radmind-1.15.4-autoreconf-libsnet.patch b/app-admin/radmind/files/radmind-1.15.4-autoreconf-libsnet.patch
new file mode 100644
index 000000000000..a33003b33424
--- /dev/null
+++ b/app-admin/radmind/files/radmind-1.15.4-autoreconf-libsnet.patch
@@ -0,0 +1,276 @@
+From c91010238967d6042f2fffd3dd00b436ba5a39f0 Mon Sep 17 00:00:00 2001
+From: orbea <orbea@riseup.net>
+Date: Thu, 12 May 2022 22:41:54 -0700
+Subject: [PATCH] Upstream-PR: https://sourceforge.net/p/libsnet/patches/7/
+
+Restore missing parts from aclocal.m4
+
+* Uses pkg-config for libsasl, libssl and zlib
+* Restores CHECK_PROFILED
+* Removes broken legacy osx macros
+
+The legacy CHECK_SASL, CHECK_SSL and CHECK_ZLIB macros
+have problems with adding hardcoded -L linker directories
+to the LDFLAGS which is inappropriate on modern systems.
+Using pkg-config avoids this problem.
+
+When setting LIBTOOL in the environment to slibtool the
+profiled libraries will fail to build because of the ../
+prepended to the $(LIBTOOL) variable. This was expoed when
+building radmind which includes libsnet as a submodule.
+
+Gentoo Bug: https://bugs.gentoo.org/show_bug.cgi?id=779664
+---
+ libsnet/Makefile.in | 29 +++++++++++++++--------------
+ libsnet/configure.ac | 22 +++++++++++++++++-----
+ libsnet/m4/profiled.m4 | 16 ++++++++++++++++
+ 3 files changed, 48 insertions(+), 19 deletions(-)
+ create mode 100644 m4/profiled.m4
+
+diff --git a/libsnet/Makefile.in b/libsnet/Makefile.in
+index 8af7eaf..2c7932e 100644
+--- a/libsnet/Makefile.in
++++ b/libsnet/Makefile.in
+@@ -14,8 +14,9 @@ LOBJ = snet.lo
+ INCPATH= @CPPFLAGS@ -I.
+ DEFS=
+ OPTOPTS= @OPTOPTS@
+-CFLAGS= ${DEFS} ${OPTOPTS} ${INCPATH} @CFLAGS@
+-LDFLAGS= @LDFLAGS@
++CFLAGS= ${DEFS} ${OPTOPTS} ${INCPATH} \
++ @sasl_CFLAGS@ @ssl_CFLAGS@ @zlib_CFLAGS@ @CFLAGS@
++LDFLAGS= @LDFLAGS@ @sasl_LIBS@ @ssl_LIBS@ @zlib_LIBS@
+ PROFILED= @PROFILED@
+ CC= @CC@
+
+@@ -31,31 +32,31 @@ DISTDIR= ../libsnet-${VERSION}
+ .SUFFIXES: .o .lo
+
+ .c.o:
+- $(LIBTOOL) --mode=compile \
++ $(LIBTOOL) --mode=compile --tag=CC \
+ $(CC) -c $(CFLAGS) $<
+ @if test x_$(PROFILED) = x_true ; then echo "building profiled $@" ; \
+- ( mkdir -p profiled; cd profiled ; ../$(LIBTOOL) --mode=compile \
++ mkdir -p profiled; $(LIBTOOL) --mode=compile --tag=CC \
+ $(CC) -c $(CFLAGS) -p -I.. -I$(srcdir) `if [ -f $< ]; then echo $<; \
+- else echo ../$<; fi` >/dev/null 2>&1 ) ; fi
++ else echo ../$<; fi` >/dev/null 2>&1 ; fi
+
+ .c.lo:
+- $(LIBTOOL) --mode=compile \
++ $(LIBTOOL) --mode=compile --tag=CC \
+ $(CC) -c $(CFLAGS) $<
+ @if test x_$(PROFILED) = x_true ; then echo "building profiled $@" ; \
+- ( mkdir -p profiled; cd profiled ; ../$(LIBTOOL) --mode=compile \
++ mkdir -p profiled; $(LIBTOOL) --mode=compile --tag=CC \
+ $(CC) -c $(CFLAGS) -p -I.. -I$(srcdir) `if [ -f $< ]; then echo $<; \
+- else echo ../$<; fi` >/dev/null 2>&1 ) ; fi
++ else echo ../$<; fi` >/dev/null 2>&1 ; fi
+
+
+ all: libsnet.la
+
+ libsnet.la: $(OBJ) $(LOBJ)
+- $(LIBTOOL) --mode=link \
++ $(LIBTOOL) --mode=link --tag=CC \
+ $(CC) -o libsnet.la $(LDFLAGS) $(LOBJ) -rpath $(libdir) -version-info 0:0:0
+ @if test x_$(PROFILED) = x_true ; then echo "building profiled $@" ; \
+- ( cd profiled ; ../$(LIBTOOL) --mode=link \
+- $(CC) -o libsnet_p.la $(LDFLAGS) $(LOBJ) -rpath $(libdir) \
+- -version-info 0:0:0 >/dev/null 2>&1 ) ; fi
++ $(LIBTOOL) --mode=link --tag=CC \
++ $(CC) -o profiled/libsnet_p.la $(LDFLAGS) $(LOBJ) -rpath $(libdir) \
++ -version-info 0:0:0 >/dev/null 2>&1 ; fi
+
+ install: all
+ mkdir -p $(libdir)
+@@ -67,8 +68,8 @@ install: all
+ $(INSTALL) -c -m 644 libsnet.la $(libdir)/libsnet.la
+ @if test x_$(PROFILED) = x_true ; then \
+ echo "installing profiled libraries" ; \
+- ( cd profiled ; ../$(LIBTOOL) --mode=install \
+- $(INSTALL) -c -m 644 libsnet_p.la \
++ $(LIBTOOL) --mode=install \
++ $(INSTALL) -c -m 644 profiled/libsnet_p.la \
+ $(libdir)/libsnet_p.la >/dev/null 2>&1 ) ; fi
+
+ clean:
+diff --git a/libsnet/configure.ac b/libsnet/configure.ac
+index df612d4..83f7e59 100644
+--- a/libsnet/configure.ac
++++ b/libsnet/configure.ac
+@@ -1,6 +1,7 @@
+ # Process this file with autoconf to produce a configure script.
+ AC_INIT(libsnet,VERSION,rsug@umich.edu)
+ AC_CONFIG_HEADER(config.h)
++AC_CONFIG_MACRO_DIR([m4])
+ AC_PREREQ(2.52)
+ AC_COPYRIGHT([Copyright (c) 1995-2003 Regents of The University of Michigan. All Rights Reserved.])
+ AC_CONFIG_SRCDIR([snet.c])
+@@ -10,15 +11,26 @@ AC_PROG_AWK
+ AC_PROG_CC
+ AC_PROG_INSTALL
+
+-CHECK_ZLIB
++PKG_CHECK_MODULES([zlib], [zlib],
++ [AC_DEFINE([HAVE_ZLIB], [1], [zlib])],
++ [AC_MSG_WARN(zlib.pc not found, building without zlib support)])
++AC_SUBST([zlib_LIBS])
++AC_SUBST([zlib_CFLAGS])
+
+ # Checks for libraries.
+ if test \! x_$with_ssl = x_no; then
+- AC_CHECK_LIB([ssl], [SSL_accept], , [CHECK_SSL])
+- AC_CHECK_LIB([crypto], [SSLeay_version], , [CHECK_SSL])
++ PKG_CHECK_MODULES([ssl], [openssl],
++ [AC_DEFINE([HAVE_LIBSSL], [1], [libssl])],
++ [AC_MSG_WARN(openssl.pc not found, building without libssl support)])
++ AC_SUBST([ssl_LIBS])
++ AC_SUBST([ssl_CFLAGS])
+ fi
+-CHECK_SASL
+-CHECK_UNIVERSAL_BINARIES
++
++PKG_CHECK_MODULES([sasl], [libsasl2],
++ [AC_DEFINE([HAVE_LIBSASL], [1], [libsasl])],
++ [AC_MSG_WARN(libsasl2.pc not found, building without libsasl support)])
++AC_SUBST([sasl_LIBS])
++AC_SUBST([sasl_CFLAGS])
+
+ # Checks for header files.
+ #AC_HEADER_STDC
+diff --git a/libsnet/m4/profiled.m4 b/libsnet/m4/profiled.m4
+new file mode 100644
+index 0000000..88a421b
+--- /dev/null
++++ b/libsnet/m4/profiled.m4
+@@ -0,0 +1,16 @@
++AC_DEFUN([CHECK_PROFILED],
++[
++ # Allow user to control whether or not profiled libraries are built
++ AC_MSG_CHECKING(whether to build profiled libraries)
++ PROFILED=true
++ AC_ARG_ENABLE(profiled,
++ [ --enable-profiled build profiled libsnet (default=yes)],
++ [test x_$enable_profiled = x_no && PROFILED=false]
++ )
++ AC_SUBST(PROFILED)
++ if test x_$PROFILED = x_true ; then
++ AC_MSG_RESULT(yes)
++ else
++ AC_MSG_RESULT(no)
++ fi
++])
+--
+2.35.1
+
+From 4ea29130382b5ae8b9cf3e3dc8962da764f65377 Mon Sep 17 00:00:00 2001
+From: orbea <orbea@riseup.net>
+Date: Fri, 13 May 2022 13:41:49 -0700
+Subject: [PATCH 2/2] Add AC_ARG_ENABLE options for ssl, sasl and zlib
+
+---
+ configure.ac | 83 +++++++++++++++++++++++++++++++++++++++++-----------
+ 1 file changed, 66 insertions(+), 17 deletions(-)
+
+diff --git a/libsnet/configure.ac b/libsnet/configure.ac
+index 83f7e59..9cd16c7 100644
+--- a/libsnet/configure.ac
++++ b/libsnet/configure.ac
+@@ -11,26 +11,75 @@ AC_PROG_AWK
+ AC_PROG_CC
+ AC_PROG_INSTALL
+
+-PKG_CHECK_MODULES([zlib], [zlib],
+- [AC_DEFINE([HAVE_ZLIB], [1], [zlib])],
+- [AC_MSG_WARN(zlib.pc not found, building without zlib support)])
+-AC_SUBST([zlib_LIBS])
+-AC_SUBST([zlib_CFLAGS])
++# Enable features
++AC_ARG_ENABLE([sasl],
++ AS_HELP_STRING([--enable-sasl], [Build with crypto_sasl @<:@default=yes@:>@]),
++ [AS_CASE(${enableval}, [yes], [], [no], [],
++ [AC_MSG_ERROR([bad value '${enableval}' for --enable-sasl])])],
++ [enable_sasl=check])
+
+-# Checks for libraries.
+-if test \! x_$with_ssl = x_no; then
+- PKG_CHECK_MODULES([ssl], [openssl],
+- [AC_DEFINE([HAVE_LIBSSL], [1], [libssl])],
+- [AC_MSG_WARN(openssl.pc not found, building without libssl support)])
+- AC_SUBST([ssl_LIBS])
+- AC_SUBST([ssl_CFLAGS])
+-fi
++AC_ARG_ENABLE([ssl],
++ AS_HELP_STRING([--enable-ssl], [Build with openssl @<:@default=yes@:>@]),
++ [AS_CASE(${enableval}, [yes], [], [no], [],
++ [AC_MSG_ERROR([bad value '${enableval}' for --enable-ssl])])],
++ [enable_ssl=check])
+
+-PKG_CHECK_MODULES([sasl], [libsasl2],
+- [AC_DEFINE([HAVE_LIBSASL], [1], [libsasl])],
+- [AC_MSG_WARN(libsasl2.pc not found, building without libsasl support)])
+-AC_SUBST([sasl_LIBS])
++AC_ARG_ENABLE([zlib],
++ AS_HELP_STRING([--enable-zlib], [Build with zlib @<:@default=yes@:>@]),
++ [AS_CASE(${enableval}, [yes], [], [no], [],
++ [AC_MSG_ERROR([bad value '${enableval}' for --enable-zlib])])],
++ [enable_zlib=check])
++
++# Checks for crypto_sasl.
++AS_IF([test x$enable_sasl != xno],
++ [PKG_CHECK_MODULES([sasl], [libsasl2],
++ [AC_DEFINE([HAVE_LIBSASL], [1], [libsasl])],
++ [AS_IF([test x$enable_sasl != xyes],
++ [AC_MSG_WARN([cannot find libsasl2.pc, disabling libsasl support])],
++ [enable_sasl=error])
++ ])
++ ])
++
++AS_IF([test x$enable_sasl = xerror],
++ [AC_MSG_ERROR([cannot find libsasl2.pc and libsasl support requested])])
++
++AM_CONDITIONAL([ENABLE_LIBSASL], [test x$enable_sasl = xyes])
+ AC_SUBST([sasl_CFLAGS])
++AC_SUBST([sasl_LIBS])
++
++# Checks for openssl.
++AS_IF([test x$enable_ssl != xno],
++ [PKG_CHECK_MODULES([ssl], [openssl],
++ [AC_DEFINE([HAVE_LIBSSL], [1], [libssl])],
++ [AS_IF([test x$enable_ssl != xyes],
++ [AC_MSG_WARN([cannot find openssl.pc, disabling libssl support])],
++ [enable_ssl=error])
++ ])
++ ])
++
++AS_IF([test x$enable_ssl = xerror],
++ [AC_MSG_ERROR([cannot find openssl.pc and libssl support requested])])
++
++AM_CONDITIONAL([ENABLE_LIBSSL], [test x$enable_ssl = xyes])
++AC_SUBST([ssl_CFLAGS])
++AC_SUBST([ssl_LIBS])
++
++# Checks for zlib.
++AS_IF([test x$enable_zlib != xno],
++ [PKG_CHECK_MODULES([zlib], [zlib],
++ [AC_DEFINE([HAVE_ZLIB], [1], [zlib])],
++ [AS_IF([test x$enable_zlib != xyes],
++ [AC_MSG_WARN([cannot find zlib.pc, disabling zlib support])],
++ [enable_zlib=error])
++ ])
++ ])
++
++AS_IF([test x$enable_zlib = xerror],
++ [AC_MSG_ERROR([cannot find zlib.pc and zlib support requested])])
++
++AM_CONDITIONAL([ENABLE_ZLIB], [test x$enable_zlib = xyes])
++AC_SUBST([zlib_CFLAGS])
++AC_SUBST([zlib_LIBS])
+
+ # Checks for header files.
+ #AC_HEADER_STDC
+--
+2.35.1
+
diff --git a/app-admin/radmind/files/radmind-1.15.4-autoreconf.patch b/app-admin/radmind/files/radmind-1.15.4-autoreconf.patch
new file mode 100644
index 000000000000..df983d074709
--- /dev/null
+++ b/app-admin/radmind/files/radmind-1.15.4-autoreconf.patch
@@ -0,0 +1,395 @@
+Upstream-PR: https://github.com/Radmind/radmind/pull/336
+Upstream-PR: https://github.com/voretaq7/radmind/pull/1
+
+From 335a7f35847da2ae366028cbc3fbdd01779f9d37 Mon Sep 17 00:00:00 2001
+From: orbea <orbea@riseup.net>
+Date: Thu, 12 May 2022 14:25:56 -0700
+Subject: [PATCH 2/4] Fix autoreconf-2.71
+
+---
+ configure.ac | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 38896af..3bbdabb 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -69,8 +69,8 @@ if test x$libc_inet_aton != xyes; then
+ AC_CHECK_LIB(resolv, inet_aton)
+ fi
+ if test x$host_vendor = xapply; then
+- AC_CHECK_LIB(c, lchown, [AC_DEFINE(HAVE_LCHOWN)], [])
+- AC_CHECK_LIB(c, lchmod, [AC_DEFINE(HAVE_LCHMOD)], [])
++ AC_CHECK_LIB(c, lchown, [AC_DEFINE([HAVE_LCHOWN], [], [lchown])])
++ AC_CHECK_LIB(c, lchmod, [AC_DEFINE([HAVE_LCHMOD], [], [lchmod])])
+ fi
+ AC_CHECK_LIB(nsl, gethostbyaddr)
+ AC_CHECK_LIB([socket], [socket])
+@@ -78,7 +78,7 @@ AC_CHECK_LIB([ssl], [SSL_accept], , [CHECK_SSL])
+ AC_CHECK_HEADER([openssl/ssl.h], [], [AC_MSG_ERROR([header file <openssl/ssl.h>
+ is required for this software. You may be running RedHat 9. If so, see the FAQ or the README for further instructions.])])
+ AC_CHECK_LIB([crypto], [SSLeay_version], , [CHECK_SSL])
+-AC_CHECK_LIB([crypto], [X509_VERIFY_PARAM_set_flags], [AC_DEFINE(HAVE_X509_VERIFY_PARAM)], [])
++AC_CHECK_LIB([crypto], [X509_VERIFY_PARAM_set_flags], [AC_DEFINE([HAVE_X509_VERIFY_PARAM], [], [X509_verify_param])])
+
+ # PAM
+ AC_ARG_WITH([pam], AC_HELP_STRING([--with-pam=PATH], [Pluggable Authentication Module support (default: /usr)]), [], with_pam=/usr)
+@@ -88,12 +88,12 @@ if test x_"$with_pam" != x_no; then
+ AC_CHECK_LIB([pam], [pam_start],
+ [
+ AC_CHECK_HEADERS(pam/pam_appl.h, , [AC_CHECK_HEADERS(security/pam_appl.h)])
+- AC_DEFINE(HAVE_LIBPAM)
++ AC_DEFINE([HAVE_LIBPAM], [], [libpam])
+ LIBS="$LIBS -lpam";
+ ]
+ )
+ fi
+-AC_CHECK_HEADER([dns_sd.h], [AC_DEFINE(HAVE_DNSSD)], [], [])
++AC_CHECK_HEADER([dns_sd.h], [AC_DEFINE([HAVE_DNSSD], [], [dnssd])])
+ AC_CHECK_LIB(dns_sd, DNSServiceRegister)
+
+ CHECK_ZLIB
+
+From dd731c6e7b55d62cf93df8d6c872a736785b3ac1 Mon Sep 17 00:00:00 2001
+From: orbea <orbea@riseup.net>
+Date: Thu, 12 May 2022 15:41:38 -0700
+Subject: [PATCH 3/4] Makefile.in: Use mkdir -p
+
+Silences trivial non-fatal errors during make
+---
+ Makefile.in | 20 ++++++++++----------
+ 1 file changed, 10 insertions(+), 10 deletions(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index 158a7cb..300f64c 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -256,10 +256,10 @@ VERSION=$(shell date +%Y%m%d)
+ DISTDIR=radmind-${VERSION}
+
+ dist : distclean
+- mkdir ../${DISTDIR}
++ mkdir -p ../${DISTDIR}
+ tar -h -c -f - -X EXCLUDE . | tar xpf - -C ../${DISTDIR}
+ echo ${VERSION} > ../${DISTDIR}/VERSION
+- -mkdir ../${DISTDIR}/tmp
++ -mkdir -p ../${DISTDIR}/tmp
+ for i in ${MANTARGETS}; do \
+ sed -e 's@_RADMIND_BUILD_DATE@${RADMIND_BUILD_DATE}@g' \
+ ../${DISTDIR}/man/$$i > ../${DISTDIR}/tmp/$$i; \
+@@ -269,7 +269,7 @@ dist : distclean
+ (cd .. && tar cvfz ${DISTDIR}.tar.gz ${DISTDIR})
+
+ rash : FRC
+- -mkdir tmp
++ -mkdir -p tmp
+ sed -e 's@_RADMIND_HOST@${RADMIND_HOST}@g' \
+ -e 's@_RADMIND_AUTHLEVEL@${RADMIND_AUTHLEVEL}@g' \
+ -e 's@_RADMIND_PREAPPLY@${PREAPPLYDIR}@g' \
+@@ -283,8 +283,8 @@ rash : FRC
+ ${srcdir}/ra.sh > tmp/ra.sh;
+
+ man : FRC
+- -mkdir tmp
+- -mkdir tmp/man
++ -mkdir -p tmp
++ -mkdir -p tmp/man
+ pwd
+ for i in ${MANTARGETS}; do \
+ sed -e 's@_RADMIND_PATH@${RADMINDDIR}@g' \
+@@ -308,15 +308,15 @@ install : all man rash
+ ${INSTALL} -m 0755 -c tmp/ra.sh ${DESTDIR}/${BINDIR}/
+ -mkdir -p ${DESTDIR}/${prefix}
+ -mkdir -p ${DESTDIR}/${MANDIR}
+- -mkdir ${DESTDIR}/${MANDIR}/man1
++ -mkdir -p ${DESTDIR}/${MANDIR}/man1
+ for i in ${MAN1TARGETS}; do \
+ ${INSTALL} -m 0644 -c tmp/man/$$i ${DESTDIR}/${MANDIR}/man1/; \
+ done
+- -mkdir ${DESTDIR}/${MANDIR}/man5
++ -mkdir -p ${DESTDIR}/${MANDIR}/man5
+ for i in ${MAN5TARGETS}; do \
+ ${INSTALL} -m 0644 -c tmp/man/$$i ${DESTDIR}/${MANDIR}/man5/; \
+ done
+- -mkdir ${DESTDIR}/${MANDIR}/man8
++ -mkdir -p ${DESTDIR}/${MANDIR}/man8
+ for i in ${MAN8TARGETS}; do \
+ ${INSTALL} -m 0644 -c tmp/man/$$i ${DESTDIR}/${MANDIR}/man8/; \
+ done
+@@ -333,8 +333,8 @@ PKGSRCDIR=`pwd`
+ INFOLIST= $(wildcard OS_X/*.plist)
+
+ info :
+- -mkdir tmp
+- -mkdir tmp/OS_X
++ -mkdir -p tmp
++ -mkdir -p tmp/OS_X
+ for i in ${INFOLIST}; do \
+ sed -e 's@_RADMIND_VERSION@${VERSION}@g' \
+ $$i > tmp/$$i; \
+
+From 2a20542a9367fc9c7f34d275a471da1e503a78b1 Mon Sep 17 00:00:00 2001
+From: orbea <orbea@riseup.net>
+Date: Fri, 13 May 2022 00:07:30 -0700
+Subject: [PATCH 4/4] Use pkg-config to remove legacy macros
+
+The legacy macros CHECK_ZLIB and CHECK_SSL add many instances of
+hardcoded -L/usr/lib which is problematic on newer systems.
+
+It is better to use pkg-config so they are always found where expected.
+
+Also removed some totally broken legacy osx macros.
+---
+ Makefile.in | 5 +++--
+ configure.ac | 21 +++++++++++----------
+ 2 files changed, 14 insertions(+), 12 deletions(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index 300f64c..48ef9d2 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -39,11 +39,12 @@ INCPATH= @CPPFLAGS@ -I${srcdir}/libsnet -I.
+ OPTOPTS= @OPTOPTS@
+ CC= @CC@
+ DEFS=
+-LIBS= -lsnet @LIBS@
++LIBS= -lsnet @LIBS@ @ssl_LIBS@ @zlib_LIBS@
+ LDFLAGS= -Llibsnet/.libs @LDFLAGS@ ${LIBS}
+ INSTALL= @INSTALL@
+
+-CFLAGS= ${DEFS} ${OPTOPTS} @CFLAGS@ ${INCPATH}
++CFLAGS= ${DEFS} ${OPTOPTS} ${INCPATH} \
++ @ssl_CFLAGS@ @zlib_CFLAGS@ @CFLAGS@
+
+ BINTARGETS= fsdiff ktcheck lapply lcksum lcreate lmerge lfdiff repo \
+ twhich lsort
+diff --git a/configure.ac b/configure.ac
+index 3bbdabb..8a96de3 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -46,12 +46,6 @@ AC_SYS_LARGEFILE
+ AC_CHECK_SIZEOF(off_t)
+ AC_CHECK_SIZEOF(time_t)
+
+-# check early to make any required changes to environment for following tests.
+-CHECK_UNIVERSAL_BINARIES
+-
+-# mute Mac OS X's helpful notices that using dylib OpenSSL
+-MACOSX_MUTE_DEPRECATION_WARNINGS
+-
+ # Checks for header files
+
+ # glibc 2.25 still includes sys/sysmacros.h in sys/types.h but emits
+@@ -74,17 +68,20 @@ if test x$host_vendor = xapply; then
+ fi
+ AC_CHECK_LIB(nsl, gethostbyaddr)
+ AC_CHECK_LIB([socket], [socket])
+-AC_CHECK_LIB([ssl], [SSL_accept], , [CHECK_SSL])
++
++PKG_CHECK_MODULES([ssl], [openssl],
++ [AC_DEFINE([HAVE_LIBSSL], [1], [libssl])])
++AC_SUBST([ssl_LIBS])
++AC_SUBST([ssl_CFLAGS])
++
+ AC_CHECK_HEADER([openssl/ssl.h], [], [AC_MSG_ERROR([header file <openssl/ssl.h>
+ is required for this software. You may be running RedHat 9. If so, see the FAQ or the README for further instructions.])])
+-AC_CHECK_LIB([crypto], [SSLeay_version], , [CHECK_SSL])
+ AC_CHECK_LIB([crypto], [X509_VERIFY_PARAM_set_flags], [AC_DEFINE([HAVE_X509_VERIFY_PARAM], [], [X509_verify_param])])
+
+ # PAM
+ AC_ARG_WITH([pam], AC_HELP_STRING([--with-pam=PATH], [Pluggable Authentication Module support (default: /usr)]), [], with_pam=/usr)
+ if test x_"$with_pam" != x_no; then
+ CPPFLAGS="${CPPFLAGS} -I$with_pam/include"
+- LDFLAGS="${LDFLAGS} -L$with_pam/lib"
+ AC_CHECK_LIB([pam], [pam_start],
+ [
+ AC_CHECK_HEADERS(pam/pam_appl.h, , [AC_CHECK_HEADERS(security/pam_appl.h)])
+@@ -96,7 +93,11 @@ fi
+ AC_CHECK_HEADER([dns_sd.h], [AC_DEFINE([HAVE_DNSSD], [], [dnssd])])
+ AC_CHECK_LIB(dns_sd, DNSServiceRegister)
+
+-CHECK_ZLIB
++PKG_CHECK_MODULES([zlib], [zlib],
++ [AC_DEFINE([HAVE_ZLIB], [1], [zlib])],
++ [AC_MSG_WARN(zlib.pc not found, building without zlib support)])
++AC_SUBST([zlib_LIBS])
++AC_SUBST([zlib_CFLAGS])
+
+ # HPUX lacks wait4 and strtoll
+ AC_CHECK_FUNCS(wait4 strtoll)
+From d31a1c234e7d4f4d630c720024df8bdf911b1de4 Mon Sep 17 00:00:00 2001
+From: orbea <orbea@riseup.net>
+Date: Sat, 14 May 2022 03:30:35 -0700
+Subject: [PATCH 5/6] Disable sasl for libsnet
+
+This was previously set in aclocal.m4
+---
+ configure.ac | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 8a96de3..60a56fb 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -113,7 +113,9 @@ if test x_"$OPTOPTS" = x_; then
+ fi
+ AC_SUBST(OPTOPTS)
+
+-SET_NO_SASL
++ac_configure_args="$ac_configure_args --enable-sasl=no";
++AC_MSG_RESULT([Disabling SASL for libsnet])
++
+ AC_CONFIG_SUBDIRS(libsnet)
+ AC_CONFIG_FILES(Makefile)
+ AC_OUTPUT
+--
+2.35.1
+
+From 66e0cb1c85e16ff70cf68c27e39ae2ec31487183 Mon Sep 17 00:00:00 2001
+From: orbea <orbea@riseup.net>
+Date: Sat, 14 May 2022 09:33:31 -0700
+Subject: [PATCH 6/6] Add AC_ARG_ENABLE options for pam, ssl and zlib
+
+---
+ Makefile.in | 4 +--
+ configure.ac | 89 ++++++++++++++++++++++++++++++++++++++++------------
+ 2 files changed, 71 insertions(+), 22 deletions(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index ca01832..b2ef2b6 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -39,12 +39,12 @@ INCPATH= @CPPFLAGS@ -I${srcdir}/libsnet -I.
+ OPTOPTS= @OPTOPTS@
+ CC= @CC@
+ DEFS=
+-LIBS= -lsnet @LIBS@ @ssl_LIBS@ @zlib_LIBS@
++LIBS= -lsnet @LIBS@ @pam_LIBS@ @ssl_LIBS@ @zlib_LIBS@
+ LDFLAGS= -Llibsnet/.libs @LDFLAGS@ ${LIBS}
+ INSTALL= @INSTALL@
+
+ CFLAGS= ${DEFS} ${OPTOPTS} ${INCPATH} \
+- @ssl_CFLAGS@ @zlib_CFLAGS@ @CFLAGS@
++ @pam_CFLAGS@ @ssl_CFLAGS@ @zlib_CFLAGS@ @CFLAGS@
+
+ BINTARGETS= fsdiff ktcheck lapply lcksum lcreate lmerge lfdiff repo \
+ twhich lsort
+diff --git a/configure.ac b/configure.ac
+index 60a56fb..8c9b916 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -56,6 +56,25 @@ CFLAGS="$HOST_CFLAGS -Werror"
+ AC_HEADER_MAJOR
+ CFLAGS="$SAVED_CFLAGS"
+
++# Enable features.
++
++AC_ARG_ENABLE([pam],
++ AS_HELP_STRING([--enable-pam], [Build with pam @<:@default=yes@:>@]),
++ [AS_CASE(${enableval}, [yes], [], [no], [],
++ [AC_MSG_ERROR([bad value '${enableval}' for --enable-pam])])],
++ [enable_pam=check])
++
++AC_ARG_ENABLE([ssl],
++ AS_HELP_STRING([--enable-ssl], [Build with openssl @<:@default=yes@:>@]),
++ [AS_CASE(${enableval}, [yes], [], [no], [],
++ [AC_MSG_ERROR([bad value '${enableval}' for --enable-ssl])])],
++ [enable_ssl=check])
++
++AC_ARG_ENABLE([zlib],
++ AS_HELP_STRING([--enable-zlib], [Build with zlib @<:@default=yes@:>@]),
++ [AS_CASE(${enableval}, [yes], [], [no], [],
++ [AC_MSG_ERROR([bad value '${enableval}' for --enable-zlib])])],
++ [enable_zlib=check])
+
+ # Checks for libraries.
+ AC_CHECK_LIB(c, inet_aton, libc_inet_aton=yes)
+@@ -69,35 +88,65 @@ fi
+ AC_CHECK_LIB(nsl, gethostbyaddr)
+ AC_CHECK_LIB([socket], [socket])
+
+-PKG_CHECK_MODULES([ssl], [openssl],
+- [AC_DEFINE([HAVE_LIBSSL], [1], [libssl])])
+-AC_SUBST([ssl_LIBS])
+-AC_SUBST([ssl_CFLAGS])
++# Checks for pam.
++AS_IF([test x$enable_pam != xno],
++ [PKG_CHECK_MODULES([pam], [pam],
++ [AC_CHECK_HEADERS([pam/pam_appl.h],
++ [], [AC_CHECK_HEADERS([security/pam_appl.h])])]
++ [AC_DEFINE([HAVE_LIBPAM], [1], [libpam])],
++ [AS_IF([test x$enable_pam != xyes],
++ [AC_MSG_WARN([cannot find pam.pc, disabling pam support])],
++ [enable_pam=error])
++ ])
++ ])
++
++AS_IF([test x$enable_pam = xerror],
++ [AC_MSG_ERROR([cannot find pam.pc and pam support requested])])
++
++AM_CONDITIONAL([ENABLE_PAM], [test x$enable_pam = xyes])
++AC_SUBST([pam_CFLAGS])
++AC_SUBST([pam_LIBS])
++
++# Checks for openssl.
++AS_IF([test x$enable_ssl != xno],
++ [PKG_CHECK_MODULES([ssl], [openssl],
++ [AC_DEFINE([HAVE_LIBSSL], [1], [libssl])],
++ [AS_IF([test x$enable_ssl != xyes],
++ [AC_MSG_WARN([cannot find openssl.pc, disabling libssl support])],
++ [enable_ssl=error])
++ ])
++ ])
+
+ AC_CHECK_HEADER([openssl/ssl.h], [], [AC_MSG_ERROR([header file <openssl/ssl.h>
+ is required for this software. You may be running RedHat 9. If so, see the FAQ or the README for further instructions.])])
+ AC_CHECK_LIB([crypto], [X509_VERIFY_PARAM_set_flags], [AC_DEFINE([HAVE_X509_VERIFY_PARAM], [], [X509_verify_param])])
+
+-# PAM
+-AC_ARG_WITH([pam], AC_HELP_STRING([--with-pam=PATH], [Pluggable Authentication Module support (default: /usr)]), [], with_pam=/usr)
+-if test x_"$with_pam" != x_no; then
+- CPPFLAGS="${CPPFLAGS} -I$with_pam/include"
+- AC_CHECK_LIB([pam], [pam_start],
+- [
+- AC_CHECK_HEADERS(pam/pam_appl.h, , [AC_CHECK_HEADERS(security/pam_appl.h)])
+- AC_DEFINE([HAVE_LIBPAM], [], [libpam])
+- LIBS="$LIBS -lpam";
+- ]
+- )
+-fi
++AS_IF([test x$enable_ssl = xerror],
++ [AC_MSG_ERROR([cannot find openssl.pc and libssl support requested])])
++
++AM_CONDITIONAL([ENABLE_LIBSSL], [test x$enable_ssl = xyes])
++AC_SUBST([ssl_CFLAGS])
++AC_SUBST([ssl_LIBS])
++
+ AC_CHECK_HEADER([dns_sd.h], [AC_DEFINE([HAVE_DNSSD], [], [dnssd])])
+ AC_CHECK_LIB(dns_sd, DNSServiceRegister)
+
+-PKG_CHECK_MODULES([zlib], [zlib],
+- [AC_DEFINE([HAVE_ZLIB], [1], [zlib])],
+- [AC_MSG_WARN(zlib.pc not found, building without zlib support)])
+-AC_SUBST([zlib_LIBS])
++# Checks for zlib.
++AS_IF([test x$enable_zlib != xno],
++ [PKG_CHECK_MODULES([zlib], [zlib],
++ [AC_DEFINE([HAVE_ZLIB], [1], [zlib])],
++ [AS_IF([test x$enable_zlib != xyes],
++ [AC_MSG_WARN([cannot find zlib.pc, disabling zlib support])],
++ [enable_zlib=error])
++ ])
++ ])
++
++AS_IF([test x$enable_zlib = xerror],
++ [AC_MSG_ERROR([cannot find zlib.pc and zlib support requested])])
++
++AM_CONDITIONAL([ENABLE_ZLIB], [test x$enable_zlib = xyes])
+ AC_SUBST([zlib_CFLAGS])
++AC_SUBST([zlib_LIBS])
+
+ # HPUX lacks wait4 and strtoll
+ AC_CHECK_FUNCS(wait4 strtoll)
+--
+2.35.1
+
diff --git a/app-admin/radmind/metadata.xml b/app-admin/radmind/metadata.xml
index e980be75a6a5..4bf7c59e8555 100644
--- a/app-admin/radmind/metadata.xml
+++ b/app-admin/radmind/metadata.xml
@@ -5,6 +5,7 @@
<longdescription>A suite of Unix command-line tools and a server designed to remotely administer
the file systems of multiple Unix machines.</longdescription>
<upstream>
+ <remote-id type="github">Radmind/radmind</remote-id>
<remote-id type="sourceforge">radmind</remote-id>
</upstream>
</pkgmetadata>
diff --git a/app-admin/radmind/radmind-1.15.3-r1.ebuild b/app-admin/radmind/radmind-1.15.3-r1.ebuild
deleted file mode 100644
index 0e948d4f5d21..000000000000
--- a/app-admin/radmind/radmind-1.15.3-r1.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DESCRIPTION="Command-line tools and server to remotely administer multiple Unix filesystems"
-HOMEPAGE="https://github.com/Radmind https://sourceforge.net/projects/radmind/"
-SRC_URI="https://github.com/voretaq7/radmind/releases/download/${P}/${P}.tar.gz"
-
-LICENSE="HPND"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-DEPEND="dev-libs/openssl:0="
-RDEPEND="${DEPEND}
- !dev-util/repo"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.7.0-gentoo.patch
- "${FILESDIR}"/${PN}-1.14.1-glibc225.patch
-)
-
-src_install() {
- default
- keepdir /var/radmind/{cert,client,postapply,preapply}
-}
diff --git a/app-admin/radmind/radmind-1.15.4-r1.ebuild b/app-admin/radmind/radmind-1.15.4-r1.ebuild
new file mode 100644
index 000000000000..99ad31c192c5
--- /dev/null
+++ b/app-admin/radmind/radmind-1.15.4-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Command-line tools and server to remotely administer multiple Unix filesystems"
+HOMEPAGE="https://github.com/Radmind https://sourceforge.net/projects/radmind/"
+SRC_URI="https://github.com/voretaq7/radmind/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="pam zlib"
+
+DEPEND="
+ dev-libs/openssl:0=
+ net-libs/libnsl
+ pam? ( sys-libs/pam )
+ zlib? ( sys-libs/zlib )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.7.0-gentoo.patch
+ "${FILESDIR}"/${PN}-1.14.1-glibc225.patch
+ # 779664
+ "${FILESDIR}"/${PN}-1.15.4-autoreconf.patch
+ "${FILESDIR}"/${PN}-1.15.4-autoreconf-libsnet.patch
+)
+
+src_prepare() {
+ default
+
+ # We really don't want these
+ # https://github.com/Radmind/radmind/pull/336
+ # https://sourceforge.net/p/libsnet/patches/7/
+ rm -f {,libsnet/}aclocal.m4 || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable pam)
+ $(use_enable zlib)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ keepdir /var/radmind/{cert,client,postapply,preapply}
+}