summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/rex')
-rw-r--r--app-admin/rex/Manifest2
-rw-r--r--app-admin/rex/metadata.xml2
-rw-r--r--app-admin/rex/rex-1.14.3.ebuild (renamed from app-admin/rex/rex-1.13.3.ebuild)15
-rw-r--r--app-admin/rex/rex-9999.ebuild15
4 files changed, 24 insertions, 10 deletions
diff --git a/app-admin/rex/Manifest b/app-admin/rex/Manifest
index 6bac2adedf4d..4ec16dbe7b4d 100644
--- a/app-admin/rex/Manifest
+++ b/app-admin/rex/Manifest
@@ -1 +1 @@
-DIST Rex-1.13.3.tar.gz 349550 BLAKE2B c2ccc2144e56761d33ed2b5d790febd49863639d2e3bba8028b7937b43eb51e7e59e9e99cb1d67f247b2dff8ef91aa04776afd6277ad8a2370f35d71e0b528dd SHA512 beab22aef8ba620b6e74847698eab99977844d2e9632812a9ae0e1ee303cbe4e5a6489000bd5209d76e42e3bb4bb799a90408ed6fb14e034f68132a4d37766dc
+DIST Rex-1.14.3.tar.gz 377627 BLAKE2B 40285856b42488f8b557ee2621c3c4ba1019b014d93e3d2e05c09590cb9d1cfa2738e3588aa8cb102ceb3c645cf5aa8113c279a18e23636ad80db09db0825d19 SHA512 7a64221b76f6949f2c5176adc86af9acaff80e9745ad19bc54ffc93d9542bb3c5250d4c511250a0917afb58b92d7a2cf2b24f6915331237c4e2635a760230b70
diff --git a/app-admin/rex/metadata.xml b/app-admin/rex/metadata.xml
index 3e055b65d18a..ec96a5449c26 100644
--- a/app-admin/rex/metadata.xml
+++ b/app-admin/rex/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person" proxied="yes">
<email>erkiferenc@gmail.com</email>
diff --git a/app-admin/rex/rex-1.13.3.ebuild b/app-admin/rex/rex-1.14.3.ebuild
index cad3166f1de0..1b5ca9f0db12 100644
--- a/app-admin/rex/rex-1.13.3.ebuild
+++ b/app-admin/rex/rex-1.14.3.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
if [[ ${PV} == 9999 ]]; then
GITHUB_USER=RexOps
@@ -21,7 +21,7 @@ fi
inherit bash-completion-r1 perl-module ${VCS_ECLASS}
DESCRIPTION="(R)?ex, the friendly automation framework"
-HOMEPAGE="https://metacpan.org/release/Rex https://www.rexify.org"
+HOMEPAGE="https://metacpan.org/dist/Rex https://www.rexify.org"
SLOT="0"
IUSE="minimal test"
@@ -48,6 +48,7 @@ RDEPEND="
dev-perl/Expect
dev-perl/IPC-Shareable
dev-perl/XML-LibXML
+ net-misc/rsync
)
virtual/perl-Carp
virtual/perl-Data-Dumper
@@ -81,6 +82,7 @@ RDEPEND="
dev-perl/libwww-perl
dev-perl/YAML
virtual/perl-version
+ virtual/perl-Term-ANSIColor
"
# NB: would add test? !minimal? Test-mysqld, but I can't get that to work
BDEPEND="
@@ -91,13 +93,18 @@ BDEPEND="
virtual/perl-Module-Metadata
test? (
!minimal? (
- dev-perl/File-LibMagic
+ || ( dev-perl/File-LibMagic sys-apps/file )
+ dev-vcs/git
)
virtual/perl-File-Temp
+ dev-perl/Sub-Override
dev-perl/Test-Deep
+ dev-perl/Test-Exception
dev-perl/Test-Output
dev-perl/Test-UseAllModules
+ dev-perl/Test-Warnings
virtual/perl-autodie
+ virtual/perl-Module-Load-Conditional
)
"
diff --git a/app-admin/rex/rex-9999.ebuild b/app-admin/rex/rex-9999.ebuild
index cad3166f1de0..1b5ca9f0db12 100644
--- a/app-admin/rex/rex-9999.ebuild
+++ b/app-admin/rex/rex-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
if [[ ${PV} == 9999 ]]; then
GITHUB_USER=RexOps
@@ -21,7 +21,7 @@ fi
inherit bash-completion-r1 perl-module ${VCS_ECLASS}
DESCRIPTION="(R)?ex, the friendly automation framework"
-HOMEPAGE="https://metacpan.org/release/Rex https://www.rexify.org"
+HOMEPAGE="https://metacpan.org/dist/Rex https://www.rexify.org"
SLOT="0"
IUSE="minimal test"
@@ -48,6 +48,7 @@ RDEPEND="
dev-perl/Expect
dev-perl/IPC-Shareable
dev-perl/XML-LibXML
+ net-misc/rsync
)
virtual/perl-Carp
virtual/perl-Data-Dumper
@@ -81,6 +82,7 @@ RDEPEND="
dev-perl/libwww-perl
dev-perl/YAML
virtual/perl-version
+ virtual/perl-Term-ANSIColor
"
# NB: would add test? !minimal? Test-mysqld, but I can't get that to work
BDEPEND="
@@ -91,13 +93,18 @@ BDEPEND="
virtual/perl-Module-Metadata
test? (
!minimal? (
- dev-perl/File-LibMagic
+ || ( dev-perl/File-LibMagic sys-apps/file )
+ dev-vcs/git
)
virtual/perl-File-Temp
+ dev-perl/Sub-Override
dev-perl/Test-Deep
+ dev-perl/Test-Exception
dev-perl/Test-Output
dev-perl/Test-UseAllModules
+ dev-perl/Test-Warnings
virtual/perl-autodie
+ virtual/perl-Module-Load-Conditional
)
"