summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/ryzen_smu/ryzen_smu-0.1.2_p20210627.ebuild')
-rw-r--r--app-admin/ryzen_smu/ryzen_smu-0.1.2_p20210627.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-admin/ryzen_smu/ryzen_smu-0.1.2_p20210627.ebuild b/app-admin/ryzen_smu/ryzen_smu-0.1.2_p20210627.ebuild
new file mode 100644
index 000000000000..6beb7f83fc15
--- /dev/null
+++ b/app-admin/ryzen_smu/ryzen_smu-0.1.2_p20210627.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-mod linux-info toolchain-funcs
+
+SRC_URI="https://dev.gentoo.org/~slashbeast/distfiles/${PN}/${P}.tar.xz"
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Kernel driver for AMD Ryzen's System Management Unit"
+HOMEPAGE="https://github.com/leogx9r/ryzen_smu"
+
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+MODULE_NAMES="ryzen_smu(misc)"
+
+pkg_setup() {
+ linux_config_exists
+
+ linux-mod_pkg_setup
+
+ BUILD_TARGETS="modules"
+ BUILD_PARAMS="CC=$(tc-getCC) KERNEL_BUILD=${KERNEL_DIR}"
+}
+
+src_install() {
+ linux-mod_src_install
+ insinto /usr/lib/modules-load.d/
+ newins "${FILESDIR}"/ryzen_smu.conf ryzen_smu.conf
+
+}