summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/serf/serf-0.8.0.ebuild')
-rw-r--r--app-admin/serf/serf-0.8.0.ebuild105
1 files changed, 0 insertions, 105 deletions
diff --git a/app-admin/serf/serf-0.8.0.ebuild b/app-admin/serf/serf-0.8.0.ebuild
deleted file mode 100644
index e4be0991b391..000000000000
--- a/app-admin/serf/serf-0.8.0.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit systemd user
-
-KEYWORDS="~amd64"
-EGO_PN="github.com/hashicorp/serf"
-DESCRIPTION="Service orchestration and management tool"
-HOMEPAGE="https://www.serfdom.io/"
-SRC_URI="https://github.com/hashicorp/serf/archive/v${PV}.tar.gz -> ${P}.tar.gz
- https://github.com/mitchellh/gox/archive/c9740af9c6574448fd48eb30a71f964014c7a837.tar.gz -> gox-c9740af9c6574448fd48eb30a71f964014c7a837.tar.gz
- https://github.com/mitchellh/iochan/archive/87b45ffd0e9581375c491fef3d32130bb15c5bd7.tar.gz -> iochan-87b45ffd0e9581375c491fef3d32130bb15c5bd7.tar.gz
-"
-
-SLOT="0"
-LICENSE="MPL-2.0"
-IUSE=""
-RESTRICT="test"
-
-DEPEND="
- >=dev-lang/go-1.6:=
- >=dev-go/go-tools-0_pre20160121"
-RDEPEND=""
-
-pkg_setup() {
- enewgroup serf
- enewuser serf -1 -1 /var/lib/${PN} serf
-}
-
-get_archive_go_package() {
- local archive=${1} uri x
- for x in ${SRC_URI}; do
- if [[ ${x} == http* ]]; then
- uri=${x}
- elif [[ ${x} == ${archive} ]]; then
- break
- fi
- done
- uri=${uri#https://}
- echo ${uri%/archive/*}
-}
-
-unpack_go_packages() {
- local go_package x
- # Unpack packages to appropriate locations for GOPATH
- for x in ${A}; do
- unpack ${x}
- if [[ ${x} == *.tar.gz ]]; then
- go_package=$(get_archive_go_package ${x})
- mkdir -p src/${go_package%/*}
- mv ${go_package##*/}-* src/${go_package} || die
- fi
- done
-}
-
-src_unpack() {
- mkdir "${S}" || die
- cd "${S}" || die
- unpack_go_packages
-}
-
-src_prepare() {
- eapply_user
- # Avoid the need to have a git checkout
- sed -e 's:^GIT.*::' \
- -e 's:-X main.GitCommit.*:" \\:' \
- -i "${S}/src/${EGO_PN}/scripts/build.sh" || die
-
- # go install golang.org/x/tools/cmd/stringer: mkdir /usr/lib/go-gentoo/bin/: permission denied
- sed -e 's:go get -u -v $(GOTOOLS)::' \
- -e 's:^GIT.*::' \
- -i "${S}/src/${EGO_PN}/GNUmakefile" || die
-}
-
-src_compile() {
- export GOPATH="${S}"
- go install -v -work -x ${EGO_BUILD_FLAGS} "github.com/mitchellh/gox/..." || die
- # The dev target sets causes build.sh to set appropriate XC_OS
- # and XC_ARCH, and skips generation of an unused zip file,
- # avoiding a dependency on app-arch/zip.
- PATH=${PATH}:${S}/bin \
- emake -C "${S}/src/${EGO_PN}" dev
-}
-
-src_install() {
- local x
-
- dobin "${S}/bin/${PN}"
-
- keepdir /etc/serf.d
- insinto /etc/serf.d
-
- for x in /var/{lib,log}/${PN}; do
- keepdir "${x}"
- fowners serf:serf "${x}"
- done
-
- newinitd "${FILESDIR}/serf.initd" "${PN}"
- newconfd "${FILESDIR}/serf.confd" "${PN}"
- insinto /etc/logrotate.d
- newins "${FILESDIR}/${PN}.logrotated" "${PN}"
- systemd_dounit "${FILESDIR}/serf.service"
-}