summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/supervisor')
-rw-r--r--app-admin/supervisor/Manifest1
-rw-r--r--app-admin/supervisor/files/conf.d4
-rw-r--r--app-admin/supervisor/files/init.d28
-rw-r--r--app-admin/supervisor/files/init.d-r113
-rw-r--r--app-admin/supervisor/metadata.xml8
-rw-r--r--app-admin/supervisor/supervisor-3.1.3.ebuild47
6 files changed, 101 insertions, 0 deletions
diff --git a/app-admin/supervisor/Manifest b/app-admin/supervisor/Manifest
new file mode 100644
index 000000000000..78a6a1775b37
--- /dev/null
+++ b/app-admin/supervisor/Manifest
@@ -0,0 +1 @@
+DIST supervisor-3.1.3.tar.gz 391529 SHA256 e32c546fe8d2a6e079ec4819c49fd24534d4075a58af39118d04367918b3c282 SHA512 40795bfd1aee3eba9e51b6dc1bfcff20c42c0a42ca7ceecc35c428f7840d5d631303b7f0c4eee85375296fd4e9a48f6b405a87caf038f8ffbfe227b5160e7aa5 WHIRLPOOL da8f41907857c46633e93e1806449babd9230994a528c73946276c10387e380763b7b9fb884bb3376537d6eb55428e5873ed8e9a11cd410a3d6c8d7593907552
diff --git a/app-admin/supervisor/files/conf.d b/app-admin/supervisor/files/conf.d
new file mode 100644
index 000000000000..922f4ce4132f
--- /dev/null
+++ b/app-admin/supervisor/files/conf.d
@@ -0,0 +1,4 @@
+# /etc/conf.d/supervisord
+
+# Options to pass to the supervisord process
+SUPD_OPTS=""
diff --git a/app-admin/supervisor/files/init.d b/app-admin/supervisor/files/init.d
new file mode 100644
index 000000000000..91188b7d36f8
--- /dev/null
+++ b/app-admin/supervisor/files/init.d
@@ -0,0 +1,28 @@
+#!/sbin/runscript
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+checkconfig() {
+ if [ ! -f /etc/supervisord.conf ] ; then
+ eerror "Please create /etc/supervisord.conf:"
+ eerror "echo_supervisord_conf >> /etc/supervisord.conf"
+ return 1
+ fi
+ return 0
+}
+
+start() {
+ checkconfig || return $?
+ ebegin "Starting supervisord"
+ start-stop-daemon --start \
+ --exec /usr/bin/supervisord -b --pidfile /var/run/supervisord.pid \
+ -- -n ${SUPD_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping supervisord"
+ start-stop-daemon --stop --pidfile /var/run/supervisord.pid
+ eend $?
+}
diff --git a/app-admin/supervisor/files/init.d-r1 b/app-admin/supervisor/files/init.d-r1
new file mode 100644
index 000000000000..e1bff4f1c92d
--- /dev/null
+++ b/app-admin/supervisor/files/init.d-r1
@@ -0,0 +1,13 @@
+#!/sbin/runscript
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+description="client/server system that allows its users to monitor and control a number of processes on UNIX-like operating systems"
+
+command="/usr/bin/supervisord"
+pidfile="/var/run/supervisord.pid"
+command_args="--nodaemon --pidfile ${pidfile} ${SUPD_OPTS}"
+command_background="yes"
+
+required_files="/etc/supervisord.conf"
diff --git a/app-admin/supervisor/metadata.xml b/app-admin/supervisor/metadata.xml
new file mode 100644
index 000000000000..0d8452b949e9
--- /dev/null
+++ b/app-admin/supervisor/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">supervisor</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-admin/supervisor/supervisor-3.1.3.ebuild b/app-admin/supervisor/supervisor-3.1.3.ebuild
new file mode 100644
index 000000000000..c5791e15c8aa
--- /dev/null
+++ b/app-admin/supervisor/supervisor-3.1.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 ) # py2 only
+# xml.etree.ElementTree module required.
+PYTHON_REQ_USE="xml"
+
+inherit distutils-r1
+
+MY_PV="${PV/_beta/b}"
+
+DESCRIPTION="A system for controlling process state under UNIX"
+HOMEPAGE="http://supervisord.org/ http://pypi.python.org/pypi/supervisor"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="repoze ZPL BSD HPND GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc test"
+
+# ALL versions of meld3 match to >=meld3-0.6.5
+RDEPEND="dev-python/meld3[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+python_compile_all() {
+ # Somehow the test phase is called and run on invoking a doc build; harmless
+ use doc && emake -C docs html
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ newinitd "${FILESDIR}/init.d-r1" supervisord
+ newconfd "${FILESDIR}/conf.d" supervisord
+ use doc && local HTML_DOCS=( docs/.build/html/. )
+ distutils-r1_python_install_all
+}