summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/swatch/swatch-3.2.3-r2.ebuild')
-rw-r--r--app-admin/swatch/swatch-3.2.3-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-admin/swatch/swatch-3.2.3-r2.ebuild b/app-admin/swatch/swatch-3.2.3-r2.ebuild
new file mode 100644
index 000000000000..493fd1c6ce4f
--- /dev/null
+++ b/app-admin/swatch/swatch-3.2.3-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+GENTOO_DEPEND_ON_PERL_SUBSLOT=yes
+inherit perl-app
+
+DESCRIPTION="Perl-based system log watcher"
+HOMEPAGE="http://sourceforge.net/projects/swatch/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="dev-perl/DateManip
+ dev-perl/Date-Calc
+ dev-perl/File-Tail
+ dev-perl/TimeDate
+ >=virtual/perl-Time-HiRes-1.12"
+
+src_install() {
+ emake install
+ newinitd "${FILESDIR}/${PN}-init" "${PN}"
+ newconfd "${FILESDIR}/${PN}-confd" "${PN}"
+ insinto /etc
+ doins "${FILESDIR}/swatchrc"
+}