summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/sxid')
-rw-r--r--app-admin/sxid/sxid-4.2-r3.ebuild (renamed from app-admin/sxid/sxid-4.2-r2.ebuild)21
1 files changed, 12 insertions, 9 deletions
diff --git a/app-admin/sxid/sxid-4.2-r2.ebuild b/app-admin/sxid/sxid-4.2-r3.ebuild
index 8e2f23878d45..42953f3c0b36 100644
--- a/app-admin/sxid/sxid-4.2-r2.ebuild
+++ b/app-admin/sxid/sxid-4.2-r3.ebuild
@@ -1,32 +1,35 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit autotools
DESCRIPTION="suid, sgid file and directory checking"
-HOMEPAGE="http://linukz.org/sxid.shtml https://github.com/taem/sxid"
-SRC_URI="http://linukz.org/download/${P}.tar.gz"
+HOMEPAGE="https://linukz.org/sxid.shtml https://github.com/taem/sxid"
+SRC_URI="https://linukz.org/download/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
+IUSE="selinux"
-RDEPEND="virtual/mailx"
+RDEPEND="
+ virtual/mailx
+ selinux? ( sec-policy/selinux-sxid )
+"
-DOCS=( docs/sxid.{conf,cron}.example )
+DOCS=( NEWS README docs/sxid.{conf,cron}.example )
src_prepare() {
default
# this is an admin application and really requires root to run correctly
# we need to move the binary to the sbin directory
- sed -i s/bindir/sbindir/g source/Makefile.in || die
+ sed -i 's/bindir/sbindir/g' source/Makefile.in || die
+ sed -i -e 's/configure.in/configure.ac/g' Makefile || die
eautoreconf
}
pkg_postinst() {
- elog
elog "You will need to configure sxid.conf for your system using the manpage and example"
- elog
}