summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/system-config-printer')
-rw-r--r--app-admin/system-config-printer/Manifest2
-rw-r--r--app-admin/system-config-printer/files/system-config-printer-1.5.18-fix-debugprint-exception.patch22
-rw-r--r--app-admin/system-config-printer/metadata.xml29
-rw-r--r--app-admin/system-config-printer/system-config-printer-1.5.15.ebuild76
-rw-r--r--app-admin/system-config-printer/system-config-printer-1.5.18-r2.ebuild94
5 files changed, 133 insertions, 90 deletions
diff --git a/app-admin/system-config-printer/Manifest b/app-admin/system-config-printer/Manifest
index 15de7f12123b..12e9f144b7b9 100644
--- a/app-admin/system-config-printer/Manifest
+++ b/app-admin/system-config-printer/Manifest
@@ -1 +1 @@
-DIST system-config-printer-1.5.15.tar.xz 1005764 BLAKE2B 4919c555444829505b09b658ce0fd016ba235260f8c8b4db751e6a511afba5d5975e5f9570f5fe74fc35d158bbf2dd3ece99aa568ec1bb850096e5f12f0fc0b0 SHA512 b992f96f48c54350c11c5c629e77ee4409fe52fb17b386f226a42d532a95e17b6506319dcedeb70c0072555cb9ab464daaae22f295ce3d5181e5f49836f2ae2e
+DIST system-config-printer-1.5.18.tar.xz 1396808 BLAKE2B 910e853829ee876edc597a3103b5ab857b3b8c1cb87096f25213b1088e35d9f4d320dad61f55b530283a7650b07abe028a53b4e144b33b1b66c733cb2caa8011 SHA512 33dc9c52d92f4234e055fb10a99cadd58424dcdb62554797b44bdd5319f1c3662bd2fa33417ac3a3f5ec51216d64e81e1897f3e671eb49f6be34057d7c38f3f4
diff --git a/app-admin/system-config-printer/files/system-config-printer-1.5.18-fix-debugprint-exception.patch b/app-admin/system-config-printer/files/system-config-printer-1.5.18-fix-debugprint-exception.patch
new file mode 100644
index 000000000000..829166ad9d8e
--- /dev/null
+++ b/app-admin/system-config-printer/files/system-config-printer-1.5.18-fix-debugprint-exception.patch
@@ -0,0 +1,22 @@
+From 399b3334d6519639cfe7f1c0457e2475b8ee5230 Mon Sep 17 00:00:00 2001
+From: Zdenek Dohnal <zdohnal@redhat.com>
+Date: Thu, 13 Oct 2022 14:03:37 +0200
+Subject: [PATCH] Fix debugprint() in options.py (fixes #291)
+
+---
+ options.py | 2 +-
+ 1 file changed, 1 insertions(+), 1 deletion(-)
+
+diff --git a/options.py b/options.py
+index d756f98dc..d7c236deb 100644
+--- a/options.py
++++ b/options.py
+@@ -423,7 +423,7 @@ def __init__(self, name, value, supported, on_change):
+ debugprint("Unknown value for %s: %s" % (name, value))
+ debugprint("Choices: %s" % (supported))
+ if len(supported) > 0:
+- debugprint("Selecting from choices:", supported[0])
++ debugprint("Selecting from choices: %s" % supported[0])
+ self.selector.set_active(0)
+ self.selector.connect("changed", self.changed)
+
diff --git a/app-admin/system-config-printer/metadata.xml b/app-admin/system-config-printer/metadata.xml
index ef7c43f6f08a..e34a1cb28469 100644
--- a/app-admin/system-config-printer/metadata.xml
+++ b/app-admin/system-config-printer/metadata.xml
@@ -1,16 +1,19 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="person">
- <email>reavertm@gentoo.org</email>
- <name>Maciej Mrozowski</name>
-</maintainer>
-<maintainer type="project">
- <email>gnome@gentoo.org</email>
- <name>Gentoo GNOME Desktop</name>
-</maintainer>
-<maintainer type="project">
- <email>kde@gentoo.org</email>
- <name>Gentoo KDE Project</name>
-</maintainer>
+ <maintainer type="person">
+ <email>reavertm@gentoo.org</email>
+ <name>Maciej Mrozowski</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>kde@gentoo.org</email>
+ <name>Gentoo KDE Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">OpenPrinting/system-config-printer</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/app-admin/system-config-printer/system-config-printer-1.5.15.ebuild b/app-admin/system-config-printer/system-config-printer-1.5.15.ebuild
deleted file mode 100644
index e2494d75ec08..000000000000
--- a/app-admin/system-config-printer/system-config-printer-1.5.15.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-PYTHON_REQ_USE="xml"
-inherit python-single-r1 systemd xdg
-
-DESCRIPTION="Graphical user interface for CUPS administration"
-HOMEPAGE="https://github.com/OpenPrinting/system-config-printer"
-SRC_URI="https://github.com/OpenPrinting/${PN}/releases/download/v${PV}/${P}.tar.xz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm arm64 ~ia64 ppc ppc64 ~sparc x86"
-IUSE="gnome-keyring policykit"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-# Needs cups running, bug 284005
-RESTRICT="test"
-
-# Additional unhandled dependencies
-# gnome-extra/gnome-packagekit[${PYTHON_USEDEP}] with pygobject:2 ?
-# python samba client: smbc
-# selinux: needed for troubleshooting
-COMMON_DEPEND="${PYTHON_DEPS}
- dev-libs/glib:2
- net-print/cups[dbus]
- virtual/libusb:1
- >=virtual/udev-172
- x11-libs/gtk+:3[introspection]
- x11-libs/libnotify[introspection]
- x11-libs/pango[introspection]
-"
-DEPEND="${COMMON_DEPEND}
- app-text/docbook-xml-dtd:4.1.2
- >=app-text/xmlto-0.0.22
- dev-perl/XML-Parser
- dev-util/desktop-file-utils
- dev-util/intltool
- sys-devel/gettext
- virtual/pkgconfig
-"
-RDEPEND="${COMMON_DEPEND}
- $(python_gen_cond_dep '
- dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
- dev-python/pycairo[${PYTHON_MULTI_USEDEP}]
- dev-python/pycups[${PYTHON_MULTI_USEDEP}]
- dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
- dev-python/requests[${PYTHON_MULTI_USEDEP}]
- dev-python/urllib3[${PYTHON_MULTI_USEDEP}]
- ')
- gnome-keyring? ( app-crypt/libsecret[introspection] )
- policykit? ( net-print/cups-pk-helper )
-"
-
-pkg_setup() {
- python-single-r1_pkg_setup
-}
-
-src_configure() {
- local myeconfargs=(
- --enable-nls
- --with-desktop-vendor=Gentoo
- --with-udev-rules
- --with-systemdsystemunitdir=$(systemd_get_systemunitdir)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
- python_fix_shebang "${ED}"
- python_optimize
-}
diff --git a/app-admin/system-config-printer/system-config-printer-1.5.18-r2.ebuild b/app-admin/system-config-printer/system-config-printer-1.5.18-r2.ebuild
new file mode 100644
index 000000000000..eac1dbdb254b
--- /dev/null
+++ b/app-admin/system-config-printer/system-config-printer-1.5.18-r2.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 systemd udev xdg
+
+DESCRIPTION="Graphical user interface for CUPS administration"
+HOMEPAGE="https://github.com/OpenPrinting/system-config-printer/"
+SRC_URI="
+ https://github.com/OpenPrinting/${PN}/releases/download/v${PV}/${P}.tar.xz
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm arm64 ~ia64 ~loong ppc ppc64 ~riscv ~sparc x86"
+IUSE="keyring policykit"
+# Needs cups running, bug 284005
+RESTRICT="test"
+
+# Additional unhandled dependencies
+# gnome-extra/gnome-packagekit[${PYTHON_USEDEP}] with pygobject:2 ?
+# python samba client: smbc
+# selinux: needed for troubleshooting
+DEPEND="
+ dev-libs/glib:2
+ net-print/cups[dbus]
+ virtual/libusb:1
+ >=virtual/udev-172
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libnotify[introspection]
+ x11-libs/pango[introspection]
+"
+BDEPEND="
+ app-text/docbook-xml-dtd:4.1.2
+ >=app-text/xmlto-0.0.22
+ dev-perl/XML-Parser
+ dev-util/desktop-file-utils
+ >=sys-devel/gettext-0.20
+ virtual/pkgconfig
+"
+RDEPEND="
+ ${DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pycups[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ ')
+ keyring? ( app-crypt/libsecret[introspection] )
+ policykit? ( net-print/cups-pk-helper )
+"
+
+PATCHES=(
+ # git master (1.5.19)
+ "${FILESDIR}/${P}-fix-debugprint-exception.patch"
+)
+
+src_configure() {
+ local myeconfargs=(
+ --with-xmlto
+ --enable-nls
+ --with-desktop-vendor=Gentoo
+ --with-udev-rules
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake PYTHON=:
+ distutils-r1_src_compile
+}
+
+src_install() {
+ emake DESTDIR="${D}" PYTHON=: install
+ python_fix_shebang "${ED}"
+ distutils-r1_src_install
+}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}