summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/system-config-printer')
-rw-r--r--app-admin/system-config-printer/files/system-config-printer-1.5.18-fix-debugprint-exception.patch22
-rw-r--r--app-admin/system-config-printer/system-config-printer-1.5.18-r2.ebuild (renamed from app-admin/system-config-printer/system-config-printer-1.5.18.ebuild)46
2 files changed, 47 insertions, 21 deletions
diff --git a/app-admin/system-config-printer/files/system-config-printer-1.5.18-fix-debugprint-exception.patch b/app-admin/system-config-printer/files/system-config-printer-1.5.18-fix-debugprint-exception.patch
new file mode 100644
index 000000000000..829166ad9d8e
--- /dev/null
+++ b/app-admin/system-config-printer/files/system-config-printer-1.5.18-fix-debugprint-exception.patch
@@ -0,0 +1,22 @@
+From 399b3334d6519639cfe7f1c0457e2475b8ee5230 Mon Sep 17 00:00:00 2001
+From: Zdenek Dohnal <zdohnal@redhat.com>
+Date: Thu, 13 Oct 2022 14:03:37 +0200
+Subject: [PATCH] Fix debugprint() in options.py (fixes #291)
+
+---
+ options.py | 2 +-
+ 1 file changed, 1 insertions(+), 1 deletion(-)
+
+diff --git a/options.py b/options.py
+index d756f98dc..d7c236deb 100644
+--- a/options.py
++++ b/options.py
+@@ -423,7 +423,7 @@ def __init__(self, name, value, supported, on_change):
+ debugprint("Unknown value for %s: %s" % (name, value))
+ debugprint("Choices: %s" % (supported))
+ if len(supported) > 0:
+- debugprint("Selecting from choices:", supported[0])
++ debugprint("Selecting from choices: %s" % supported[0])
+ self.selector.set_active(0)
+ self.selector.connect("changed", self.changed)
+
diff --git a/app-admin/system-config-printer/system-config-printer-1.5.18.ebuild b/app-admin/system-config-printer/system-config-printer-1.5.18-r2.ebuild
index 2d949358637b..eac1dbdb254b 100644
--- a/app-admin/system-config-printer/system-config-printer-1.5.18.ebuild
+++ b/app-admin/system-config-printer/system-config-printer-1.5.18-r2.ebuild
@@ -1,22 +1,25 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
PYTHON_REQ_USE="xml(+)"
-inherit python-single-r1 systemd udev xdg
+
+inherit distutils-r1 systemd udev xdg
DESCRIPTION="Graphical user interface for CUPS administration"
-HOMEPAGE="https://github.com/OpenPrinting/system-config-printer"
-SRC_URI="https://github.com/OpenPrinting/${PN}/releases/download/v${PV}/${P}.tar.xz"
+HOMEPAGE="https://github.com/OpenPrinting/system-config-printer/"
+SRC_URI="
+ https://github.com/OpenPrinting/${PN}/releases/download/v${PV}/${P}.tar.xz
+"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm arm64 ~ia64 ~loong ppc ppc64 ~riscv ~sparc x86"
-IUSE="gnome-keyring policykit"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
+IUSE="keyring policykit"
# Needs cups running, bug 284005
RESTRICT="test"
@@ -24,7 +27,7 @@ RESTRICT="test"
# gnome-extra/gnome-packagekit[${PYTHON_USEDEP}] with pygobject:2 ?
# python samba client: smbc
# selinux: needed for troubleshooting
-COMMON_DEPEND="${PYTHON_DEPS}
+DEPEND="
dev-libs/glib:2
net-print/cups[dbus]
virtual/libusb:1
@@ -33,7 +36,7 @@ COMMON_DEPEND="${PYTHON_DEPS}
x11-libs/libnotify[introspection]
x11-libs/pango[introspection]
"
-DEPEND="${COMMON_DEPEND}
+BDEPEND="
app-text/docbook-xml-dtd:4.1.2
>=app-text/xmlto-0.0.22
dev-perl/XML-Parser
@@ -41,7 +44,8 @@ DEPEND="${COMMON_DEPEND}
>=sys-devel/gettext-0.20
virtual/pkgconfig
"
-RDEPEND="${COMMON_DEPEND}
+RDEPEND="
+ ${DEPEND}
$(python_gen_cond_dep '
dev-python/dbus-python[${PYTHON_USEDEP}]
dev-python/pycairo[${PYTHON_USEDEP}]
@@ -50,13 +54,14 @@ RDEPEND="${COMMON_DEPEND}
dev-python/requests[${PYTHON_USEDEP}]
dev-python/urllib3[${PYTHON_USEDEP}]
')
- gnome-keyring? ( app-crypt/libsecret[introspection] )
+ keyring? ( app-crypt/libsecret[introspection] )
policykit? ( net-print/cups-pk-helper )
"
-pkg_setup() {
- python-single-r1_pkg_setup
-}
+PATCHES=(
+ # git master (1.5.19)
+ "${FILESDIR}/${P}-fix-debugprint-exception.patch"
+)
src_configure() {
local myeconfargs=(
@@ -64,21 +69,20 @@ src_configure() {
--enable-nls
--with-desktop-vendor=Gentoo
--with-udev-rules
- --with-systemdsystemunitdir=$(systemd_get_systemunitdir)
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
)
econf "${myeconfargs[@]}"
}
src_compile() {
- default
- python_optimize cupshelpers
+ emake PYTHON=:
+ distutils-r1_src_compile
}
src_install() {
- default
+ emake DESTDIR="${D}" PYTHON=: install
python_fix_shebang "${ED}"
- python_optimize
- python_domodule cupshelpers
+ distutils-r1_src_install
}
pkg_postinst() {