summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/terraform/terraform-1.2.4.ebuild')
-rw-r--r--app-admin/terraform/terraform-1.2.4.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/app-admin/terraform/terraform-1.2.4.ebuild b/app-admin/terraform/terraform-1.2.4.ebuild
deleted file mode 100644
index 411e61a46d05..000000000000
--- a/app-admin/terraform/terraform-1.2.4.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-inherit go-module
-
-DESCRIPTION="A tool for building, changing, and combining infrastructure safely"
-HOMEPAGE="https://www.terraform.io/"
-SRC_URI="https://github.com/hashicorp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
-
-LICENSE="Apache-2.0 BSD BSD-2 MPL-2.0 MIT ISC"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-
-BDEPEND="dev-go/gox"
-
-RESTRICT="test"
-
-DOCS=( {README,CHANGELOG}.md )
-
-src_compile() {
- export CGO_ENABLED=0
- gox \
- -os=$(go env GOOS) \
- -arch=$(go env GOARCH) \
- -output bin/terraform \
- -verbose \
- . || die
-}
-
-src_install() {
- dobin bin/*
- einstalldocs
-}
-
-pkg_postinst() {
- elog "If you would like to install shell completions please run:"
- elog " terraform -install-autocomplete"
-}