summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/tmpwatch/tmpwatch-2.11-r1.ebuild')
-rw-r--r--app-admin/tmpwatch/tmpwatch-2.11-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-admin/tmpwatch/tmpwatch-2.11-r1.ebuild b/app-admin/tmpwatch/tmpwatch-2.11-r1.ebuild
new file mode 100644
index 000000000000..5a300e412916
--- /dev/null
+++ b/app-admin/tmpwatch/tmpwatch-2.11-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Files which haven't been accessed in a given period of time are removed from specified directories"
+HOMEPAGE="https://fedorahosted.org/tmpwatch/"
+SRC_URI="https://fedorahosted.org/releases/t/m/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="selinux"
+
+RDEPEND="selinux? ( sec-policy/selinux-tmpreaper )"
+DEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-boottime.patch"
+ epatch_user
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ dosbin tmpwatch || die
+ doman tmpwatch.8 || die
+ dodoc ChangeLog NEWS README AUTHORS || die
+
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}/${PN}.cron" "${PN}" || die
+}