summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/tpm/tpm-9999.ebuild')
-rw-r--r--app-admin/tpm/tpm-9999.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-admin/tpm/tpm-9999.ebuild b/app-admin/tpm/tpm-9999.ebuild
new file mode 100644
index 000000000000..dd2b55edef2e
--- /dev/null
+++ b/app-admin/tpm/tpm-9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Tiny password manager"
+HOMEPAGE="https://github.com/nmeum/tpm"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/nmeum/${PN}.git"
+else
+ SRC_URI="https://github.com/nmeum/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="app-crypt/gnupg"
+BDEPEND="dev-lang/perl"
+
+src_install() {
+ emake install DESTDIR="${D}" PREFIX="${EPREFIX}/usr"
+}