summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/usbview')
-rw-r--r--app-admin/usbview/Manifest4
-rw-r--r--app-admin/usbview/metadata.xml10
-rw-r--r--app-admin/usbview/usbview-2.0.ebuild35
-rw-r--r--app-admin/usbview/usbview-3.0.ebuild (renamed from app-admin/usbview/usbview-2.1.ebuild)6
-rw-r--r--app-admin/usbview/usbview-3.1.ebuild25
5 files changed, 33 insertions, 47 deletions
diff --git a/app-admin/usbview/Manifest b/app-admin/usbview/Manifest
index 96a8cfafcba0..ddb1c1d8a7dd 100644
--- a/app-admin/usbview/Manifest
+++ b/app-admin/usbview/Manifest
@@ -1,2 +1,2 @@
-DIST usbview-2.0.tar.gz 366337 BLAKE2B d3ce8f3b97ebb650f7cc8b47d7a4c4b985022811f55b43b41a65aaa120450aa187ce2dfc2671315575dfcbd108b68ca50420145a6c59ab85f7c4fcfc53a233f9 SHA512 87b3d0b0c734c94e5527f19575c0460f5c0b894dac29936a759d573058c9c007ad59c9be32a5c6d485cba258193efe4ca15bdd6f3ca31df321ed230778b5404f
-DIST usbview-2.1.tar.gz 377376 BLAKE2B 76e6a45a31006f7a7b69783b608dd33304a1a3401c784bfdce62079c764795cbd4914b030ca44884f2f9dd14a479bd679be6c1eabd8bc1776a902b4d1446d82f SHA512 7d973eb9ad74e8c0842396e6239ee44d5feab2d3ce412f7c91e18b947604bcf3c2d3dc456bbefc4cd7567a03d9306593b378ce29c3fb3b13eefe75af3f4c14d4
+DIST usbview-3.0.tar.gz 375159 BLAKE2B 3c95e8c1e37c7209f086206305ab22ff7d26868e8b5eeae07111c82f5bc60eccf8d4ba4021cb57d2d299775f6a4ca7c006ebbf41b7ce24baa7b976cab976b565 SHA512 65cfc933eac44e83df48ebc79e9eb85db64f817b9c09b708ba06471d7845ac575cdec1a4a06a5792cb2b8d80b046dadc118200c455a350300b0285b80221aac5
+DIST usbview-3.1.tar.gz 374228 BLAKE2B a0836049c8075831a5fc2c19532870478ea610ba9616d9809a25f6ca39c53e40695f134e794d378d4259dc102fa50e7f730c9bdc00558db1342694e6cc117cad SHA512 edc60d9543e5ebb377d4d1e71b8ca83d055cee9c12270a4d189a19503c12c8574103637fd6b9a13741c6dc9375a80c7c57daf4d6ccf0520d55e843e07be09479
diff --git a/app-admin/usbview/metadata.xml b/app-admin/usbview/metadata.xml
index 9a0cbad9a0eb..d4b9dfd24c64 100644
--- a/app-admin/usbview/metadata.xml
+++ b/app-admin/usbview/metadata.xml
@@ -1,13 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person" proxied="yes">
- <email>telans@posteo.de</email>
- <name>James Beddek</name>
- </maintainer>
- <maintainer type="project" proxied="proxy">
- <name>Proxy Maintainers</name>
- <email>proxy-maint@gentoo.org</email>
+ <maintainer type="person">
+ <email>soap@gentoo.org</email>
+ <name>David Seifert</name>
</maintainer>
<upstream>
<remote-id type="github">gregkh/usbview</remote-id>
diff --git a/app-admin/usbview/usbview-2.0.ebuild b/app-admin/usbview/usbview-2.0.ebuild
deleted file mode 100644
index c8096088021a..000000000000
--- a/app-admin/usbview/usbview-2.0.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit desktop linux-info
-
-DESCRIPTION="Display the topology of devices on the USB bus"
-HOMEPAGE="http://www.kroah.com/linux-usb/"
-SRC_URI="http://www.kroah.com/linux-usb/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~hppa ppc ppc64 sparc x86"
-
-RDEPEND="
- dev-libs/glib:2
- x11-libs/gdk-pixbuf:2
- x11-libs/gtk+:3
-"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-DOCS=( AUTHORS ChangeLog README TODO )
-
-pkg_setup() {
- CONFIG_CHECK="~DEBUG_FS"
- linux-info_pkg_setup
-}
-
-src_install() {
- default
- doicon usb_icon.xpm
- make_desktop_entry ${PN} 'USB Viewer' usb_icon
-}
diff --git a/app-admin/usbview/usbview-2.1.ebuild b/app-admin/usbview/usbview-3.0.ebuild
index e5d607ada575..c1a37d825fc9 100644
--- a/app-admin/usbview/usbview-2.1.ebuild
+++ b/app-admin/usbview/usbview-3.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit linux-info
+inherit linux-info xdg
DESCRIPTION="Display the topology of devices on the USB bus"
HOMEPAGE="http://www.kroah.com/linux-usb/ https://github.com/gregkh/usbview"
@@ -11,7 +11,7 @@ SRC_URI="http://www.kroah.com/linux-usb/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="~alpha amd64 ~hppa ppc ppc64 sparc x86"
RDEPEND="
dev-libs/glib:2
diff --git a/app-admin/usbview/usbview-3.1.ebuild b/app-admin/usbview/usbview-3.1.ebuild
new file mode 100644
index 000000000000..0a78c3e5780f
--- /dev/null
+++ b/app-admin/usbview/usbview-3.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info xdg
+
+DESCRIPTION="Display the topology of devices on the USB bus"
+HOMEPAGE="http://www.kroah.com/linux-usb/ https://github.com/gregkh/usbview"
+SRC_URI="http://www.kroah.com/linux-usb/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~hppa ppc ppc64 sparc x86"
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/imagemagick-tools[png,svg]
+ virtual/pkgconfig"
+
+CONFIG_CHECK="~DEBUG_FS"