summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/whowatch')
-rw-r--r--app-admin/whowatch/files/whowatch-1.8.4-configure-clang16.patch24
-rw-r--r--app-admin/whowatch/metadata.xml8
-rw-r--r--app-admin/whowatch/whowatch-1.8.6-r2.ebuild (renamed from app-admin/whowatch/whowatch-1.8.6.ebuild)18
-rw-r--r--app-admin/whowatch/whowatch-99999.ebuild36
4 files changed, 37 insertions, 49 deletions
diff --git a/app-admin/whowatch/files/whowatch-1.8.4-configure-clang16.patch b/app-admin/whowatch/files/whowatch-1.8.4-configure-clang16.patch
new file mode 100644
index 000000000000..243a1e543a0c
--- /dev/null
+++ b/app-admin/whowatch/files/whowatch-1.8.4-configure-clang16.patch
@@ -0,0 +1,24 @@
+https://github.com/mtsuszycki/whowatch/pull/12
+
+From 62688e7316de7d4c80591f83afc97d55d73ad272 Mon Sep 17 00:00:00 2001
+From: Florian Weimer <fweimer@redhat.com>
+Date: Sat, 26 Nov 2022 17:45:23 +0100
+Subject: [PATCH] configure.ac: Do not call undeclared exit function
+
+Implicit function declarations were removed from the C language in
+1999, and future compilers are likely to treat them as errors by
+default.
+--- a/configure.ac
++++ b/configure.ac
+@@ -120,8 +120,8 @@ fd_set rfds;
+ struct timeval tv = {1, 0};
+ FD_ZERO(&rfds); FD_SET(0,&rfds);
+ select(1,&rfds,0,0,&tv);
+-if(tv.tv_sec == 0) exit(0);
+-else exit(1);
++if(tv.tv_sec == 0) return 0;
++else return 1;
+ }
+ ]])],[AC_MSG_RESULT(yes); AC_DEFINE([RETURN_TV_IN_SELECT],[1],[define if select() modifies the time value])],[AC_MSG_RESULT(no)],[AC_MSG_RESULT(no)])
+
+
diff --git a/app-admin/whowatch/metadata.xml b/app-admin/whowatch/metadata.xml
index f156c871d6ec..fab25be381f0 100644
--- a/app-admin/whowatch/metadata.xml
+++ b/app-admin/whowatch/metadata.xml
@@ -1,11 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>polynomial-c@gentoo.org</email>
- <name>Lars Wendler</name>
- </maintainer>
+ <!-- maintainer-needed -->
<longdescription>
A interactive who program that displays information about the users currently logged into the machine.
</longdescription>
+ <upstream>
+ <remote-id type="github">mtsuszycki/whowatch</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/app-admin/whowatch/whowatch-1.8.6.ebuild b/app-admin/whowatch/whowatch-1.8.6-r2.ebuild
index 83d9bef99ca5..bc6d1d06f686 100644
--- a/app-admin/whowatch/whowatch-1.8.6.ebuild
+++ b/app-admin/whowatch/whowatch-1.8.6-r2.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
inherit autotools
DESCRIPTION="Displays information about users currently logged on in real time"
@@ -12,19 +13,18 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm ~hppa ~mips ppc x86"
-RDEPEND="
- sys-libs/ncurses:0=
-"
-DEPEND="
- ${RDEPEND}
- virtual/pkgconfig
-"
+RDEPEND="sys-libs/ncurses:="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
PATCHES=(
"${FILESDIR}"/${PN}-1.8.4-tinfo.patch
+ "${FILESDIR}"/${PN}-1.8.4-configure-clang16.patch
)
src_prepare() {
default
+
eautoreconf
}
diff --git a/app-admin/whowatch/whowatch-99999.ebuild b/app-admin/whowatch/whowatch-99999.ebuild
deleted file mode 100644
index 73c452f9523b..000000000000
--- a/app-admin/whowatch/whowatch-99999.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit autotools desktop git-r3
-
-DESCRIPTION="Displays information about users currently logged on in real time"
-HOMEPAGE="http://wizard.ae.krakow.pl/~mike/ https://github.com/mtsuszycki/whowatch/"
-EGIT_REPO_URI="https://github.com/mtsuszycki/${PN}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS=""
-
-RDEPEND="
- sys-libs/ncurses:0=
-"
-DEPEND="
- ${RDEPEND}
- virtual/pkgconfig
-"
-PATCHES=(
- "${FILESDIR}"/${PN}-1.8.4-tinfo.patch
-)
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_install() {
- dobin src/${PN}
- doman ${PN}.1
- dodoc AUTHORS ChangeLog.old NEWS PLUGINS.readme README.md TODO
- domenu ${PN}.desktop
-}