summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/xtail/files')
-rw-r--r--app-admin/xtail/files/xtail-2.1_p8-fix-limits-musl.patch28
-rw-r--r--app-admin/xtail/files/xtail-2.1_p8-fix-prototype.patch20
-rw-r--r--app-admin/xtail/files/xtail-2.1_p8-rename-configure.patch23
3 files changed, 71 insertions, 0 deletions
diff --git a/app-admin/xtail/files/xtail-2.1_p8-fix-limits-musl.patch b/app-admin/xtail/files/xtail-2.1_p8-fix-limits-musl.patch
new file mode 100644
index 000000000000..c9a7ca3f2f5d
--- /dev/null
+++ b/app-admin/xtail/files/xtail-2.1_p8-fix-limits-musl.patch
@@ -0,0 +1,28 @@
+From: Sam James <sam@gentoo.org>
+Subject: [PATCH] Fix build on musl
+
+Closes: https://bugs.gentoo.org/715876
+--- a/miscfuncs.c
++++ b/miscfuncs.c
+@@ -8,6 +8,8 @@
+ #include <ctype.h>
+ #include <fcntl.h>
+ #include <errno.h>
++#include <limits.h>
++
+ #ifdef HAVE_UNISTD_H
+ # include <unistd.h>
+ #endif
+@@ -65,7 +67,11 @@ int scan_directory(const char *dirname)
+ char *basename;
+ struct stat sbuf;
+ DIR *dirp;
+- static char pathname[MAXNAMLEN];
++ #ifdef NAME_MAX
++ static char pathname[NAME_MAX];
++ #else
++ static char pathname[MAXNAMLEN]
++ #endif
+
+ Dprintf(stderr, ">>> scanning directory '%s'\n", dirname);
+ if ((dirp = opendir(dirname)) == NULL)
diff --git a/app-admin/xtail/files/xtail-2.1_p8-fix-prototype.patch b/app-admin/xtail/files/xtail-2.1_p8-fix-prototype.patch
new file mode 100644
index 000000000000..29eff229772f
--- /dev/null
+++ b/app-admin/xtail/files/xtail-2.1_p8-fix-prototype.patch
@@ -0,0 +1,20 @@
+From: Sam James <sam@gentoo.org>
+Subject: [PATCH] Fix -Wdeprecated-non-prototype
+
+xtail.c:365:22: warning: a function declaration without a prototype is deprecated in all versions of C and is treated as a zero-parameter prototype in C2x, conflicting with a previous declaration [-Wdeprecated-non-prototype]
+ extern unsigned sleep();
+ ^
+/usr/include/unistd.h:464:21: note: conflicting prototype is here
+extern unsigned int sleep (unsigned int __seconds);
+ ^
+1 warning generated.
+--- a/xtail.c
++++ b/xtail.c
+@@ -362,7 +362,6 @@ int main(int argc, char *argv[])
+ * End of checking loop.
+ */
+ {
+- extern unsigned sleep();
+ (void) fflush(stdout);
+ (void) sleep(SLEEP_TIME);
+ }
diff --git a/app-admin/xtail/files/xtail-2.1_p8-rename-configure.patch b/app-admin/xtail/files/xtail-2.1_p8-rename-configure.patch
new file mode 100644
index 000000000000..56d3372aceda
--- /dev/null
+++ b/app-admin/xtail/files/xtail-2.1_p8-rename-configure.patch
@@ -0,0 +1,23 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -25,7 +25,7 @@ CFLAGS = @CFLAGS@ $(DEFS)
+ TARBALL = xtail.tar
+ XTAIL_OBJECTS = xtail.o entryfuncs.o miscfuncs.o
+ DISTFILES = Makefile.in README acconfig.h config.h.in configure \
+- configure.in entryfuncs.c install-sh miscfuncs.c xtail.1 xtail.c \
++ configure.ac entryfuncs.c install-sh miscfuncs.c xtail.1 xtail.c \
+ xtail.h
+
+ ###
+@@ -70,9 +70,9 @@ Makefile : $(srcdir)/Makefile.in config.status
+ #config.h : $(srcdir)/config.h.in config.status
+ # CONFIG_FILES= CONFIG_HEADERS=$@ $(SHELL) ./config.status
+
+-$(srcdir)/configure : $(srcdir)/configure.in
++$(srcdir)/configure : $(srcdir)/configure.ac
+ cd $(srcdir) && autoconf
+
+-$(srcdir)/config.h.in : $(srcdir)/configure.in $(srcdir)/acconfig.h
++$(srcdir)/config.h.in : $(srcdir)/configure.ac $(srcdir)/acconfig.h
+ cd $(srcdir) && autoheader
+