summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/afio/afio-2.5.1-r2.ebuild')
-rw-r--r--app-arch/afio/afio-2.5.1-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-arch/afio/afio-2.5.1-r2.ebuild b/app-arch/afio/afio-2.5.1-r2.ebuild
new file mode 100644
index 000000000000..fced7417de80
--- /dev/null
+++ b/app-arch/afio/afio-2.5.1-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="Afio creates cpio-format archives."
+HOMEPAGE="http://members.chello.nl/k.holtman/afio.html https://github.com/kholtman/afio"
+SRC_URI="http://members.chello.nl/k.holtman/${P}.tgz"
+
+LICENSE="Artistic LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.5.1-fix-build-system.patch
+ "${FILESDIR}"/${PN}-2.5.1-control-file-warning-fix.patch
+)
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ dobin "${PN}"
+ doman "${PN}.1"
+ dodoc ANNOUNCE-* HISTORY README SCRIPTS
+
+ local i
+ for i in {1..4}; do
+ docinto "script${i}"
+ dodoc -r "script${i}"/.
+ done
+}